cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1489
Views
0
Helpful
2
Replies

Prefix numbers calling a modem

Hi, we need to place calls to a GSM modem and we need to prefix 999 to the called number, but I have no clue it thats possible,The calls that have to prefix 999 are the ones going out the interface Serial3/6:15 using

line 2/77 2/107

session-timeout 2  output

script connection COSME

modem InOut

modem autoconfigure type COSME

modem dialout controller 3/6

rotary 5 round-robin

transport input all

transport output all

escape-character NONE

telnet transparent

thats the whole running.

CL2_D_-1_COM_RT17#sh run
Building configuration...

Current configuration : 8531 bytes
!
! Last configuration change at 09:43:21 MET Tue Dec 18 2012 by naturalcorzc1
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CL2_D_-1_COM_RT17
!
boot-start-marker
boot system flash c5350-is-mz.124-10c.bin
no boot startup-test
boot-end-marker
!
logging buffered 32000 debugging
enable secret 5 $1$fpLi$CpGL0ERbXS.7fI0atevtx1
!
!
!
resource-pool disable
aaa new-model
!
!
aaa authentication login default none
aaa authentication login RADIUS_UFINET group radius local
aaa authorization exec RADIUS_UFINET group radius if-authenticated
!
aaa session-id common
clock timezone MET 1
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 2:00
calltracker enable
calltracker call-record verbose
calltracker timestamp msec
spe default-firmware spe-firmware-1
!
!
ip cef
no ip domain lookup
!
!
isdn switch-type primary-net5
chat-script COSME ABORT ERROR ABORT BUSY "" "AT&FS29=8S57=9600S64=0" OK \c
modemcap entry COSME:FD=&F:AA=S0=1:CD=&C1:DTR=&D2:NEC=E0:NRS=Q1:ONH=H0:OFH=H1
!
!
!
!
!
!
!
!
!
!
!
!
call-history-mib retain-timer 500
call-history-mib max-size 150
!
username ufinet privilege 15 password 7 000C470055555812
username ciscoworks password 7 15111C5E507A7A747D
archive
log config
  hidekeys
!
!
controller E1 3/0
pri-group timeslots 1-31
!
controller E1 3/1
pri-group timeslots 1-31
!
controller E1 3/2
pri-group timeslots 1-31
!
controller E1 3/3
pri-group timeslots 1-31
!
controller E1 3/4
pri-group timeslots 1-31
!
controller E1 3/5
pri-group timeslots 1-31
!
controller E1 3/6
pri-group timeslots 1-31
!
controller E1 3/7
pri-group timeslots 1-31
!
!
!
!
!
!
!
interface FastEthernet0/0
description gestion
ip address 10.200.255.13 255.255.255.192
ip access-group 99 in
ip access-group 98 out
duplex auto
speed auto
!
interface FastEthernet0/1
description CNX_CPD_CPII
ip address 192.168.253.168 255.255.255.192
duplex full
speed 100
standby 11 ip 192.168.253.170
standby 11 priority 95
standby 11 preempt
standby 11 track Serial3/0:15
standby 11 track Serial3/1:15
standby 11 track Serial3/2:15
standby 11 track Serial3/3:15
standby 11 track Serial3/4:15
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface Serial3/0
no ip address
shutdown
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
interface Serial3/0:15
description PRI_COSME_1_CL2
no ip address
encapsulation ppp
isdn switch-type primary-net5
isdn calling-number 89999
no isdn outgoing ie facility
no isdn outgoing ie progress-indicator
no isdn outgoing ie network-facility
no isdn outgoing ie notify-indicator
no isdn outgoing display-ie
no isdn outgoing ie low-layer-compat
no isdn outgoing ie high-layer-compat
no isdn outgoing ie user-user
no isdn v110 padding
!
interface Serial3/1:15
description PRI_COSME_2_CL2
no ip address
encapsulation ppp
isdn switch-type primary-net5
isdn calling-number 89999
no isdn outgoing ie facility
no isdn outgoing ie progress-indicator
no isdn outgoing ie network-facility
no isdn outgoing ie notify-indicator
no isdn outgoing display-ie
no isdn outgoing ie low-layer-compat
no isdn outgoing ie high-layer-compat
no isdn outgoing ie user-user
no isdn v110 padding
!
interface Serial3/2:15
description PRI_COSME_3_CL2
no ip address
encapsulation ppp
isdn switch-type primary-net5
isdn calling-number 89999
no isdn outgoing ie facility
no isdn outgoing ie progress-indicator
no isdn outgoing ie network-facility
no isdn outgoing ie notify-indicator
no isdn outgoing display-ie
no isdn outgoing ie low-layer-compat
no isdn outgoing ie high-layer-compat
no isdn outgoing ie user-user
no isdn v110 padding
!
interface Serial3/3:15
description PRI_COSME_4_CL2
no ip address
encapsulation ppp
isdn switch-type primary-net5
isdn calling-number 89999
no isdn outgoing ie facility
no isdn outgoing ie progress-indicator
no isdn outgoing ie network-facility
no isdn outgoing ie notify-indicator
no isdn outgoing display-ie
no isdn outgoing ie low-layer-compat
no isdn outgoing ie high-layer-compat
no isdn outgoing ie user-user
no isdn v110 padding
!
interface Serial3/4:15
description PRI_COSME_5_CL2
no ip address
encapsulation ppp
isdn switch-type primary-net5
isdn calling-number 89999
no isdn outgoing ie facility
no isdn outgoing ie progress-indicator
no isdn outgoing ie network-facility
no isdn outgoing ie notify-indicator
no isdn outgoing display-ie
no isdn outgoing ie low-layer-compat
no isdn outgoing ie high-layer-compat
no isdn outgoing ie user-user
no isdn v110 padding
!
interface Serial3/5:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
no isdn v110 padding
!
interface Serial3/6:15
description PRI_COSME_7_CL2
no ip address
encapsulation ppp
isdn switch-type primary-net5
isdn calling-number 89997
no isdn outgoing ie facility
no isdn outgoing ie progress-indicator
no isdn outgoing ie network-facility
no isdn outgoing ie notify-indicator
no isdn outgoing display-ie
no isdn outgoing ie low-layer-compat
no isdn outgoing ie high-layer-compat
no isdn outgoing ie user-user
no isdn v110 padding
ppp authentication chap
!
interface Serial3/7:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
no isdn outgoing ie facility
no isdn outgoing ie progress-indicator
no isdn outgoing ie network-facility
no isdn outgoing ie notify-indicator
no isdn outgoing display-ie
no isdn outgoing ie low-layer-compat
no isdn outgoing ie high-layer-compat
no isdn outgoing ie user-user
no isdn v110 padding
no cdp enable
!
interface Group-Async0
no ip address
encapsulation ppp
async mode interactive
group-range 1/00 2/45
!
interface Group-Async1
no ip address
encapsulation ppp
async mode interactive
group-range 2/46 2/76
!
interface Group-Async2
no ip address
encapsulation ppp
async mode interactive
group-range 2/77 2/107
!
!
ip route 0.0.0.0 0.0.0.0 192.168.253.130
ip route 10.132.2.128 255.255.255.192 10.200.255.1
no ip http server
!
!
logging trap errors
logging 10.132.2.132
access-list 98 remark SoloGestion
access-list 98 permit 10.200.255.13
access-list 99 remark SoloGestion
access-list 99 permit 10.109.3.0 0.0.0.255
access-list 99 permit 10.132.2.128 0.0.0.127
access-list 99 permit 10.200.255.0 0.0.0.255
snmp-server community uficor RW 99
snmp-server ifindex persist
snmp-server location CERRO PLATA NUEVO COSME
snmp-server contact UFICOR-Ext.21000
snmp-server system-shutdown
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server host 10.132.2.131 version 2c uficor
snmp-server host 10.132.2.144 version 2c uficor
snmp-server host 10.132.2.190 version 2c uficor
!
!
radius-server host 10.132.2.144 auth-port 1645 acct-port 1646
radius-server host 10.132.2.185 auth-port 1645 acct-port 1646
radius-server host 10.132.2.190 auth-port 1645 acct-port 1646
radius-server retransmit 2
radius-server timeout 1
radius-server deadtime 15
radius-server key 7 130D43145A02573E
!
control-plane
!
!
!
voice-port 3/0:D
!
voice-port 3/1:D
!
voice-port 3/2:D
!
voice-port 3/3:D
!
voice-port 3/4:D
!
voice-port 3/5:D
!
voice-port 3/6:D
!
voice-port 3/7:D
!
!
!
!
ss7 mtp2-variant Bellcore 0
ss7 mtp2-variant Bellcore 1
ss7 mtp2-variant Bellcore 2
ss7 mtp2-variant Bellcore 3
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
exec-timeout 60 0
logging synchronous
login authentication RADIUS_UFINET
line vty 5 15
exec-timeout 60 0
logging synchronous
login authentication RADIUS_UFINET
line 1/00 2/45
session-timeout 2  output
script connection COSME
modem InOut
modem autoconfigure type COSME
modem dialout controller 3/0-3/4
rotary 1 round-robin
transport input all
transport output all
escape-character NONE
telnet transparent
line 2/46 2/76
session-timeout 2  output
script connection COSME
modem InOut
modem autoconfigure type COSME
modem dialout controller 3/5
rotary 4 round-robin
transport input all
transport output all
escape-character NONE
telnet transparent
line 2/77 2/107
session-timeout 2  output
script connection COSME
modem InOut
modem autoconfigure type COSME
modem dialout controller 3/6
rotary 5 round-robin
transport input all
transport output all
escape-character NONE
telnet transparent
!
scheduler allocate 10000 400
ntp clock-period 17179976
ntp update-calendar
ntp server 10.132.2.131 prefer
ntp peer 192.168.253.164
ntp server 10.132.2.190
end

Thanks in advance

Cesar

1 Accepted Solution

Accepted Solutions

I'm not sure but you can try to use a translation rule under voice-port.

The interface Serial3/6:15 is connected to voice-port 3/6:D so you can try this:

voice translation-rule 10

rule 1 /^\(.*\)/ /999\1/

voice translation-profile ADD_CALLED_PREFIX

translate called 10

voice-port 3/6:D

translation-profile incoming ADD_CALLED_PREFIX

More details about translation rule are here:

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080325e8e.shtml

Regards.

View solution in original post

2 Replies 2

I'm not sure but you can try to use a translation rule under voice-port.

The interface Serial3/6:15 is connected to voice-port 3/6:D so you can try this:

voice translation-rule 10

rule 1 /^\(.*\)/ /999\1/

voice translation-profile ADD_CALLED_PREFIX

translate called 10

voice-port 3/6:D

translation-profile incoming ADD_CALLED_PREFIX

More details about translation rule are here:

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080325e8e.shtml

Regards.

Thanks for your help, we already applied a different solution , given to us by the provider, so i wont be able to test that one. but Thanks for your time.

Regards

Cesar