Showing results for 
Search instead for 
Did you mean: 

RTP Traffic not seen with debug IP packet


We placed a Debug Ip Packet detail in ACL (any to host destination) but RTP traffic wasn´t see.

Rtp session is stablished and debug rtp packets is a hard debug. Debug ip rtp ip and port is not enough information about packet.

Sniffer is not possible at customer site.

Do you have any idea for check with debug IP Packet?


5 Replies 5


Have you tried the suggested PCM capture procedure from Cisco below:

# config t

# voice hpi capture buffer 3000000        ( to configure the capture buffer.)

# voice hpi capture destination flash:pcm.dat   (to specify the destination file.)

Once you have the above configured you are ready to capture the PCM stream from the router.  Start a test call and leave it connected.

1.  Enter "show voice call status" and determine what voice port a trouble call is using.

2.  Enter "test voice port 1/0/4 pcm-dump caplog 7" where 1/0/4 is the number of the port that has the problem call up.

- You can check the status of the capture using the following command: sh voice hpi capture

- Make sure you have capture the whole duration of the problem call.  Then stop the capture, enter "test voice port 1/0/4 pcm-dump disable"

- When you are done capturing, just enter configure terminal again and do the following:

  no voice hpi capture destination flash:pcm.dat

  no voice hpi capture buffer 300000

Following that, email the capture file pcm.dat to TAC for further analysis.


The suggestion to use the (new in IOS) built in capability to capture traffic on the router is a good suggestion and I believe that you would do well to give it a try. But to answer your original issue - the reason that you were not seeing debug output is that debug can only report on traffic that is process switched in the router CPU. When traffic is CEF switched (or any other type of enhanced forwarding processing which bypasses the router CPU) then debug does not see those packets and can not report them. So to get the output in debug you would need to turn off CEF on the interface where the traffic arrives on the router. Note that there would be some performance impact from doing this, so be very careful on a production router.





Hi Richard,

Cef was disable an TCP traffic in this IP was seen as traffic, but not UDP traffic is seen and not RTP traffic.





May be RTP traffic goes to other IP (for example the client use NAT, and RTP sends to private IP). Or may be you use ACL  with TCP parametr(can you show ACL)?

We upgraded IOIS version for that question, RTP traffic was not sended...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers