cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3417
Views
0
Helpful
2
Replies

unable to call from pstn to h323 gateway (incoming calls)

techguy
Enthusiast
Enthusiast

I have configured CUE and i can call from internal and can listen the greeting message. but when i call from any other pstn number to main line (2811 cisco router acting as h323 Voice Gateway) calls have been dropped.

I call from ip phone to pstn (outgoing is ok) but problem is in incoming call.

Any clue???

CONFIGURATION is as below

boot-start-marker

boot-end-marker

!

card type e1 0 2

logging message-counter syslog

enable secret 5 $1$7SY2$Zwgh/Il4qYxg9DOFHpST.1

!

no aaa new-model

clock timezone GMT 4

network-clock-participate wic 2

network-clock-select 1 E1 0/2/0

!

dot11 syslog

ip source-route

!

!

ip cef

!

!

!

no ip domain lookup

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

!

voice call send-alert

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

h323

sip

  bind control source-interface Loopback101

  bind media source-interface Loopback101

  registrar server

!

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 g729r8

!

!

!

!

voice class h323 1

  h225 timeout tcp establish 3

!

!

!

!

!

!

!

!

!

!

voice register global

mode cme

source-address 10.1.211.1 port 5060

max-dn 100

authenticate register

!

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

application

global

  service alternate default

!

!

log config

  hidekeys

!

!

!

!

!

controller E1 0/2/0

framing NO-CRC4

pri-group timeslots 1-10,16

!

!

!

!

!

interface Loopback101

ip address 10.1.211.1 255.255.255.192

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.1.211.1

!

!

interface Serial0/2/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Integrated-Service-Engine1/0

ip unnumbered Loopback101

service-module ip address 10.1.211.62 255.255.255.192

service-module ip default-gateway 10.1.211.1

no keepalive

!

router eigrp 1

network 172.16.40.0 0.0.0.3

network 172.16.250.24 0.0.0.3

network 192.168.84.0

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 172.16.40.1

ip route 10.1.211.62 255.255.255.255 Integrated-Service-Engine1/0

ip route 172.16.250.12 255.255.255.252 172.16.250.25

ip route 172.16.250.28 255.255.255.252 172.16.250.25

no ip http server

no ip http secure-server

!

!

!!

!

control-plane

!

call fallback active

!

!

voice-port 0/2/0:15

bearer-cap Speech

!

no ccm-manager fax protocol cisco

!

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp fax t38 ecm

!

sccp local Loopback101

sccp ccm 10.50.2.3 identifier 1 version 7.0

sccp ccm 10.50.2.4 identifier 2 version 7.0

sccp

!

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 10 pots

tone ringback alert-no-PI

description International

destination-pattern 900.T

fax rate disable

port 0/2/0:15

prefix 00

!

dial-peer voice 11 pots

tone ringback alert-no-PI

description Emergency

destination-pattern 9600....

fax rate disable

port 0/2/0:15

prefix 600

!

dial-peer voice 12 pots

tone ringback alert-no-PI

description Emergency

destination-pattern 9800....

fax rate disable

port 0/2/0:15

prefix 800

!

dial-peer voice 13 pots

tone ringback alert-no-PI

description Mobile

destination-pattern 905........

fax rate disable

port 0/2/0:15

prefix 05

!

dial-peer voice 14 pots

tone ringback alert-no-PI

description National

destination-pattern 90[234678].......

fax rate disable

port 0/2/0:15

prefix 0

!

dial-peer voice 15 pots

tone ringback alert-no-PI

description Local

destination-pattern 9.......

fax rate disable

port 0/2/0:15

!

dial-peer voice 16 pots

tone ringback alert-no-PI

description Emergency

destination-pattern 9...

fax rate disable

port 0/2/0:15

!

dial-peer voice 100 voip

description To CallManager Pub

preference 1

destination-pattern [789]..

voice-class codec 1

voice-class h323 1

session target ipv4:10.50.2.3

dtmf-relay h245-alphanumeric

req-qos guaranteed-delay audio

acc-qos guaranteed-delay audio

fax-relay ecm disable

fax rate 14400

fax nsf 000000

fax protocol pass-through g711ulaw

no vad

!

dial-peer voice 200 voip

description To CallManager Sub

huntstop

preference 2

destination-pattern [789]..

voice-class codec 1

voice-class h323 1

session target ipv4:10.50.2.4

dtmf-relay h245-alphanumeric

req-qos guaranteed-delay audio

acc-qos guaranteed-delay audio

fax-relay ecm disable

fax rate 14400

fax nsf 000000

fax protocol pass-through g711ulaw

no vad

!

!

gateway

timer receive-rtp 1200

!

!

!

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-consult

ip source-address 10.1.211.1 port 2000

max-ephones 42

max-dn 144

!

!

line con 0

speed 115200

line aux 0

line 66

no activation-character

no exec

transport preferred none

transport input all

transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

password xxxxxx

login

!

scheduler allocate 20000 1000

ntp server 89.188.26.129

end

2 Replies 2

steve.hammes
Enthusiast
Enthusiast

To make sure, are you having problems with all inbound calls, or just to the CUE pilot?  I don't see a voip dial-peer configured to connect calls to the service engine.  I've included an example below that may help.

dial-peer voice 300 voip

description CUE Voicemail Pilot

destination-pattern *YOUR CUE PILOT*

session protocol sipv2

session target ipv4:10.1.211.62

dtmf-relay sip-notify

codec g711ulaw

no vad

If you're having problems with inbound calls in general, can you post a 'debug isdn q931' so we can verify the calls are hitting your gateway and the telco is sending the correct number of digits?

--

Steve H.

Thnx for ur reply...can we do the same by creating translation rules??? If so, then what will be the rule

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers