cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
296
Views
0
Helpful
1
Replies

Voip over a specified path

dathaide
Level 1
Level 1

hi

I have two links from a remote site to corporate. I want Voip to travel on one link and am using a route map statement however not seeming my voice going over the link. When i do a show ip route-map voice don't see the packet count incrementing when making a call.

below is the relevant configuration

access-list 101 permit udp any any range 16384 32767 log

access-list 101 permit tcp any any eq 1720 log

!

route-map voice permit 10

match ip address 101

set ip next-hop 1.1.1.1

The route map is being applied to the serial interface i want the voice traffic to take.

any suggestions on how i will be able to make sure my voice traffic takes the specified path

thanks

1 Reply 1

pacameron
Level 4
Level 4

A better way to do this is to use static routes and loopback addresses.

On the first router create a loopback interface and use the h323 bind command to source the voip traffic from this interface -

interface loopback 0

ip address 10.1.1.1 255.255.255.0

h323-gateway voip bind srcaddr 10.1.1.1

assume we have 2 serial ports -

interface serial 1/0

ip address 20.1.1.1 255.255.255.0

!

interface serial 1/1

ip address 20.1.2.1 255.255.255.0

We then create 2 static routes with different metrics to point to the remote router's loopback interface (which has an IP address of 11.1.1.1) via the next hop address of the serial ports

ip route 11.1.1.1 255.255.255.255 20.1.1.2 50

ip route 11.1.1.1 255.255.255.255 20.1.2.2 100

The first static route will be prefered over the second because of the lower metric, so the traffic will go via serial 1/0. If the first link fails, the second floating static route will kick in and the traffic will be rerouted, so it gives an element of redundancy.

You then point your VOIP dial peers to the remote loopback IP address.

This approach gets around the need for route maps and potential issues with load balancing over equal cost paths.

The remote router has a similar config (loopbacks and static routes) that points back to the main site router.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: