Showing results for 
Search instead for 
Did you mean: 

Bug in the latest spa3XX-5XXG phone firmware 7.5.6 - Can not transfer anonymous calls

william Jin
Level 1
Level 1

Hi support,

I just found a bug in the latest phone firmware 7.5.6.


Linux Debian Wheezy

Asterisk 11.7

FreePBX 2.11

Affected Cisco phone model: SPA504G and SPA514G(I only tested these two models)

The issue is when there is an incoming call with anonymous caller id, after picking up the call, the xfer and bxfer softkeys are missing. On the first page, only conf softkey(3rd place out of four softkeys). After pressing the right arrow, it's redial, dir, blank(used to be bxfer) and dnd.

TS has been done.

Tested with other phones brand, yealink, snom and mitel, all working.

Tested with firmware 7.5.5b, all working.

Tested with latest firmware 7.5.6, xfer and bxfer softkeys are missing.

I read the firmware upgrade note of 7.5.6 and found below:

CSCuh25063 The SPA5x5 phone has the ability to hide Xfer/Bxfer softKeys after initial network configuration.

Maybe it's related? pure guess. Does that mean we should have the ability to un-hide Xfer/Bxfer softkeys? HOW?


I am not requesting to fix this as soon as possible. My customers are happy after downgrading to 7.5.5b. But if it can be fixed in the next available firmware, that would be great.



William Jin

30 Replies 30

Any release date for 7.5.7?  Can you provide any additional detail about how I would get the patched version of 7.5.6?


I notice that 7.5.6a has been released - does this fix the issue? I'm not familiar with what the letters following the version number mean.

So quick response from me:

Read release notes. If it mention it, you know the answer. If it doesn't mention or released notes doesn't exist at all, try it - it's simple. Let us know the results, then ...


More detailed response (supplemented later):  Release notes of 7.5.6 and 7.5.6a firmware are identical with following exceptions:

Resolved issues listed in 7.5.6 RN but not in 7.5.6a RN:

CSCun77435,CSCuo52582 - e.g. code execution and cross site scripting vulnerabilities

Does it mean regression and 7.5.6a firmware is vulnerable to those attacks again ? I don't know. It's worrying possibility, a lot.


Resolved issues listed in 7.5.6a RN but not in 7.5.6 RN:

CSCuq63643 - phone freezes on making call if DNS SRV and Auto Register enabled


CSCuh25063 is still mentioned in Resolved Issues list, but no CSCuq18187 listed here. It may mean the issue is not resolved.

It's not mentioned in Open Issues as well. It mean you should not trust completeness of Release Notes so much. Issue may or may not be resolved.

Try it. Let us know the results, then ... ;-)


According yours "I'm not familiar with what the letters following the version number mean" ...

... it may mean just troubles. According documentation (Provisioning Guide), version numbers take the form of three non-negative numbers separated by period plus an optional alphanumeric string in parentheses. Version 7.5.6a doesn't follow such definition. It's important for provisioning profile's conditional expressions. For integers and version numbers, the operators lt,le,gt,ge are defined, for generic strings only = and != can be used.

If 7.5.6a will not be recognized as valid version number, conditional expression with lt,le,gt,ge operators will not work properly. Downgrade Rev Limit may not work as well.

In previous firmwares, version numbers with letters not enclosed has not been identified as version numbers so processed accordingly. I didn't tested 7.5.6a so I don't know it will work correctly or not. Try it. Let us know the results ... ;-)

See also Version-style conditional expressions broken on XU image

After much back and forth with support and some testing - I'll share with you what I have found out.


7.5.6a does NOT contain a fix for the issue.

You must get the patched version of 7.5.6 from support to get this fix.

The patched version is just based off 7.5.6, not 7.5.6a - so if there's a fix in 7.5.6a you also need - you'll have to decide which you need more.

The full fix is due in 7.5.7 which is due out yet this year.

In short - 7.5.6 firmware has been released with severe bugs. Customers willing to pay for special support are allowed to ask for special release with issue A solved.

Later, firmware with issue B solved become available to public. Issue A is not solved within it, despite know (including solution).

Customers with support contract are required to call support again, asking for firmware with both issues corrected - and wait for them.

Well. I can accept that customers not willing to pay must to wait for solutions. It's business. But customers spending money for not so cheap support should not call for firmware with ALL known solutions embedded.

Great promotion of Cisco's paid support program ...

Well, I should calm down or I my VIP status will be fired ;-)

Thank you, Ryan, for the informations.



Hello Ryan,

Firmware 7.5.7 has been scheduled for late Feb 2015. If someone needs an immediate fix for this issue, we have an Engineering Special which is based on 7.5.6a.





Hi Shilpa,

Please could you explain how we get access to the engineering special firmware?



Hello Kurt,

Please open a service request and request the Engineers to provide the following ES firmware.



These Engineering Special images for spa51x and 50x were built on the 7.5.6a code base. Beta Trail Agreement Form needs to be signed and returned prior to the firmware publishing (will be published by the Engineer). 




I don't have a service contract, I bought these phones off a third party site. How do I get this fix that was supposed to be out months ago.

Any update on the release date for 7.5.7? 

Running into this problem too. Any update on the release date for 7.5.7?

How to get the ES-release?


Level 1
Level 1

Based on CSCuq18187, it should be fixed since February 18, but I can't find firmware 7.5.7 (yet?) on


See New release of cisco SPA50X firmware. Despite it's dedicated to other bug, the conclusions related to release date apply here as well.


Hi All,


7.5.7 is available for download in It has been posted on the 23rd.




Distinctive ringtones do not work on 7.5.7 though 3CX. Form memory this was also the case with 7.5.6.


Can confirm that it works with 7.5.5.b