Showing results for 
Search instead for 
Did you mean: 

CUE Backup fail on update and manual CLI

Thomas Gruendler

Been having an issue with one of my UC560's.  I am trying to get them updated as they are on CUE7.1 and they are wanting to use the free Smart Call Connector Toolbar which is only available with CUE 8.x and up.  Well, here is my issue.  While trying to do a backup which I do with every update, it keeps failing.  Tried CCA 3.01 and 3.1 and getting the same results.  So, opened a case with SBCS a few weeks back and they wanted me to try to do it through CLI, which I finally tried lst night and keep getting a failure of the Voicemail Data backup:

Data: Failure Script execution failed: Voicemail Backup failed

So, after talking with the CS agent, he said there is nothing that can be done and just run the update through CCA and if anything goes wrong, all I would lose is the voicemail data.  Well, I cannot take this risk.  There has to be a way for me to get a backup of my clients data before doing an update.  Has anybody had the error above for the CUE backup thorugh CLI or does anybody know of a workaround of backing up the data?

13 Replies 13

David Trad
Rising star
Rising star

Hi Thomas,

Not much solace in my advise but you could try the following scenarios:

  1. Since you are on the CUE 7.1 version, you should in theory also still have the older CUE web GUI as well, if this is the case you try doing the backup through that, this at times has the ability to get past the nasty script error (Which by the way was most prevalent in the 7.0.X and 7.1 train). Just make sure you have all the right ftp settings when setting it up
  2. physically power down the machine wait 10-20 seconds and then power it back up, with CUE version 7.1 it could take up too 12 minutes for it to load and settle completly, in that time you do not want any calls processing or any attempts being made to the CUE (Suggest after hours work maybe??) This can stop that script error and can let you use CCA to do the update
  3. Manually backup the CUE running configuration, you will loose all the personalised setup of each mail box and any store voice mails, but you can atleast restore it if something goes wrong with a forced update.
  4. Stage the update do not go straight to 8.2 SWP maybe go to SWP 8.1 first so the leap in revisions is not high, this can at times retain the data even if there is an error

That is all I have to offer, but I will reiterate you may need to be prepared to loose some data, once CUE gets into a bit of a rut, it is hard to get it out of it (Sounds bad I know, but its just the facts).

Good luck and I hope you can do it without any problems to the config.



Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *


In CUE system, there is a database running.

So I really do not suggest user just power down unit by pull out power cord.

Doing that could corrupt database structure.

I would suggest performing "service-module int 0/0 reload" from IOS prompt.

That will take down database gracefully first and reload the unit.

In fact, we are suspect that the cause of Data backup failure is due to database corrupted.

However, we have not come to conclusion yet.

For SWP upgrade, each upgrade is a "clean" installation if using CCA. so straight to SWP 8.2 should be fine.

Please open a case if you have Data backup issue.

Afert you experienced the backup failure, please collect CUE log files and attached to the case.

In CCA 3.0 onward, there is an utility to collect all CUE related logs.

In CCA, Troubleshoot ->CUE diagnostics --> CUE Connectivity Diagnostics -> click the "Generate Logs".

CCA will generate all CUE logs to the directory you assigned.

Zip them all and attached to the case.

David Liao

Thanks David and David.

Answer to David Trad's suggestions:

1.  Tried 3 backup methods.  CCA, CLI, and the Web GUI for CUE.  All 3 failed at the data backup of the Voicemail.

2.  I have tried reloading the CUE only and still get the error.  I will try tonight to reload the entire box, unhook the PRI and all phones and see if that will work.

3.  I have the manual backups of the config, timecard view, etc...  I still couldn't get a straight answer from the SBCS tech on what the Voicemail Backup contained so I could let my client know what possibly he could lose.

4.  Might try this if all else fails, which might lessen the chances of losing data.

David Liao:

I did open a case and the support "engineer" did not request CUE logs so I will do this and attach it to my case.  He pretty much told me I was s**t out of luck and just do the upgrade and hope for the best after about 30 minutes of very simple troubleshooting steps that I had pretty much already performed.  Getting more information in the forums than from one of Cisco Small Business Support "Engineers" is very disheartening in SBCS.

Hello Thomas,

Best case scenario for this problem is a routing configuration issue.  From your PC can you ping and when logged into CUE can you ping the ip address of your PC.  If it goes beyond that it may be as David L suggest a database problem. 


What CLI to use to generate the CUE logs you mentioned if using CCA is not an option ?



If CCA isn't an option you may need to call in and have an engineer run the necessary traces and collect your messages.log and atrace.log.  The traces are going to depend on which module/entity of cue you have issues with.


With due respect, have you ever looked at the log files being generated by CCA / CUE Diagnostics / CUE connectivity diagnostics feature ? They are not module/entity oriented.


Log files are generated by CUE system as part of debugging files...such as messages.log and atrace_save.log.

If you can access to CUE console, the following cli can be used to copy out logs.

However, you need to have ftp server running and accessible by CUE.

In CUE prompt...

CUE-prompt> show logs (will output all available logs in system)

CUE-prompt> copy log messages.log url ftp://uid:pwd@a.b.c.d/(sub-dir-if-any)/messages.log

This cli will copy out messages.log out to ftp location.


Assuming you have uid:abc,  pwd:xyz and ftp ip:

you can copy out messages.log to ftp home dir using the following cli

CUE-prompt>copy log messages.log url ftp://abc:xyz@

Got it. Thanks for taking the time to reply on a Saturday.

Hi Jon,

If all else fails, I would be willing to log on remotely (SSH) to look into your problem and see if I can assist you in anyway way.



Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *


It is Ok. Thanks for your offer to assist, David.

Will running these logs from CCA take the CUE offline?  Just wondering if I can do it during the day or have to wait until after hours.  I want to attach these to the case to see if I can get something going on the error and not just tough luck.

Hi, Thomas:

From CCA to take those logs can be done in real time, no need to take CUE offline.

However, You would hope those error messages are included in the logs when you take them out.

So, in this case for backup failed.

I would suggest that you repro the issue first and then take those logs out.



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers