Showing results for 
Search instead for 
Did you mean: 

How to Update SPA504G Firmware using a Mac


I am able to update SPA504G firmware using a PC on Win-7 just fine.

I am asking this question on behalf of a client, who says they can't follow the instructions I gave them for updating firmware on his SPA504G using his  Mac computer, because he says he can't run the .exe on a Mac.

I don't use a Mac, so I don't know the answer to their question.  Can anyone shed some light on this for me?  Should the firmware run the same on a Mac as it does on a PC?  Or, is there some other option?



10 Replies 10


After doing a little research, I now understand that people who use Macs can install software that will allow them to either dual boot in Windows or Mac OSx.

So, I guess, more specifically, I'm asking if Cisco provides firmware updates in Mac OSx compatible format? 

Thanks, Jeff

Can you not just upload the *.bin firmware file to a host then just add the url under the provisioning tab?

For example upload firmware.bin to then log in to via it's ip address then under the provisioning tab make sure firmware upgrade is enabled and add under the upgrade rule.

That should update the phone without the need to run any .exe files.

Paul, I don't know if the person I'm trying to advise (who uses a Mac) will be able to do as you suggest.  However, I thought this would be an interesting exercise for me to try myself just to see if I can get it to work.

I tried your suggestion on all three of my devices, with no success (PAP2T, SPA2102, and SPA504G)...?

Once I have uploaded the .bin file(s) to my web site, are you saying that the only setting change I need to make is to just enter the exact path to the uploaded file in the field "Upgrade Rule" ?  This doesn't seem to enable the upgrade procedure on any of my devices that I tried it on (even after a manual power off/on reset).  Upgrade Enable is set to "yes" (the default). 


My original path was using https://.  So, I just changed it to http:// on the spa504g, and this time the LCD display has the message: "Upgrading Firmware, Please do not turn off power...".  Problem is, all my registration lights stay green, and no lights are blinking to indicate an upgrade is in progress.  Then after a few minutes, or so, the LCD display returns back to normal display (Upgrade message dissappears).  All is normal, but spa504g did not do a firmware upgrade....?

Actually, my spa504g already has latest firmware at 7.5.3.  So, I'm trying to downgrade back to 7.5.2b, just to test out this procedure.

Message was edited by: Jeff Bourgeois

Sounds like your getting there, i have some pap2t's and some spa525g2's setup for remote provisioning as well as firmware upgrades. Works fine!

Make sure your using the correct protocol i.e. Http, https or tftp for example and that the device is not already on the latest firmware. You may have to wait a while until the countdown clock expires too before the device runs the command to update the firmware.

You probably already sorted it by now. :)

This is just one of those days things just don't work.

I could'nt even get the 504g to do a manual downgrade using the local .exe for 7.5.2b.  Then, finally I tried to locally downgrade to ver. 7.5.1a .... and this worked.

But, when I try to upgrade back to 7.5.2b over the web from my website, the spa504g does the exact same thing it did earlier:  It says it is upgrading on its LCD display, but the line LED's remain registered (green) and nothing blinks like it should while upgrading.  Finally, after about 5 minutes, the LCD display reverts back to normal display.  It did not actually perform the download and install. 

So, for some reason, it just isn't downloading the file.  Yet, I can manually download the file to my PC, from the web, using the exact URL I configue into the spa504g.  So, I don't know why it won't complete the web firmware upgrade....?

Are you sure the firmware file 7.5.2b is not corrupt? delete it and re-download the file from cisco.

Seems odd that you could not downgrade to 7.5.2b locally using the .exe file, but could using 7.5.1a. failing that your phone may need a factory reset.

The upgrade rule i use is:

The Upgrade_Error_Retry_Delay value is set at 120 and the Downgrade_Rev_Limit is 7.5.3 on mine but this value you should leave blank as it stops the phone from allowing a lesser version than 7.5.3 being installed.

I re-downloaded all last three available firmware versions for spa504G.  Then, re-uploaded them to my web site.

I locally upgraded the SPA504G back to 7.5.2b.  Then, once again configured the phone's Upgrade_Rule  to retrieve the path to latest FW version at:


Same as previous numerous times I tried:  The phone just displays "Upgrading Firmware, Please do not unplug power...".  But, no LED's flash.  It just sits there doing nothing (as far as I can tell).  Finally, after some period of time... it returns to normal display.  No upgrade.

I've now spent far too many hours on this trying to get this to work.  I give up.

Thanks for your suggestions, Paul.


I found this post while searching google on how to upgrade my phone's firmware, were you ultimately successful doing it remotely? I'ts not working on my 508G, Thanks, Ric

There has been two upgrade methods mentioned in this thread. One of them is OS independent.

You didn't disclosed what method you has used.

Also "it's not working" is so vague issue description. No way to give you a valuable advice.

This thread saved my evening from turning into a nightmare

I own a mac and I didn't want to start messing with windows based systems again

I wanted an easy way to upgrade my cisco IP phone and would like to thank all that contributed in this thread

Using a website host link I managed to upgrade my phone to the latest 2017 firmware without any issues......


Simply upload the *.bin firmware file to a host then just add the url under the provisioning tab?

For example http//

Log in to the phone via it's ip address
then under the provisioning tab make sure firmware upgrade is enabled and add under the upgrade rule.
Once you apply the settings the phone will restart and the firmware update will start DO NOT remove the power

It will take a few minutes depending on the size of file please be patient

That should update the phone without the need to run any .exe files.

....all your settings will remain intact

Word of warning do not upgrade to the very latest firmware first
You may have to upgrade in stages
If you have anything less than 7-5-2b then you may have to upgrade to 7-5-2b first then you can to the the very latest from there...

Always read the pdf files accompanying the firmware this may change after 2017

Glad I found this thread

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: