Showing results for 
Search instead for 
Did you mean: 

Inbound Calls to Generic Sip Trunk Fail


Hi, I have a UC540 setup with a Cisco 837 in bridge mode so the dsl internet connection is setup on the UC540 and the firewall is disabled.

I have a generic sip trunk setup with a ITSP here in South Africa called FNB Connect, registration and outbound calls work fine but no incomming calls come through.

It immediatly go the the voicemail of my service provider saying " The extension bla bla bla is unavailable."

I'm using a internet service provider with a dynamic ip addres.

The are using the following ports for incomming calls:

udp 5060

udp 4569

tcp 46448

tcp 46449

Can anyone please go over the config and debugs for me as I am really tired of strugling, any help will be much appreciated.

Thank you in advance...

11 Replies 11



The call is coming in and not matching an incoming dial peer.  The called number is not showing up on the trace.  I see you have an incoming dial peer, but you have fax protocols on it.

I would take this off of dial-peer 1000:

fax rate 14400

fax protocol t38 (ect).

I also see that you are trying to for g729 on the phone that your route is attached to.  Are you sure that your provider supports this codec?

I would also take out

voice source-group CCA_SIP_SOURCE_GROUP_CUE_CME


And lock down my firewall manually.  Those two lines of code have cause me (and others) more headache than they are worth.  Use your inbound ACL on your main interface to lock down port 5060 to your provider only.  Block everything else on TCP and UDP 5061 and TCP 5060.

Thank you for the quick reply, but I removed the fax protocols but still no incomming calls.

Acording to their website the support the G729 codec.

Any other idee's?


I think I edited my post above after you read.  Take out the voice source-group's.  They have caused major issues for me in the past.  They are, however, a security setting.  Once you take them out, lock down your firewall to your providers IP address on udp 5060 (and any other ports they use), then close traffic to TCP 5060, and UDP and TCP 5061.

Once you do this, can you get another trace?

Ok I removed the 2 lines...

voice source-group CCA_SIP_SOURCE_GROUP_CUE_CME


But still no incomming calls....

Can you take another debug ccapi voice inout trace please?

On your dial-peer 1000 do this:

session target sip-server

Instead of

session target ipv4:

I changed but still nothing...

I have attached a debug whith no incomming or outgoing calls...      

The problem I'm seeing is that the called number isn't making it through to be analyzed by a dial-peer.  I don't see anything on your configuration that would cause this.  There must be something different about the South African dial plan.  Do you have access to Cisco TAC?

If so, I would open a case to see if they have a bug ID or something on this issue.

No I don't think so I just bought the uc as nfr demo equipment.

But thank you for your help though...

You should be able to call TAC and open a case.  I know we were able to (way back when) we configured our nfr demo.  I would try it.  All they can do is say no.    Sorry I wasn't able to get this resolved.

What I can see regarding incomming calls is when I make a call from the service providers soft phone application to my cell phone number it shows as +27877339727

How would I set a dial peer for a + E.164 number?

But it also look like there is no incomming traffic at all....i setup another sip trunk with a diferent service provider and there is no incomming voice trafic.

Shouldn't I set nat rules or something?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: