Showing results for 
Search instead for 
Did you mean: 

Multi-Level AA


   I am trying to get the multi-level AA working on my UC 500

I have a base AA at ext 298

I configure option 3 to send to submenu1

This submenu appears to be created as 2981

But when you call 298 opt 3 you get dead air for about 10 seconds then disconnects

Never plays prompt, pressing keys do not yield desired results etc.

Any ideas?

This is my first UC, so maybe I am just lost.

17 Replies 17

Saurabh Verma

I'm assuming that you are using CCA to configure this. What version of CCA are you using? Can you capture the screen from CCA and send over? Did you use a prompt for the sub-menu? How was this prompt created?



Using CCA 2

I have uploaded several prompts, and have tried several, including the one that I am using for the top level menu, none of them work.

Not sure how to enable other than have the first menu call the second.

I have notices that the help file says this level 2 AA should use the aa_transfer2 script, but I cannot find such a script on my UC, only the aa_transfer script exists.

When you view from CLI, the autoattendant2 does not list a script or any actions or anything


What options do you have under submenu 1? After selecting the options did you hit on "OK" or "APPLY"? Also, if you close CCA and relaunch, does it detect the Auto Attendant main menu and sub menu configuration? It will be good to look at the CCA logs when you are configuring AA. Can you share that? The log files are located at "C:\Program Files\Cisco Systems\CiscoSMB\Cisco Configuration Assistant". Capture the latest one after you make the changes (look at the file timestamp to be sure).


Yes I click apply and oK the settings are saved,I can close out and come back to them etc.BUT, if I reboot then it just comes back as standard and not multi-level.


This is probably because the device configuration was not saved prior to the reboot. In the new CCA release 2.1, when you exit out of CCA, it will prompt you to save the configuration. Can you post the application logs for Auto Attendant configuration? Make sure to capture the log file after the "OK" or "APPLY" operation is completed.



I will work on getting the logs later, but I SPECIFICALLY saved the config from the CCA BEFORE I rebooted.

Here are logs.  BTW I have downloaded the new CCA2.1  Did not change anything,

I found quite a few errors in the logs. One particular one that caught my attention was an error related to FTP Server. Can you make sure that you don't have any other FTP server running on the system? One way to find if you are running any ftp server is to execute the "netstat -a"command from a DOS prompt.

I have contacted the CCA engineering team look at the logs and root cause the issue. In the meanwhile, can you check the ftp server? Also please check if you are running a compatible version of Java. Check the release notes of CCA 2.1



AN FTP Server running where?  On the computer(s)  use CCA?  I have no FTP server running on any of the computers running CCA

I have configured this thing from 3 different computers using 2.01 and now 1 of those computers running 2.1

Ok, can you check the Java version on these machines? I noticed some errors related to Java Virtual machine: Unrecognized Windows Sockets error: 0: JVM_Bind

I will update you on the analysis from the CCA engineering team.



I dont see anywhere in this document where it lists compatible java versions.

This computer, the one i have tried using CCA 2.0.1 and 2.1 is running Java 6 u15

Engineering team looked at the log file and it appears it didn't have the Auto Attendant configuration steps captured. Is it possible to restore the system to factory default and capture the logs right after configuring the Auto Attendant feature?


I think I will contact TAC before I do a factory reset.


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers