Showing results for 
Search instead for 
Did you mean: 

Multi-site printing issue

John Carney
Level 1
Level 1

This may not initially sound like a UC500 issue, but please be patient with the description.

I have a customer that has 2 sites, primary and secondary. They were initially connected via vpn using ASA5505, and all phones registered to a single UC540. Printing was working just fine between sites, as, a session at the primary site was able to print with no issues to the secondary site.

I recently had to reconfigure the environment to have a UC520 at the secondary site. I did this using the Multi-site manager, and that's when some of my problems started. Thin client traffic is working fine, and voice between the 2 sites is stable, including transferring calls and voicemails between sites. The problem I am having is printing.

I have 2 HP printers at the secondary site. I can browse to the control panel on one of the printers at the secondary site from the primary site without issues. I cannot browse to the other printer from the primary site, however, I can get to it from a device on the secondary site. I tried to re-install the print drivers on the server at the primary site for the printer at the secondary site, and it failed every time. I had to move the printer to the primary site to get the drivers to install properly. I did not have this issue when I was using the 5505's for vpn.

Now, I'm having issues trying to print to the printer at the secondary site again. For some reason, it fails, even though all other traffic, including http, seem to be working fine. It seems to me that something in the firewall settings on the multi-site config is causing some issue, but I can't figure it out. I haven't put a network sniffer on the wire yet, but thinking I may have to do that at some point. It just doesn't make sense.

Can someone point me in a direction that might be able to help me isolate the problem?


7 Replies 7

Level 4
Level 4

Just to clarify a few things:

1. Do the sites have different subnets?

2. Have you verified basic IP connectivity to the printer? (i.e: ping it, browse to its web interface, etc)

3. Have you done a packet capture of an attempted print job?


Please rate useful posts.

I have 2 printers at the remote site.

I can ping both IP addresses from the main site.

I can reach 1 printer HTTP interface from the main site, but not the other

I can reach both printers HTTP interface from a device co-located with the printer

Have not done a packet capture of the print job yet. Still trying to get there.

Not sure why when I first installed the printer I was able to send test pages from the main site to the remote site, and then it stopped working. Can still print to the printer if local.

When trying to install the print drivers over the vpn, the install hangs, then times out. If I move the printer to the main site and install the print drivers, it completes in minutes.

So, it seems like maybe a protocol is being blocked, but I'm not completely familiar with the UC500 interface to be able to trace the problem like I would on the ASA5505 using the log files.

Hi John,

Are you doing thin client printing across the sites?

Also, are you connecting to the printers directly via IP address? or through a print server? or by printer name?

If connecting by name, you probably dont have dns or wins visibility anymore.

Thin clients are at the remote site, Terminal server is at the main site. Printers are defined on the Terminal Server, so printing across sites in that way.

Yes, connecting via IP address. Seems test sheets always work. Testing some other types of printing now.


So my understanding of the issue is this:

Thin clients in secondary site, can print to their printers, whilst running a RDP session through Terminal Server located in Primary site.  Fat clients in primary site, cannot print to remote site printers. Fat clients have printers pointing to \\terminal-server\secondary-site-printer

I would check the following:

1/     Fat client can ping printer IP (which I think you confirmed above)

2/     Terminal Server can ping printer IP

3/     Check ACL applied to VPN config

4/     If Terminal Server has a static NAT, then verify that it's ACL is to NO NAT communications to secondary site.

You pretty much have it right.........

With a twist. I can get on the terminal server at the primary site and can send a test page to the printer at the remote site every time.

Someone else suggested maybe packets are getting dropped because the MTU size is too small. I know where that gets set in the ASA5505, I can't find any setting like it in the UC500.

Other possibility is that it is only a particular type of document. That's what I'm trying to track down now. They may be related, not sure.

Everything worked as expected with the 5505 in place, troubles didn't start until the UC500 replaced the 5505. I'll have to see if I can find the 5505 that came out and compare the ACL's to see if there is a difference. Seems like it has to be in the config somewhere.



Its hard to troubleshoot this without seeing a config.

I cant see that the MTU would be causing this.  Is the UC making the connection to the internet? or do you have a connecting router first, then the UC?

If the latter, then the MTU change would be done on the router.