Showing results for 
Search instead for 
Did you mean: 

Patch for SPA525 phones showing incorrect date

Brandon Turpin
Cisco Employee
Cisco Employee


You can now download the patch for the SPA525G/G2 issue with showing the incorrect date at the following links:

The spa525g-7-4-8-013.bin is the normal 7.4.8 image + the fix for this issue.  The spa525g-7-4-9c-p02.bin is the normal 7.4.9c image + the fix.  You no longer need to open a case to get the firmware and can download it directly. 



14 Replies 14

Brook Powers

Installation Instructions?

Drag & drop results in "error: File Upload For input string" "p02""

Phone Load Management | Upload only accepts zip files

The only thing that is left is to update each phone from its management web page.

HI Brook,

If you rename the file to 'spa525g-7-4-9.bin', are you then able to drag-n-drop the file in CCA?



No, no luck dropping this into CCA - I'm also trying to upgrade the other SPA phones with the recently released software but am unable to upgrade those either.

I have found that completely turning off UAC (msconfig.exe > Tools > Change to lowest setting > Reboot) on Windows 7 is required for drag and drop ugrading to work. Also try and remove the dashes in the file name.

It sstarts to download to the UC and then stops with:

Error: File Upload

For input string: ""

This happens around 1:30

I have removed the "-" from the filename and disabled UAC

I have tried various combinations of the name and they have all worked for me. I would try redownloading the file just to be sure something didn't get corrupted, directly connecting to the UC and making sure no other TFTP servers/services are running (CCA is a TFTP server).

Adriaan Mol

When updating the spa525 , the cpu process reach the 99% and system doesn't work anymore,

updating phones takes a lot of time , whats happend ?

The spa525g-7-5-1-RC1 file did upload correctly. Opening a TFTP window and uploaded OK.

How you then push that update to the phones; when you power cycle they are still loading 7-4-8

where can you get  spa525g-7-5-1-RC1 ???

• SPA525G2


• SPA50x-30x:


Cisco SPA Phone 7.5.1 Release Candidate 1 provides the following key enhancements:

• BroadSoft Advanced Call Park and Recall

• BroadSoft Call Agent Unavailable Reason Code

• Support for TR-69/104/111 (SPA525G/G2 Only)

• Voice Recording by using a USB Jump Drive (SPA525G/G2 Only)

• Support for DTLS Type SSL/VPN (SPA525G/G2 Only)

• Immediatere-registration upon a failover or recovery

• Display of HD Voice Icon when a G.722 call is established

• Expand the number of Programmable Softkeys to 16

• Support for Digest Authentication in the Profile and Report Rule

• Support user=phone in SIP Message

• Support for scrollable softkeys via “More”

• Capability to define wait and pause as part of speed dial string

• Support for chuck encoding for HTTP 1.1

• Capability to add new root CA provided by 3rd party authority for certificate authentication


If you are confortable with CLI, I would suggest the following :

-Make sure you have a 525 folder under phones


>en (enter password)

#dir (you should get a bunch of folders including one named phones)

#cd phones

#dir (you should have one named 525 if not type " mkdir 525 "

-Upload the file

#copy tftp flash  (enter settings and upload the file. I have renamed it to spa525g-7-4-9.bin to simplify things a bit)

-Configure UC to upload new file to phones

#conf t

#no tftp-server flash:/phones/525/spa525g-7-4-8.bin alias spa525g-7-4-8.bin   (this will remove old definition of firmware)

#tftp-server flash:/phones/525/spa525g-7-4-9.bin alias spa525g-7-4-9.bin  (or spa525g-7-5-1 in your case)


#no load 525G spa525g-7-4-8

#no load 525G2 spa525g-7-4-8

#load 525G spa525g-7-4-9     (or spa525g-7-5-1 in your case)

#load 525G2 spa525g-7-4-9     (or spa525g-7-5-1 in your case)

Reboot your phones and they should get the update!

Great thanks for the help!

I'll give that a go now - is it possible to make the phone keep hold of the update so it doesn't re-download each time or will this 'stick'

(We have a few remote VPN connected phones)


i have a UC540 and a Cisco SPA525G2 with the wrong date.

I tried to replace the existing Firmware spa525g-7-4-9c.bin but the IP Phone still shown "Upgrading spa525g-7-4-9c"

How long need the upgrade of the file on the ip phone?

After 45 minutes (i could not see any progress on the progress on the phone display) i replaced the new firmware file with the old one and after a reboot the IP Phone works with the old configuration and the wrong date.

Kind regards,

Joerg K.

Thomas Antony

I have updated from 7-4-8 to the newest firmware 7-4-9c and the translation on the SPA525G is mostly wrong.

For example the button description displays mostly "Eingabe" or "Schlüssel" instead of Pickup or GPickUp.

It seems the dictionary isn't compatibel with the latest firmware.

Is there a new compatibel dictionary for spa525g-7-4-9c-p02.bin?

How do i upgrade the dictionary on a UC560 with SP 8.1 or 8.2?

King regards,


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers