Showing results for 
Search instead for 
Did you mean: 

Problems with LAN NTP with Version 2.2.2(1)

Chuck Brier

In my setup, I am not using the WAN port. My UC320 is connected to a port on a ASA for internet access. DHCP and NTP is provided by a Windows 2003 Server. DHCP on the LAN side works fine. Internet access for data lan is fine. I have loaded the PMF file to access the NTP server on the local lan. They are all in the same subnet. My UC 320 never synch with time server. I see no indication that the UC320 is even attempting to synch with the local NTP server.   

I have turned on syslogs and looked through log file for clues. I see nothing to help me troubleshoot this problem.anybody have any ideas on what may be the issue or how to troubleshoot the problem?

6 Replies 6

Christopher Edgeworth
Frequent Contributor
Frequent Contributor


A couple of things to verify:

  • Make sure you specified the NTP server as an IP address and not a host or FQDN in the PMF.
  • Make sure you perform an 'Apply' after installing the PMF
  • Have you tried to run the ping tool in the UC320W to see if the UC320W can ping the NTP server (Status -> Support tools -> Ping)?
  • Make sure your Windows server firewall isn't blocking NTP traffic.



  1. NTP server is dotted decimal.
  2. I applied the configuration
  3. When I run ping tool, ping result = "No WAN Connection WAN IP = []
  4. No firewall on windows server.

It seems like the UC 320 doesn't know how to access the DATA LAN.

The first thing that jumped out at me was you said its plugged directly into the ASA. Possible routing/access list/interface issue? Have you tried hooking a PC/Laptop into the same port and verifying internet connectivity and NTP server access?


It looks like you have found a problem with the ping API.  It doesn't work when the WAN port is not connected.  However, if I run the ping from a lower layer support tool, I can ping other devices directly connected on the LAN data VLAN subnet.

Does your internet router support a DMZ VLAN or ability to support VLANs on it's LAN side?  If so, I'd would recommend setting this up and connecting the WAN port to the box so it can connect to the Internet.  Key requirement is that it has to be a different subnet than what you are using for data VLAN and Voice VLAN.



I am working now. I am not sure what event made my configuration work. I did not change any of the network design or configuration. I have a companion ESW that handles the PoE phones. The servers and printers are on the UC 320. I setup SNTP on the ESW and it synch'd right away. Went back to the UC 320, no synch.

I reset the Windows Time Service on the MS Server 2003, no change on the UC, Throughout the troubleshooting process, I used a tool on my laptop to test the NTP server on the windows server to ensure it was working with clients. All good.

I deleted the PMF and reconfigured the UC 320. Applied the configuration and no time synch. Rebooted the UC and the UC time synch with NTP server.

The only thing i changed was setup ntp on esw. That would not have affected the uc 320.

My complaint is the tools to troubleshoot are weak compared to the enterprise products. It would be nice to have more granular logging and tools. Maybe CLI access like CME on IOS. This is my first SMB implementation and have always been in the enterprise space. It will be interesting to contrast the two product lines.

It would be nice to have CLI access for basic ping / traceroute type things. Sadly, only Cisco can get access to the SSH server on it (unless you're devious and find an exploit - but I don't think anyone would be silly enough to admit to that on a Cisco forum). Given it's Linux underneeth, some sort of chrooted jail with just basic tools wouldn't be *that* hard to implement.


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: