Showing results for 
Search instead for 
Did you mean: 

SPA504G - encrypted call (SRTP) - no call waiting tone

Alex A. Welzl
Level 1
Level 1

I have configured a SPA504G (FW 7.5.4) with an Asterisk to use TLS/SRTP. Overall it runs w/o any issues. The only problem I have is that when I in an encrypted call, another incoming call is only signalized on the display and the red light on the the top. I get no call waiting tone even though the call waiting tone is configured and unchanged. If I revert to UDP/RTP communication, a call waiting tone can be heard.

I have also tried FW 7.5.2b, but no change of that behaviour. Any ideas? any recommendations?

8 Replies 8

paolo bevilacqua
Hall of Fame
Hall of Fame

Wrong forum, post in "small business voice - SPA phones". You can move your post using the actions panel on the right.

Alex A. Welzl
Level 1
Level 1

This issue is still pending - even with FW 7.5.7 on SPA3xx & SPA5xx. 
(only on SPA525G and SPA525G2 is the call waiting tone working on SRTP)

There has been a thread related to it, but I can't found it now. I vaguely remember a comment claiming there may be good reason for such behavior. The SRTP call is considered "secured" with no bit in voice channel tampered. As call waiting tone has not been sent/caused by trusted peer it is not allowed to be mixed with trusted audio signal.

I can't confirm nor deny the programmer's intentions, but note the behavior may not be considered broken on SPA[35]xx but on SPA525G2 instead.



I cannot follow the argument you have mentioned in your post. All Cisco SPA phones support a "secure tone indicator" which can be set, but it should be not possible to do that same with a "call waiting tone"? So I would suggest to solve it via an optional switch to enable/disable such tone on a SRTP call - so it is up to the administrator of the phone and not to programmer's mood ... ;-)

"Secure tone indicator" is issued before the secured audio begin. It's not mixed with signed stream. So it's not the same case.

But we have no power to make such kind decision. Cisco need to make decision. Did you reported the issue to SMB TAC support ? Did they accepted the bug report ? Then it is considered bug (until rejected or solved). Did they rejected the report ? Then it is not considered bug but feature ...

Note that Cisco technicians are not monitoring this community. So unless you reported the issue to SMB TAC, no one responsible is aware of it.


Just side note - if I remember correctly, the CW tone is not the only "issue" related to secured calls. If I remember correctly, the early-audio doesn't work as well.


I cannot confirm that the "secure indicator tone" is before the audio starts. In our case it is being mixed into the audio channel (Asterisk 1.8 / 13 environment). We have already initiated a TAC request and waiting for further investigation on Cisco's side. (We are now pushing the issue, because we want to move all our 650 exts to SRTP).

Following update to the issue: The call waiting tone is working, IF the secure call indication tone is set and not empty. It looks like there is an issue as soon as the field is blank in the interface. As I find the secure indication quite nasty, I have put 397@-19;0.01(0/*/0) as setting not to hear anything from it at all. Now the call waiting comes through.

Well, it sounds like firmware bug. Unfortunately, Cisco is not monitoring this forum. If you wish the Cisco become aware of such bug, you need to report them to SMB TAC. Even in such case don't put so much hope on it. SMB TAC may accept your report, but may give no further feedback to you then.

It would be nice to have syslog&debug (highest level) captured - both from phone with no secure tone defined and with such tone defined. The difference may reveal more about issue cause.

Just side note - despite documentation doesn't forbid empty definition of tone explicitly, I consider it "you like to live on edge" configuration.