Showing results for 
Search instead for 
Did you mean: 

SPA525G2 SPCP token issue

Level 1
Level 1

My problem is almost exactly the same as that posted by Anthony Pisano last November.

I have a 525G2 right out of the box that will not register with an equally new UC540.  I get the error "SPCP register token rejected."

I am using CCA 3.0.

SWP is 8.1.0 with IOS version 12.4(24) SB and CUE 8.0.3.

525G2 came preloaded with firmware version 7.4.5

Have attempted the following:

1.  Factory reset (Note:  After factory reset, phone appears to be ready to download settings, reboots again, but then error appears.

2.  Upgrade firmware to 7.4.7 using the instructions that were given to Anthony. (Note:  After another factory reset, phone again appears ready to download settings, immediately reboots again; momentarily shows that it is upgrading to 7.4.7, and then displays the error.

3.  Attempted to manually upgrade firmware through the phone's configuration page using the file "spa525g-7-4-7.bin.  Get error "Forbidden image for this hardware."

4.  Tried same with earlier .bin files, but got same error until I tried "spa525g-7-4-4.bin", which is the current firmware installed on the phone.

5.  Tried to reinstall 7.4.5, but couldn't find image on Cisco website.

6.  Following is result of "debug tftp events" (Note: performed from Generic Debugs under Troubleshoot in CCA):

Log Buffer (5000000 bytes):

000240: Feb 28 11:41:45.899: %SYS-5-CONFIG_I: Configured from http by admin on
000241: Feb 28 11:42:50.843: TFTP: Looking for English_United_States/SCCP-dictionary.xml
000242: Feb 28 11:42:50.843: TFTP: Opened system:/its/united_states/SCCP-dictionary.xml, fd 14, size 2740 for process 32
000243: Feb 28 11:42:50.855: TFTP: Finished system:/its/united_states/SCCP-dictionary.xml, time 00:00:00 for process 32
000244: Feb 28 11:42:51.075: TFTP: Looking for SEPD0D0FDE97578.cnf.xml
000245: Feb 28 11:42:51.075: TFTP: Opened system:/its/XMLDefault525G.cnf.xml, fd 14, size 1530 for process 32
000246: Feb 28 11:42:51.083: TFTP: Finished system:/its/XMLDefault525G.cnf.xml, time 00:00:00 for process 32
000247: Feb 28 11:42:51.595: TFTP: Looking for spa525g-7-4-7.BIN
000248: Feb 28 11:42:51.683: TFTP: Opened flash:/phones/525/spa525g-7-4-7.bin, fd 14, size 10376704 for process 32
000249: Feb 28 11:42:52.243: TFTP: Looking for RingList.xml
000250: Feb 28 11:42:52.275: TFTP: Opened flash:/ringtones/RingList.xml, fd 15, size 2823 for process 222
000251: Feb 28 11:42:52.287: TFTP: Finished flash:/ringtones/RingList.xml, time 00:00:00 for process 222
000252: Feb 28 11:42:52.291: TFTP: Looking for DistinctiveRingList.xml
000253: Feb 28 11:42:52.319: TFTP: Opened flash:/ringtones/DistinctiveRingList.xml, fd 15, size 2823 for process 222
000254: Feb 28 11:42:52.327: TFTP: Finished flash:/ringtones/DistinctiveRingList.xml, time 00:00:00 for process 222
000255: Feb 28 11:42:52.339: TFTP: Looking for United_States/525G2-tones.xml
000256: Feb 28 11:42:52.347: TFTP: Looking for United_States/525G2-tones.xml
000257: Feb 28 11:42:52.347: TFTP: Looking for United_States/525G2-tones.xml
000258: Feb 28 11:42:52.351: TFTP: Looking for United_States/525G2-tones.xml
000259: Feb 28 11:42:52.355: TFTP: Looking for United_States/525G2-tones.xml
000260: Feb 28 11:42:52.359: TFTP: Looking for United_States/525G2-tones.xml
000261: Feb 28 11:42:52.363: TFTP: Looking for United_States/525G2-tones.xml
000262: Feb 28 11:42:52.363: TFTP: Looking for United_States/525G2-tones.xml
000263: Feb 28 11:42:52.367: TFTP: Looking for United_States/525G2-tones.xml
000264: Feb 28 11:42:52.371: TFTP: Looking for United_States/525G2-tones.xml
000265: Feb 28 11:42:52.375: TFTP: Looking for English_United_States/525G2-kate.xml
000266: Feb 28 11:42:52.379: TFTP: Looking for English_United_States/525G2-kate.xml
000267: Feb 28 11:42:52.383: TFTP: Looking for English_United_States/525G2-kate.xml
000268: Feb 28 11:43:16.703: TFTP: Finished flash:/phones/525/spa525g-7-4-7.bin, time 00:00:25 for process 32

7.  Following is result of "debug ephone register" (same caveats as above)

Log Buffer (5000000 bytes):

000277: Feb 28 11:47:11.995: %SYS-5-CONFIG_I: Configured from http by admin on

000278: Feb 28 11:48:15.607: New Skinny socket accepted [2] from 0, sub 1 (6 active)

000279: Feb 28 11:48:15.607: sin_family 2, sin_port 2513, in_addr

000280: Feb 28 11:48:15.607: skinny_add_socket 2 2513

000281: Feb 28 11:48:15.647: ephone-1[0/1]:SPCPRegisterTokenReq

000282: Feb 28 11:48:15.647: fStationSPCPRegisterTokenReq received on socket 4

000283: Feb 28 11:48:15.647: Invalid Device Id 80009

000284: Feb 28 11:48:15.647: StationSPCPRegisterTokenReject sent on socket 4

8.  I see where the last debug shows an Invalid device, but don't know where to go next?

1 Accepted Solution

Accepted Solutions

Steven DiStefano
VIP Alumni
VIP Alumni

Hi T.

The IOS you mention you are running (12.4(24) SB) does NOT support the SPA525G2 and is not part of SWP 8.1.0, hence the type is perhaps built as SPA525G and the phone is not that type, and so the token error.

Refer here:

You should probably upgrade your IOS.  Then it will work.


View solution in original post

5 Replies 5

Level 1
Level 1

What firmware is on the phone? Check the phone itself to see what version is on it.


Steven DiStefano
VIP Alumni
VIP Alumni

Hi T.

The IOS you mention you are running (12.4(24) SB) does NOT support the SPA525G2 and is not part of SWP 8.1.0, hence the type is perhaps built as SPA525G and the phone is not that type, and so the token error.

Refer here:

You should probably upgrade your IOS.  Then it will work.


Problem resolved.  Although after rerunning the Software Upgrade wizard again and ending up with IOS version 15.1(2)T2, I was still receiving the error.  I dug through the running config to verify the proper Load statements were there for the 525G2.  However, when I found the ephone definition for th this phone, I found it was showing as a 525G (This is a demo kit, and I had set up the phone configurations in accordance with Tech Enablement Lab 25 (CCA2.2(5) version) before actually connecting the phones.  I obviously entered 525G as the phone type instead of G2.).  After correcting this in Users and Phones, the phone "magically" registered.  Of course, I just discovered the the newest version of TEL 25 was just released days ago.

Will a factory reset also set the IOS back to factory as well, or only configuration settings?   I checked the Help in CCA and found this statement:  "Resetting a device restores the settings that it had when it was new from the factory," which led me to believe I was only changing the configuration settings back to factory default (which is what I wanted).  Now, if the reset does only affect settings, then I was left with the older IOS after running the Software Upgrade wizard as soon as I connected the UC540 to power.  Either the upgrade wizard was only partially successful (which left me with CUE 8.0.3 from SWP 8.1.0 and IOS 12.4(24) from SWP 7.1.3, or the factory reset was only partially successful by leaving me with the same combination.

Good.  Thats the type I was talking about :-)  I have seen it before (myself) and it happens to all of us.

Factory reset will do IOS/CME and CUE back to the best practice default configuration file that comes with the latest version of CCA, so to me, I always do this for lab systems or staging systems (obviously not production). 

The TEL #25 has changed.   A few weeks prior (1/18) to its update, I wrote about the new behavior of NOT having to leave phones unplugged any longer.  The latest SWP and CCA do Auto ephone registration, but WE DONT do auto ephone-dn assignment.  SO this means you can stage a system with some phones plugged in, and some phones not.

I am not sure how you ended up with older IOS, but SW Upgrade will fix that, and includes a button for factory reset during SW Upgrade.

Factory reset DOESNT upgrade the IOS.


Also note

CSCtd26844 Cisco 500 phone registration fails when ephone tag is 56 or greater.

Symptom After a license upgrade from 48 to 64 user license on a UC520, the Cisco 500 series phone registration fails with the following errors in debug ephone register output:

Error: Device Id 80000 Configured Device Id -1 StationSPCPRegisterTokenReject sent 
on socket 4

Conditions Problem is seen when registering any 500 series phone to a CME on UC520 platforms. The problem only occurs when the ephone tag value for this phone registration is 56 or higher.

Workaround Use an ephone tag that is of lower numerical value. Ephone 55 or lower will work.