Showing results for 
Search instead for 
Did you mean: 

UC520 Router SPA525G2 and SSL VPN's, Very Dissapointed!!


We have been having an issue with our VOIP system.  We purchased a SPA525G2 phone in the hope that it would connect back remotely to our UC520 and could be used everywhere in the world.

I have over 15 years configuring Cisco gear and have a CCNA and CCNP - so i configured this myself using a combination of the CCA and confirming in the CLI to make sure i understood what was going on.

The set-up seems to have worked - the phone connects and registers okay, however if i try and make a call all hell breaks loose.

First of all incoming traffic to the phone fails after 15 seconds but outgoing traffic carries on (i.e. I can't ping the phone anymore, but the other person at the other end is able to hear me)

After about 1minute 20 seconds the phone says there is a network error and then it says connecting

At the same time the router throws off any other SSL VPN client which is attached to it

About 10 seconds after that all the phones in the office start loosing buttons and have to re-register.

I have logged this call with TAC.  I have been working on it with them for over a week, but no one is able to come up with a solution.

Finally made some headway when we were able to see that the buffers where failing due to lack of memory during all of this.  The Engineer said he would put my call through to someone who knew about hardware/memory issues but has forwarded me to the SPA team who look after the phone????

It's all a bit rediculous.

My personal belief is this router can't take it.

It can't take the workload.....

has anyone got this set-up running?

Before anyone asks i'm running the latest software on the router and on the SPA525G2...

I'm really frustrated about this - Having read around this board other people seem to have expereienced simular but there are no solutions out there.

16 Replies 16

I do not see this resolved with any combination of  software on the system and the phones,  I have 5 clients having similar issues, and the best we get is, it works sometimes but once connected they still get drops in the audio (packet loss)

If I use an old 881W router using EZVPN  (IPSEC)  the remote phones are rock solid,  no problems.

Looking at the load on the UC I do not see much traffic of buffer problems with 1 ssl client,  but the problem happens.

I am suspecting the SSL client (Phone) is not up to the task.  and drop packets.


I just realised that in most cases where we run these phones (and after latest firmware they seem to be pretty solid) we are actually terminating the SSL VPN on a 2811 or similar. Or the 560 in some cases, but not a 520. If it makes any difference.

Sent from Cisco Technical Support iPad App

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers