cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1158
Views
0
Helpful
9
Replies

UC520 with software pack 8.04

anbatist
Cisco Employee
Cisco Employee

Hi Guys,

I'm connecting IP Phones CP-524 to a UC520 with software pack 8.0.4. and the phones can not register, the phones shows in the screen the following information:

Downloding XMLDefault

Any of you had expirience this problem?

9 Replies 9

David Hornstein
Rising star
Rising star

I have seen this before but not on the CP-524.  If I recall, the phone was having trouble finding it's phone load.

I believe i just reset the phone to factory defaults (manually) and off she went and started to grab the right phone load.

I already did that but doenst work.

Here are some displays that may help you.  I have CP521 and CP524 on a UC560 and running SWP 8.0.4.

I manage this system only with CCA 2.2.5.

I can do some CLI displays for you to confirm...

Confirm the Phone FW is on flash in the proper directory:

UC_560#dir flash:/phones/521_524
Directory of flash:/phones/521_524/

    5  -rw-      892511  Aug 23 2010 18:30:56 -04:00  cp524g-8-1-17.bin

Confirm Load Statements in telephony-service

UC_560#sh telephony-service
CONFIG (Version=8.0)
=====================
Version 8.0
Cisco Unified Communications Manager Express
For on-line documentation please see:
http://www.cisco.com/en/US/products/sw/voicesw/ps4625/tsd_products_support_series_home.html

protocol mode default
ip source-address 10.1.1.1 port 2000
ip qos dscp:
ef (the MS 6 bits, 46, in ToS, 0xB8) for media
cs3 (the MS 6 bits, 24, in ToS, 0x60) for signal
af41 (the MS 6 bits, 34, in ToS, 0x88) for video
default (the MS 6 bits, 0, in ToS, 0x0) for serviceservice directed-pickup
service dnis overlay
service dnis dir-lookup
load 7914 S00105000400
load 7915-12 B015-1-0-4
load 7915-24 B015-1-0-4
load 7916-12 B016-1-0-4
load 7916-24 B016-1-0-4
load 7906 SCCP11.8-5-3S
load 7911 SCCP11.8-5-3S
load 7921 CP7921G-1.3.4SR1
load 7925 CP7925G-1.3.4SR1
load 7931 SCCP31.8-5-3S
load 7936 cmterm_7936.3-3-20-0
load 7937 apps37sccp.1-3-4-0
load 7960-7940 P00308010200
load 7941 SCCP41.8-5-3S
load 7941GE SCCP41.8-5-3S
load 7942 SCCP42.8-5-3S
load 7945 SCCP45.8-5-3S
load 7961 SCCP41.8-5-3S
load 7961GE SCCP41.8-5-3S
load 7962 SCCP42.8-5-3S
load 7965 SCCP45.8-5-3S
load 7970 SCCP70.8-5-3S
load 7971 SCCP70.8-5-3S
load 7975 SCCP75.8-5-3S
load 521G-524G cp524g-8-1-17
load 521G-524G cp524g-8-1-17

Confirm you have the xml files in system:its/ and they use the same LOADed FW.

UC_560#more system:its/XMLDefault521G.cnf.xml

{7960 Oct 25 2010 10:41:04}
0
false






2000

10.1.1.1






2

cp524g-8-1-17

English_United_States
en

United_States

United_States

0
http://10.1.10.1/voiceview/authentication/authenticate.do

http://10.1.1.1:80/localdirectory




http://10.1.1.1:80/CMEserverForPhone/serviceurl
0
96

1
1


         
UC_560#
UC_560#more system:its/XMLDefault524G.cnf.xml

{7960 Oct 25 2010 10:41:04}
0
false






2000

10.1.1.1






2

cp524g-8-1-17

English_United_States
en

United_States

United_States

0
http://10.1.10.1/voiceview/authentication/authenticate.do

http://10.1.1.1:80/localdirectory




http://10.1.1.1:80/CMEserverForPhone/serviceurl
0
96

1
1

Confirm tftp-server statement match and have alias:

UC_560#sh run | inc tftp-server
tftp-server flash:/phones/521_524/cp524g-8-1-17.bin alias cp524g-8-1-17.bin

Hi Steven,

I was using SWP 8.0.4 with the default config, I will do your recomendation in my lab with the SWP 8.04 , but the thing that I did in the customer  was to put the software pack 7.0.4 and the phones comes up without problem.

Thanks for your help.

Darren DeCroock
Enthusiast
Enthusiast

One more thing I would check before worrying about having the correct load statement, tftp-server statement, and xml file.

What is the IP address you are receiving on the phone?  If the IP address is on the data Vlan, the DHCP server for the data side will most likely not have the option configured to give you the TFTP server address.  Make sure that you are getting an IP address on the Voice Vlan.

Hi Darren,

The IP address that the phone is receiving is correct, from voice vlan (10.1.1.x) and everithing looks.

final-reseaux
Beginner
Beginner

Do you have the latest firmware ? if not try it. If you don't know how to do that, you have a lab in the document section.

BR,

Romain

Hi,

The phones has the 8.1.17 firmware version.

You can also run the debug tftp commands to see what is happening with the TFTP server of the UC560.

Enter the following commands to enable TFTP packets or events:

debug tftp packets

or

debug tftp events

term mon

To disable:

undebug all

term no mon

The debug commands will give you visability into when the phone tries to register and upload the image. The EVENTS command will give you the summary of each event the phone is requesting where the PACKETS give you the details of the TFTP requests and the associated responses.

Hope this helps.

Bert Wilhelm

APW Solutions

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: