cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

910
Views
0
Helpful
8
Replies
Nicholas Balog
Beginner

2.1.4(3) FXS Port Not Working

I just upgraded to the newest LD firmware and now my FXS port is not answering. I removed the user/phone and re-added it thinking that it may solve the issue, but that didnt work.

I can directly dial its internal extension and my fax machine answers the phone just fine. Anyone have any ideas?

8 REPLIES 8
Christopher Edgeworth
Frequent Contributor

Hi Nicholas,

If I'm reading this right, external calls can't terminate to the FXS port but internal calls can?  What happens when external calls destined for that port are made?  do they go to a VM box for the FXS?   Are you using FXO or SIP trunks?  Did you do an APPLY after upgrading?

Chris

Hi Chris,

     Thanks for the reply. You are reading this correctly. My 1st FXO port is configured as a group with all of my phones sharing the outside line, including my fxs port. I do this so my faxes can be sent and received on that line.

When placing an external call to my primary line, the group rings my phones and under normal circumstances fxs rings and the fax can answer and receive with no issues (2.1.3 firmware).

Today my client said that the fax machine wasnt answering, so I checked the usual suspects, mainly checking the fax machine. It was set up correctly. I then proceeded to place a call to that line and making sure AA was on on the fax noticed that it did not display the ringing dialogue I expected. So the fxs line was the only line in the group not ringing.

I then decided to check it out internally by dialing the extension for the fxs port. It rang normally.

During troubleshooting, I completely removed the fxs userr and config and applied the deletion, then re-added it and applied that as well, thinking that basically deleting and re-adding the line in essence would take care of the issue. It did not. This is only a basic fxo/fxs config......no VM on the line and no sip trunking at all.

Hi Nicholas,

I think you need someone from the Cisco Small Business Support Center to look at the UC320 configuration. 

Chris

I had a similar issue and had to take it to CISCO TAC. Apparently files can get corrupted on these things and cause that to happen.

I bet if you run a debug in the 320 GUI on the FXS port and make some calls to it you'll find it shows a message to the effect of can't find file.

HTH

I just upgraded to 2.2.0 this evening, so I'll have to hook the fxs port back up to the fax and see if it was automagically fixed or if the problem still persists.

How did you wind up correcting the problem Daniel? Did you have to do a factory wipe and start from scratch or did you find out a way to fix the problem without going through all of that trouble?

This issue just cropped into the mix without being a result of any changes to the system. For this to 'just happen' is very poor on the part of Cisco.

My uc320 has been RMA'd. 

I went through a few steps to get there.

I did all the Tshooting myself to verify it was in fact a port issue and not a trunk. I rebooted, reloaded and then upgraded to the limited firmware all no luck.

I contacted Cisco tac and they tried to tell me it was a telco issue. (I am the TELCO) It took about 15 min to prove to him it was in fact the uc320. He went through most of the stuff I tried and then took a capture to send to their tier 2. I got a call back a couple hours later and they said it was hooped and they weere sending me a new box.

Should be here any day now. Basically what the Cisco TAC guy told me was becvause these things run on an Asterisk like OS everything is a file. If a file gets corupted this type of thing can happen or it's hardware.

This is completely insane! You would think that there would be some kind of function built into this unit which would detect such a config file issue and it would be rebuilt instead of it just choking on a non-existant file. I mean, if its live and running in the system with a config issue, you would think a new Apply would just wipe and rebuild and away you go.

I replaced an Asterisk box running Nortel 2007i phones with this as it was supposed to be the nice, low maintenance alternative to a cumbersome linux deployment. I can honestly say I have had less luck with this box then I did my Asterisk box.

Tell me at least TAC did you the justice of a spare in the air ship instead of having you send in the faulty unit first. My experience with TAC is less then stellar.

Yes the replacement was quick and easy. They overnighted the new box and I have to ship the broken one back afterwards.

This widget could not be displayed.