cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
9954
Views
0
Helpful
17
Replies
Highlighted
Beginner

Call Tracking

I was curious if this is possible. My clients configuration is that all inobound calls get the AA that lets them either dial directly by extension or pick an option to go to a specific group. What is happening is the CallLog feature in CallConnector is logging all inbound calls as x600 which is the AA and not the caller ID of the inbound call. So when a user looks at their history they see a bunch of inbound calls from x600 which doesn't help when they need to see the history.

Does anyone know of a way to keep the caller ID from the inbound call throughout the call history in CallConnector so we can do proper searching?

Thanks,

Jorge

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Collaborator

You need to configure CUE to do blind transfers using the SIP BYE/ALSO method in order to preserve the original CLID. Log into CUE and do this:

ccn subsystem sip

transfer-mode blind bye-also

Let me know if that works.


Marcos

View solution in original post

17 REPLIES 17
Highlighted
Collaborator

You need to configure CUE to do blind transfers using the SIP BYE/ALSO method in order to preserve the original CLID. Log into CUE and do this:

ccn subsystem sip

transfer-mode blind bye-also

Let me know if that works.


Marcos

View solution in original post

Highlighted

So far it looks like it didn't take. I ran the command and rebooted the CUE and checked with a user. She stated all inbound calls still show up as 600 which is the AA...of course it could be the user not reading things properly. I have an engineer going on site tomorrow and I'll have him check things out.

Highlighted

Make sure you save the configuration in CUE. You should not need to reboot the system...

Marcos

Highlighted

Yeah, I ran a 'write mem' and then checked some logs, it didn't look like it worked so I ended up rebooting the CUE just to be safe.

Highlighted

Marcos,

OK my engineer confirmed that calls being transferred through our AA are still coming accross as 600 and not the caller-ID. They are using a T1 split into a PRI, not sure if that changes the config settings.

Any other thoughts? Maybe a debug log I can look at?

Thanks,

Jorge

Highlighted

That setting should have done the trick. Please provide a "debug ccsip message" showing the outcall from CUE's AA.

Thanks,


Marcos

Highlighted

I ran the debug ccsip message command but can't get the output, is there an additional command to display the output from this debug session?

Thanks,

Jorge

Highlighted

Issue the command "term mon" to monitor the output on the terminal (ie your telnet session)

Highlighted

If you are using telnet or ssh, you need to type...

term mon

If you are on the console port, try...

logging console

Highlighted

Yeah sorry...had a newb moment

Anyway, I ran the debug and copied the text, it is attached.

As a side note I enabled the setting on our office system and it works perfectly. So this is isolated to something with my clients system.

Highlighted

Jorge,


Can you try semi-attended transfer mode in CUE? Just a test. Let me know,


Marcos

Highlighted

Sure, but I am not sure exactly how to do that, can you provide some guidance?

Thanks,

Jorge

Highlighted

No problem. Under ccn subsystem sip, change the transfer-mode to semi-attended.

Thanks,


Marcos

Highlighted

OK, I changed the mode and ran the debug log again. it is attached. I did check on a CallConnector log and it did show the inbound call to the users extension coming from 600 not the caller ID number.


Thanks,

Jorge