Showing results for 
Search instead for 
Did you mean: 

Get the latest Cisco news in this December issue of the Cisco Small Business Monthly Newsletter


cannot connect to SPA525G2 from Cisco Configuration Assistant

I am trying to connect to two SPA525G2 Cisco IP Phones to upgrade the firmware.  Currently, they have firmware v7.4.8.  The hardware version is 2.1.0.

I have tried these steps:

1) set PC with Configuration Assistant to fixed IP and disconnect from LAN

2) Factory reset SPA525G2

3) Set fixed IP on phone

4) Use that IP in Configuration Assistant to connect to device:

     - if I leave it to HTTPS, I get an Unable to connect error.

     - if I change it to HTTP, I get a login dialog, but have no clue what might be valid for a factory reset device

I can use a browser to the IP - read only interface - no apparent way to manage the phone via browser.  I've seen posts showing one going to <phone IP>/admin/advanced from browser but this give a "403  Forbidden !" error.  Using https://<ip> with or without /admin/advanced or various ports offered on posts just yields a not available error.

What I realy need to do is upgrade the firmware and ship these phones out with some belief that the people in the field will be able to connect them to the phone switch there.

1) I also saw references to using a USB stick to do update - but no details on how to set it up.

2) I also saw references to using TFTP, but still not sure what needs to be done to make a go of it.

Any help much appreciated!

Everyone's tags (3)

cannot connect to SPA525G2 from Cisco Configuration Assistant

I have successfully flashed the firmware of these two SPA525G2 phones using the USB method.

I am going to try to connect the Ciso Configuration Assistant to the updated phones to see if it will now that the firmware is not so old, but any insite there will still be much apreciated!