Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


Cannot register 9971 on UC520/CME 8.6

I'm having issue registering a 9971 phone on a UC520 running CME 8.6

Here are the relevant configs -

voice register global

mode cme

source-address port 5060

max-dn 224

max-pool 56

load 9971 sip9971.9-2-2

load 7971 term71.default

authenticate register

authenticate realm all

timezone 13


voicemail 400

tftp-path flash:

create profile sync 0467524178137401



voice register dn  2

number 701

name Video Phone


label Video Phone

voice register pool  2

id mac 8875.xxxx.xxxx

session-transport tcp

type 9971

number 1 dn 2

dtmf-relay rtp-nte

username video1 password 123456

codec g711ulaw


When I bootup my phone, it simply displays "Phone Not Registered".  If I manually set an Alternate TFTP and specify, it requires me to enter 123456 to enter Administrator Settings and I also see Extension Mobility and My Phone Apps under settings which is an indication that the phone system is talking to the phone.

Here's my debug tftp events output -

Oct  8 20:13:46.781: TFTP: Looking for CTLSEP887556511C12.tlv

Oct  8 20:13:46.873: TFTP: Looking for ITLSEP887556511C12.tlv

Oct  8 20:13:46.961: TFTP: Looking for ITLFile.tlv

Oct  8 20:13:47.089: TFTP: Looking for SEP887556511C12.cnf.xml

Oct  8 20:13:47.089: TFTP: Opened flash:/SEP887556511C12.cnf.xml, fd 1, size 4338 for process 336

Oct  8 20:13:47.117: TFTP: Finished flash:/SEP887556511C12.cnf.xml, time 00:00:00 for process 336

Oct  8 20:13:49.201: TFTP: Looking for featurePolicyDefault.xml

Oct  8 20:13:49.205: TFTP: Opened flash:/featurePolicyDefault.xml, fd 1, size 825 for process 336

Oct  8 20:13:49.213: TFTP: Finished flash:/featurePolicyDefault.xml, time 00:00:00 for process 336

Oct  8 20:13:49.477: TFTP: Looking for English_United_States/gd-sip.jar

Oct  8 20:13:49.577: TFTP: Looking for United_States/g4-tones.xml

When I look at the status messages on the phone -

Does not find United_States/g4-tones.xml

Does not find English_United_States/gd-sip.jar

Gets an error updating locale

Anyone have any ideas / suggestions?  Thanks!    


I don't see the image in a tftp flash command (9951 in this example)

tftp-server flash:/phones/9951/dkern9951.100609R2-9-2-2.sebn alias dkern9951.100609R2-9-2-2.sebn

tftp-server flash:/phones/9951/kern9951.9-2-2.sebn alias kern9951.9-2-2.sebn

tftp-server flash:/phones/9951/rootfs9951.9-2-2.sebn alias rootfs9951.9-2-2.sebn

tftp-server flash:/phones/9951/sboot9951.031610R1-9-2-2.sebn alias sboot9951.031610R1-9-2-2.sebn

tftp-server flash:/phones/9951/sip9951.9-2-2.loads alias sip9951.9-2-2.loads

tftp-server flash:/phones/9951/skern9951.022809R2-9-2-2.sebn alias skern9951.022809R2-9-2-2.sebn


I still get the load errors on the phones but they work

Donwload and install new locale. This issue is related with the process:

CME SIP configured -> CME SIP removed -> CME SIP configured again

Verify the voice service voip configurations. The registrer server must be set on sip. Trust me, I spedn a lot of hours to discovery this. Afer I added the registrar command, the 9971 phone register quickly!

voice service voip
 no ip address trusted authenticate
 allow-connections sip to sip
  bind control source-interface VlanX
  bind media source-interface VlanX
  registrar server

The error with the locale always happens. I tryed to solvi it with defferente firmwares and locale versions, but I don't know why 9971 tryes to get the ring and jar files on the directory flash that doest exists. I tryed this steps, but didnt solve the error, and the 9971 had registered and worked!

copy tftp://x.x.x.x/CME-locale-xx_XX-Xxxxxx.tar flash:/its/

archive tar /xtract flash:/its/CME-locale-en_US-English- flash:/its/

Router(config-register-global)#user-locale US load CME-locale-en_US-English-

Router(config-register-global)#create profile

You saved me with the:

voice service voip

registrar server

Thanks a lot

This widget could not be displayed.