Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


CIPC error updating locale, time off, background images not available

I've tried reading other threads about this, but I'm not sure those apply to my situation.

We're on a UC500 with 24T. I do not think we have the entire software pack just 24T IOS image.

We have 4 issues- they may related - I am suspecting we've got garbage or conflicting info on our flash:

1)  Our softphones are 1 hour off on the time. It's like they are in Pacific time zone and we're in Mountain time zone, so the CIPC shows one hour earlier.

Both CME and CUE show the correct time, and our 7940's and 7960's show the correct time.  When I check the status Messages on the CIPC, it says  " CTL update failed, SEP001C23858810.cnf.xml, error updating locale"

2) The back ground images are not available for selection- it says "file not found". But I can see the .png files on our flash. i compared our flash to a customer's and we have the same image files... SO I VPN'd to a customer's and started my softphone. I had all the background images available and selected one.  I disconnected the VPN, started my sopftphone on my own UC and my new image was still there- but my preferences selections still look like they are not there and give me the same error of "file not found".

     < I attached pictures of both #1 and #2 >

3) All 7931 handsets are also one hour early ( pacific time)

4) One 7931 has lost it's ringer files,but the other 3 are OK.

So, do I need the full software pack of phone loads etc ?  Or do I have something else going on ?

I'm the project manager- I know enough to be dangerous.  Our tech staff is so busy they have not given our issues much attention so I'm trying to sort through it. It concerns me that we don't have an off hand understanding of the phone and the UC's exchange of information and what's failing.

My CIPC version is with CDP driver and voice engine 2.4.0

My supervisor's is, CDP driver, voice engine 2.6.4 and we have the exact same issues- so it can't be the version of the actual CIPC itself in my mind...

Thanks for any input !


Steven Smith
Rising star

UC520(config-telephony)#time-zone ?
  <1-53>  select timezone name used by IP phones (offset in minutes)
1 Dateline Standard Time -720
2 Samoa Standard Time -660
3 Hawaiian Standard Time -600
4 Alaskan Standard/Daylight Time -540
5 Pacific Standard/Daylight Time -480
6 Mountain Standard/Daylight Time -420
7 US Mountain Standard Time -420
8 Central Standard/Daylight Time -360
9 Mexico Standard/Daylight Time -360
10 Canada Central Standard Time -360

config t


time-zone 7

no create cnf-files

create cnf-files

That should fix the timezone problems.

For the ringer and desktop problems, can you attach a show run, remember to take out the passwords and other data you don't want to share.

Also, attach a show flash: all

That should help for those 2 problems.

I followed your steps and selected timezone 7. I re-started my CIPC, but nothing changed. My time is still an hour early.

Our 7931 is still an hour early as well.

I checked CME & CUE clocks too...they look correct. ( see attached screenshot).

The 7931 shows a firmware load of SCCP31.8-4-2S

Attached is also sh run and sh flash. ( with things removed - let me know if I removed anything you need to see)

My CIPC is ephone 34, my boss is ephone 39.

I feel like we've pointed things to alias's that don't exist? or phone loads that don't exist?



I am going to look more into the time stamp issue that you are having.

Can you verify that the information in the List.xml is accurate?  It appears that you have the 3 different List.xml files, but the images are all in one place.  If you have this setup incorrectly, the files might be shared, but actually in the incorrect location.

I'm pretty sure I did that ;)

I tried taking them off another customer's configs- but I wasn't sure which ones to I have a mixture of parts of the image files from other customer. but we did have some of the files on there...just the 2nd and 3rd are me messing around. Needs some clean up- I know.

Can you do a debug tftp events on the failing system when looking for the desktop images?  Can you also provide the appropriate List.xml file?

So, earlier today I tried a debug tfto events and started my CIPC- i had absolutly NO events- nothing was picked up. I had expected to see something.

But I had not tried setting a new image file in my preferences...  Is that what you want me to do? turn on the debug, then try to set my prefereces to one of the image file choices that are red X'd out and make it give me the "file not found" on my CIPC message screen ?

I am sorry I don't know what you mean about the image files- or where to look for the correct aka "appropriate" list.xml file.

Anything with last week or today's date was me trying to add correct files to flash- but not knowing what's correct or not- I don't know what the diff is between the TN png files and the png files...sorry.

Woudl you rather call me? I think you have my contact info ( at least me email) or send me to TAC?   You can have full access to our UC...and I'd be interested in understanding what's happening.

I can give you a call.  I am pretty sure I already have your contact info.  Give me just a few minutes.

In case anyone is still wondering, the problem is most likely related to the wrong phone file downloading to the CIPC.

I recreated the scenario, loaded CIPC and only loaded 7940-7960 loads (tftp) and it did the same exact thing mentioned above.. I then began to load the 7970 load files and problem was solved.

hope this helps anyone else out there..



I have almost the exact same problem, except my phones are off by 5 hours.

I think that my issue is what you described about the 7970 phone loads.  I think I did it properly, I TFTP'd all the files and then put the "load statement" under telephony-service.

"load 7970 SCCP70.9-0-2SR1S"

But I still have the same issue.  Is there a step I'm missing w/ the phone loading?

You can always check to see what phone load is actually installed and running on the phone itself, or on the UC500, using CCA: Monitor: telephony: Phones and Extensions (there is a column showing the active phone load) <-- this does the same thing, sorta like cli 'show ephone phone-load'

You can also reset the phone after setting the following debug.

# term mon

# debug tftp events

...and watch to see what happens between the UC500 (tftp-server) and Phone.

Check this for the steps to add a phone load manually....


I did a reload of the router & restart of the softphone.   I then specified under the ephone "type CIPC" and reset the phone and it pulled the correct time.