cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter

6833
Views
0
Helpful
3
Replies
Highlighted
Beginner

Cisco SPA504g SIP Set up

I hope someone can help me.

I have recently ordered VOIP lines from my telephone service provider and they have provided me with SIP details in order to set up our Cisco phones.

They have provided me with the following bits of information

Number/username

SIP password

Domain

Alt Domain

Outbound Proxy

IP address

I have attempted to set up the phones using these details through the LAN IP of the phone and I am unable to configure the phone correctly to get it working.

I would appreciate any help with getting the phones set up correctly.

3 REPLIES 3
Highlighted
Beginner

Cisco SPA504g SIP Set up

Hi Sergio,

A couple years ago I wrote the following blog article on how to configure the SPA504G from scratch (using CallCentric as the example VoIP provider for configuration).

http://blog.voipdiy.com/2011/11/configuring-cisco-spa504g-ip-phone-from.html

You may find this article useful in configuring your phone.

Sometimes there are minor differences of how to configure from one VoIP provider to another. So, it may be helpful to know who your VoIP provider is that you are configuring it with. 

For example, CallCentric requires the additional configuration of Auth ID as well as UserName.  But, your VSP appears to not use that info for registration (some providers require this; some don't).  In the case of CallCentric, Domain, Alt Domain, and Outbound Proxy would all use  the same entry;  i.e. callcentric.com.  In this case, no IP address is required, just the domain/proxy names (IP addresses are looked-up using DNS lookup).   So, again it just depends on your VSP as to whether they accept domain/proxy names, or an explicit IP address.  Also, Callcentric requires the setting "Use DNS SRV" be set to "YES".  But, not many VSP's require this setting.  So, this may not apply to your VSP settings. (they would specify, if required).

If you still have problems, more detailed information about your VSP, your LAN, and your Router may be needed.

Best regards,

Jeff - voipdiy.com

Highlighted
Beginner

Cisco SPA504g SIP Set up

Hello Jeff,

Many thanks for your support.

My Voip provider (BT) are not very helpful due to the fact I have "third party" equipment. I have spoke to a couple communication engineers and they are very reluctant to come and help set up the phones so looks like im going solo.

I have inputted the data provided by the with regards to the EXT1 page I have inputted the data in correctly (I think)

When the phone restarts it says "Initializing Network then "Checking DNS" and doesnt dissapear I presume the DNS settings are not correct but what details do I input and where?

Regards,

Sergio

Beginner

Re: Cisco SPA504g SIP Set up

Hi Sergio,

  • Make sure you have enabled "Use Outbound Proxy" to "YES".
  • Unless BT instructed otherwise, make sure "Use DNS SRV" and "DNS SRV Auto Prefix" are both set to "NO".
  • Unless BT instructed otherwise, make sure "Auth ID" is blank, and "Use Auth ID" is set to "NO".

I might also suggest you set:

  • NAT Mapping Enable to Yes.
  • NAT Keep Alive Enable to Yes.

I have seen the "Checking DNS" message not dissappear in the past, but I can't quite remember the cause and cure I found for it, at that time.

As far as DNS server settings, I have been using Google DNS for years with good results.  I set my devices with the following manual DNS servers:

  • Primary DNS:   8.8.8.8
  • Secondary DNS:  8.8.4.4
  • Then, set DNS Server Order to either:  "Manual"  or  "Manual/DHCP"

If you continue to have problems, I might suggest you make sure you are running the latest firmware version in your phones.  I explained how to update firmware in the SPA504G in this blog post a couple years ago:

http://blog.voipdiy.com/2011/11/updating-firmware-on-cisco-spa504g.html

P.S.

It may also be a good idea to set values for the NTP Time server support (System tab), as well.

  • Make sure NTP Enable is set to Yes.
  • You can use any NTP time servers of your choice.  I set my Primary NTP server to:  time.chu.nrc.ca  and  the Secondary NTP server to:  time-nw.nist.gov

Best regards,

Jeff - voipdiy.com