cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Please be advised, the GuideMe Wizard is no longer available on the Small Business Support Community. For search capability please use the community search field to find content related to Cisco Small Business documents, videos, and discussions.
1186
Views
0
Helpful
6
Replies
Beginner

Cisco SPA504G & SPA508G display time 1 hour behind

Cisco SPA504G & SPA508G display time 1 hour behind after an hour online.  When I reboot the phone it displays the correct time for 1 hour… after that hour it displays the incorrect time.  Currently running software version 7.5.7s.  DST Rule: start=3/8/7/02:0:0;end=11/1/7/02:0:0;save=1.  Changed DNS Servers and provided static IP Addresses for Primary and Secondary NTP Servers (instead of the us.pool.ntp.org) but no luck.  Phones are set to DHCP; no options defined in DHCP.  DHCP provided by Cisco 1841 router (default gateway).  Any assistance would be greatly appreciated.

6 REPLIES 6
Engager

All those settings are

All those settings are affecting it:

So please disclose your current configuration. Don't forget to mention the target timezone (time offset from UTC) you are wishing for. Make sure the NTP server of your choice is returning correct time (which us UTC time all the times as NTP known no time offsets).

Unless you are pretty sure there's no timezone options embedded in the DHCP response, set Ignore DHCP Time Offset to Yes. Turn it to yes even in the case you are sure there's no timezone options embedded in the DHCP response.

Highlighted
Beginner

My settings have not changed.

My settings have not changed...

I have it pointing to us.pool.ntp.org similar to our other locations.  This location is the only one causing this issue.  I suspect it's something in the DHCP options but not sure.  I just rebooted the phone and the time is correct.  After ~1 hour it will be behind 1 hour.

Beginner

I now set a phone to point to

I now set a phone to point to the router (192.168.1.1) as my Primary NTP Server.  Time on the router is correct (15:29:15.334 UTC Thu Mar 31 2016).  Below is my DHCP setting on the router:

--

ip dhcp excluded-address 192.168.1.0 192.168.1.100
ip dhcp excluded-address 192.168.1.200 192.168.1.254
!
ip dhcp pool Nelson-dhcp
   network 192.168.1.0 255.255.255.0
   dns-server 8.8.8.8
   default-router 192.168.1.1

Engager

Yes, but you still didn't

Yes, but you still didn't disclosed what offset you are expecting to see. Thus can't judge the settings comply with your wishes or not. OK, I will assume they are correct and you wish to see -07:00 (effective offset).

I configured my test phone using your settings (but own NTP server, of course), but I'm unable to reproduce the issue. It show expected time (e.g. -07:00) to me.

Well. Sometime the phone is using time provided by PBX it is registered to. Can you capture SIP packets sent by PBX and verify they contain correct time ?

Also, turn on syslog&debug (highest level) and catch them. It may help us to identify the cause.

Beginner

Changing my Primary NTP

Changing my Primary NTP Server to the router corrected the issue.  Thank you.

Engager

Glad to hear.

Glad to hear.

Personally, I don't recognize all those *.pool.ntp.org NTP servers as reliable source of time.  You never know what servers are in pool ...

Consider rating of helpful responses.