cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

644
Views
0
Helpful
5
Replies
Thai Huynh
Beginner

Cisco UC540 incoming call problem

Hi everyone,

 

I have a problem with my UC540, below is my network diagram:

 

Internet---------887----------UC540

 

I have successfully configured UC540, incoming and outgoing call working perfect, but when I changed IP address on UC540's F0/0 which connected directly to 887VA then incoming call stop working??? outgoing call still work fine.

Example: I change F0/0 on UC540 from 100.168.100.253/24 to 192.168.1.254/24 then incoming call dead, if I change F0/0 ip back to 192.168.1.200/24 then incoming call work normal

Note: After int F0/0 has a new ip address, I have to restart the unit or it took long time for incoming call to work as normal.

          Even when ADSL2+ connection down for a few seconds only, incoming call still dead (will work again after Registrar time expired)

          I also noticed that after IP address changed, UC540 keep sent invite but doesn't received unless Registrar expired.

Forgot to mention that I'm using SIP Trunk. Configure file attached with incoming call setting only for easy to troubleshooting.

 

Please help and thanks in advance.

Tim.

5 REPLIES 5
ajay1komban
Beginner

 

 

Dear Tim,

What type trunk connection , you are using there.

Please post your configuration

Regards,

Ajay 

Hi Ajay,

Config file attached and I'm using SIP trunk.

Thanks

 

Dear Tim,

 

Did you change the session target of below dial peer,when you change  Ip address ?

 

dial-peer voice 1009 voip
 description ** Passthrough Inbound Calls for Internal Extensions from CUE **
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 incoming called-number ^...$
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad

 

Regards,

Ajay Jose K

Hi Ajay,

 

I'm only changed ip address on interface F0/0 by cml. I have updated more details about my problem with debug file included.

 

Thanks,

Tim

 

 

soloo2014
Beginner

did you configure the 887 router or ITSP did that ?

because the ITSP will fix the traffic for the SIP to one ip , so you will need to check the configuration in the 877 router

 

another thing : in your example here i see 192.168.1.200 to 201

but in the configuration the ip is 100.168.100.253 ??

note that this ip is not a private ip address , if this IP is given to you by ITSP then you can not change it unless they approved.