cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

594
Views
0
Helpful
4
Replies
avezina
Beginner

CP-6851-3PCC : Not saving "Message waiting" setting

Hi,

 

On CP-6851-3PCC phones, firmware: sip68xx.11-2-3MSR1-1.loads. I can't save the "Message waiting" setting. Same thing happened with the previous firmware.

 

Using the web interface :

 

In /admin/Voice/Ext 1 I set the Message waiting parameter to No and then click Submit all changes. The phone reboots and then the Message waiting setting is set back to Yes and I still have mwi on the phone (aka it does not work).

 

I uploaded screenshots. before.png is juste before clicking on Submit all changes.

 

After is once the phone rebooted.

 

Using provisionning :

 

I also tried pushing this XML to the phone with /admin/resync?http... :

 

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<flat-profile>

<!-- Ext1 tab -->
<Message_Waiting_1_ ua="na">No</Message_Waiting_1_>

</flat-profile>

 

Same thing happened (reboot, then still set to Yes and mwi still active).

 

Is there something I am missing?

1 ACCEPTED SOLUTION

Accepted Solutions

Hi, 

The following parameter, <Message_Waiting_1_ ua="na">Yes</Message_Waiting_1_>  is also set by a notify sent by the server, depending on whether you have a voicemail message or not.

So if you have voicemail messages, you won't be able to turn that off, since the server will keep sending a notify to the phone, thus turning MWI on. 

 

Its the way the phone was designed to be. 

View solution in original post

4 REPLIES 4
Geovani Goncalves
Cisco Employee

How are you provisioning your phones? 

Do you have a provisioning server pushing out xml files? 

It sounds like your settings are being overwritten by the provisioning server. 

 

No provisionning on the phone (I had a Wireshark sniffing and it only downloads the dictionaries).

 

To be sure, I set provisionning to "No"Capture d’écran, le 2019-09-20 à 10.36.38.png

 

Still the same problem (Message Waiting always goes back to yes)

 

 

Hi, 

The following parameter, <Message_Waiting_1_ ua="na">Yes</Message_Waiting_1_>  is also set by a notify sent by the server, depending on whether you have a voicemail message or not.

So if you have voicemail messages, you won't be able to turn that off, since the server will keep sending a notify to the phone, thus turning MWI on. 

 

Its the way the phone was designed to be. 

View solution in original post

I understand. 

 

Is there a way to ignore those NOTIFY (message waiting) so the phone does not display an icon and a red LED when there are new messages?

 

Just out of curiosity though, what is the point of <Message_Waiting_1_ ua="na"> setting if it gets overriden by the server? Do you have an example of what it does and it what context?

 

Best regards

This widget could not be displayed.