cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Get the latest new and information the November issue of the Cisco Small Business Monthly Newsletter

1107
Views
0
Helpful
2
Replies
Highlighted
Beginner

CUCMBE3K Experience and Issues Identified

I have created a list below of issues and experiences whilst working with the CUCMBE3K.

For the purposes of this dialog, I will refer to this particular customer as “CustomerX”.

Part 1: Pre-Sale Engagement Summary

Following true to the Cisco PPDIOO model, the CUCMBE3K was identified as the best fit for the customer requirements, both technically as well as functionality. Apart from the standard hunt groups, the main highlights being the following:

  • Voicemail-to-Email notifications
  • Voicemail for all users
  • Extension Mobility for the bulk of users
  • Multilevel Auto Attendant
  • Integrated E1
  • FXS support for FAX
  • Paging/auto-answer

The Quick Pricing Tool (QPT) is the recommended Cisco tool to scope and create a CUCMBE3K BoM. And thus, this tool was used. The BoM of which was validated by Cisco Partner Presales and the order was placed.

Issue 1: UCL Licenses arrived in singular form

The first thing I happened to notice whilst I was unpacking the boxes was the quantity of UCL licenses. Yes, I am aware of bundled licenses, and I select those wherever possible, however these were specific to UCL voicemail licenses. Now I am not going to into how archaic the process is of still having to map a license key to a MAC address – I feel this should be done in the backend and not by partners like many other vendors do it – so we will look past this fact. Where I do have a concern is having to spend hours online manually activating UCL Voicemail licenses (restricted to 10 as “bulk” option on the Cisco Online License Tool); only to find out later that the CUCMBE3K itself can only accept 1 license upload at a time – therefore increasing the hours associated to simply applying licenses.

  • Issue 1 Summary:  
    • UCL Licenses provided in singular form for UCL VM, despite ordering via QPT.
    • Online license Tool unable to process more than 10 PAK’s at a time;
    • CUCMBE3K unable to accept more than 1 license at one time
    • Issue 1 Fixes/Workarounds/Requests 
      • Cisco, please fix QPT to ensure so that when you specify the amount of voicemail users it creates UCL VM bundled sku’s for VM UCL’s
      • Increase the ability of the Cisco online License Tool to accept more than 10 at a time.
      • CUCMBE3K team, please provide the ability to select more than one license at a time to import.

Issue 2: Wait time of 15 minutes before CUCMBE3K Web interface responds

Powering on the CUCMBE3K unit; like any engineer you would run a ping to the default IP address to indicate when the device has successfully come up and then you would connect to it via the appropriate management interface. The CUCMBE3K would respond to the ping shortly after start-up, however the web interface was not available. No documentation indicates that the CUCMBE3K actually takes between 15 to 20 minutes to start-up, before it becomes responsive and phones can register.

  • Issue 2 Summary: 
    • CUCMBE3K takes 15 to 20 minutes to respond after boot-up.
    • Nowhere is this documented yet when TAC case is logged, it is outlined as normal behaviour
    • Issue 2 Fixes/Workarounds/Requests: 
      • Be patient
      • Cisco, please update documentation
      • CUCMBE3K Team, please look at how this boot-up time can be improved

Issue 3: First Time Wizard Crashes/Issues and Web Interface

As per the CUCMBE3K documentation for version 8.6.3, which is what was shipped with this device. I did not use the “Bulk Import Tool” (which I will get into a bit later) and simply configured the first time wizard for a “single” site. The wizard itself crashed 3 times, where I would be working through it and it would simply hang and stop responding. So I would have to restart the device and then have to wait 15 to 20 minutes before I could try again. You are looking at 1 full hour of sole boot-up time as a result of this – never mind the crashing interface.

I just kept trying and then eventually got through to the “Sites” page within the wizard, which then presented another issue. For some reason the wizard would accept all my entries yet it would not let me proceed past the “Sites” Page. The only way I could get past that “Sites” page was to start the wizard again and then click “next, next, next” for the previous pages (that I had already completed) and then it let me through the “Sites” page.

When I submitted the completion of the wizard, my browser immediately displayed “timeout error”, after which I could no longer connect to default 192.168.1.250. I then tried to connect to the newly assigned IP address. It responded but would not let me log in with either the new or old credentials. I then heard the device restart…assuming that now it had applied my Wizard configurations. I think it would be a good idea to have some sort of progress bar for something like this?

I waited for the unusually long period (20 minutes) before trying to connect and yet this time I could not connect. Even after waiting for over an hour. Ping responses to the newly configured IP address were responding. Yet no Web service was available. I restarted it after waiting for over an hour and  half.

After the restart, I waited again for over an hour and yet no luck – I turned it off and I went home for the evening. I had wasted one full day on trying to give this device an IP address and login?

In the morning I powered the device back up and I could then connect to the web interface but could not access the CUCMADMIN page…I kept getting an error page indicating that cucmadmin is not available. After much retrying it eventually let me in and then I could log in for the first time post wizard configuration.

Now that I was in and working on the CUCMBE3K interface, there came a time where I had to log out. When I tried to log back in I received “An error has occurred during authentication. Contact your system administrator.” This seemed to occur regularly and logging-in twice seemed to be the only way to log into the interface (with the same credentials).

I could go on but I think you get the drift.

Issue 3 Summary:

  • Unstable 8.6.3 Wizard\Web interface
  • No progress bar for Wizards submission/config application
  • Issue 3 Fixes/Workarounds/Requests: 
    • Be patient
    • Upgrading to Version 8.6.4 dramatically improved stability of Web interface (but be careful of country pack backward compatibility – install country pack first before upgrade!!)
    • Cisco TAC recommend using Firefox – despite it not being listed as a supported browser

Issue 4: All Email address field do not support xxx@xxx.local

This particular environment is quarantined, and hence they use a domain of customerXdomain.local.

This is not supported on CUCMBE3K, despite it being a valid email address.

  • Issue 4 Summary: 
    • No support for *.local on any email fields
    • Issue 4 Fixes/Workarounds/Requests: 
      • Cisco Bug/Defect has been logged (CSCub81401)
      • No work around

Issue 5: 7900 Handsets are not configured after changes have been applied to them

Should you make a change to a usage profile and/or speed-dial etc, the affected handset then restarts and upon restart has those configurations applied.

This works fine with the 6900 series handsets however, not with the 7900 series handsets. You have to restart the 7900’s manually for changes to be applied. Not sure if this is related but I also noticed that after a CUCMBE3K restart, the 7900 series handsets did not register automatically. The just sit there indicating “registering”. So you have to manually restart them to get them to register them to the CUCMBE3K device.

  • Issue 5 Summary: 
    • 7900’s do not accept changes applied to them via CUCMBE3K
    • After CUCMBE3K restart, the 7900’s do not automatically register to the CUCMBE3K. They require a manual reboot. In some cases this was seen to be an intermittent issue i.e sometimes a 7900 handset would in fact register.
    • Issue 5 Fixes/Workarounds/Requests: 
      • Cisco Bug/Defect has been logged (CSCub81366)
      • No work around

Issue 6: Cannot assign more than 40 Speed Dials

An error is received when you try to add more than 40 speed-dials to a phone. Despite the phone being a 7975+7916+7916 handset (a tally of 48 speed-dials on the 7916 sidecars alone)

  • Issue 6 Summary:  
    • Cannot allocate more than 40 Speed Dials to handset despite if the handset can support it.
    • Issue 6 Fixes/Workarounds/Requests: 
      • Cisco Bug/Defect has been logged (CSCub83528)
      • No work around

Issue 7: No Call Busy Forward to Voicemail from Huntgroup

There is no option to have a Hunt Group Voicemail. So if no one is available in the hunt group the call will receive an engaged tone. This is a feature typically expected for any current voice platform.

  • Issue 7 Summary:  
    • No support for Hunt Group VM
    • Issue 7 Fixes/Workarounds/Requests: 
      • Cisco Bug/Defect has been logged (CSCub83528)
      • Configure Call-forward to extension with Voicemail configured for hunt group

Issue 8: Extension Mobility Users unregister when not logged in

This was a significant issue with this engagement.

The CUCMBE3K unregisters the EM user when not actively logged into a handset. This means when you call an EM user that is not logged in – you get an engaged tone. Not voicemail as what would be expected.

  • Issue 8 Summary:  
    • No voicemail support for EM users that aren’t actively logged in
    • Issue 7 Fixes/Workarounds/Requests: 
      • Cisco Bug/Defect has been logged (Bug ID CSCub83528)

Issue 9: Bulk Import Tool

The CUCMBE3K supports a feature/tool called the Bulk Import Tool. Like the name says, it allows one to upload a large portion of user details and phones to the CUCMBE3K instead of manually adding them one by one.

The issue is that in the CUCMBE3K interface, a user configuration has both a “PIN” and a “Password”. The Bulk Import Tool does not have a column or field to specify the “PIN” and thus one has to go to each and every single user manually and configure their PIN.

  • Issue 8 Summary:  
    • No user “Pin” number support in “Bulk Import Tool”
    • Issue 7 Fixes/Workarounds/Requests: 
      • Cisco Bug/Defect has been logged (Bug ID CSCub86268)
      • Manual configuration of each user “Pin” field

Issue 10: Auto Attendant “Dial-by-Extension” Feature issues

It was noted that Dial-by-Extension is not supported for Extension Mobile users as well as Departmental handset.

  • Issue 10 Fixes/Workarounds/Requests: 
    • Cisco Bug/Defect has been logged (Bug ID CSCuc59234)
    • No work around

Issue 11: Caller ID –amends user extension to external Caller ID

The CUCMBE3K amends the extension of the user/handset to the caller ID; so for example, if extension 123 (assuming 3 digit extension length) is making an external call to the outside world, the CUCMBE3K will present a Calling Number of 0x xxxx x123 (where x is the numbers of the dial plan)

This presents an issue if that extension number is not present in the number block on the PSTN side. I.e if 0x xxxx x123 is trying to call when the customer numbers purchased on the PSTN service only go up to 0x xxxx x100, the 123 call will fail. As a result you need to add a “Calling Pattern Translation pattern”. However this is not available in the CUCMBE3K interface and thus a Cisco TAC needs to be made

  • Issue 10 Summary:  
    • No option to configure Calling party translation via CUCMBE3K interface
    • Issue 10 Fixes/Workarounds/Requests: 
      • Cisco Bug/Defect has been logged (Bug ID CSCuc59156)
      • Log Cisco TAC

Other Feature limitations

Just some other feature limitation that I thought may be worthwhile listing

Auto Attendant – no multilevel function

No auto-answer is supported despite the handsets supporting it i.e. 6921’s

No paging/intercom is supported

No modification of 7900 background images is supported – despite the 7900 handsets supporting this feature.

There is no file management interface, so no option/ability to manage firmware manually etc.

2 REPLIES 2
Cisco Employee

CUCMBE3K Experience and Issues Identified

Brian,

Thanks for being a Cisco partner, working with TAC on resolving some of the issues you faced and taking time to provide feedback.

We have taken the feedback seriously and will work on addressing them in upcoming release.

Sanjay

Enthusiast

CUCMBE3K Experience and Issues Identified

1,2,7 are in the works. Any Customer defect will likely be fixed soon. The others we are definitely looking into with a lens