cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Announcement“Cisco Design Thinking Workshop”. Cisco Small Business is excited to invite its Silicon Valley customers to an exclusive interactive one-day session between customers and product Managers.  If you are interested in this exclusive workshop, please fill out the Registration Form. For more information, please check out our FAQ


Get the latest new and information the November issue of the Cisco Small Business Monthly Newsletter

1323
Views
0
Helpful
23
Replies

CUE is in use most of the time on UC520

Hello guys,

I have an issue I can't resolve with the CUE on my UC520. We have been having problems lately with users mailboxes being busy or in use. I am having to go into the CUE and unlock mailboxes to free them up. it is happening more and more often. It is happening on our GDM as well. I have involved TAC on it but could not get a answer on what the cause is. Any suggestions?

Everyone's tags (4)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Enthusiast

CUE is in use most of the time on UC520

1. Reboot CUE (this resolves this issue 95% of the time)

2. Upgrade firmware if not on the latest. (Be sure to do a full data/config backup and also a backup of the text configuration -- CUE upgrades have blown up on me more than once)

Also, are you using IMAP? IMAP has some weird bugs that can cause this as well.

View solution in original post

Rising star

CUE is in use most of the time on UC520

Hi Lewis,

I dont suppose you can do a debug on the SIP connection or the Dial-peer to the users mailbox for us could you?

I suspect that the SIP connection is not going through the clearing process properly and there is a hung session, sometimes this can be fixed by altering/changing the SIP dial-peer to the CUE to be more aligned with what it is expecting.

But as the suggestion above states, normaly a reboot can flush this, but it probably wont take long for it to return, and an upgrade of the system might resolve it, but it could also introduce other problems if your configuration is not sound and having problems.

Cheers,


David Trad.
davidtradconsultinggmail.com

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

View solution in original post

23 REPLIES 23
Enthusiast

CUE is in use most of the time on UC520

1. Reboot CUE (this resolves this issue 95% of the time)

2. Upgrade firmware if not on the latest. (Be sure to do a full data/config backup and also a backup of the text configuration -- CUE upgrades have blown up on me more than once)

Also, are you using IMAP? IMAP has some weird bugs that can cause this as well.

View solution in original post

CUE is in use most of the time on UC520

Hi Daniel,

thanks for the response. I have done the reboot a few times already and it keeps coming back. I am looking into the firmware, however, it was recently upgrade a few months ago. This client is not using the IMAP feature. it appears to be as if there are to many people on at the same time. However their call volume has not really changed. I will post some config info and some debug, however, I am logging in remotely so it is hard to simulate when no one is there. thanks again.

Rising star

CUE is in use most of the time on UC520

Hi Lewis,

I dont suppose you can do a debug on the SIP connection or the Dial-peer to the users mailbox for us could you?

I suspect that the SIP connection is not going through the clearing process properly and there is a hung session, sometimes this can be fixed by altering/changing the SIP dial-peer to the CUE to be more aligned with what it is expecting.

But as the suggestion above states, normaly a reboot can flush this, but it probably wont take long for it to return, and an upgrade of the system might resolve it, but it could also introduce other problems if your configuration is not sound and having problems.

Cheers,


David Trad.
davidtradconsultinggmail.com

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

View solution in original post

CUE is in use most of the time on UC520

Hi David,

I will post some config info shortly and you can tell me what you think. Thanks again both of you.

Lewis

CUE is in use most of the time on UC520

Here are a couple of the Dial Peers.  I can't do the debug yet, but will get some today. I hate to over tax the system with debug.

dial-peer voice 2001 voip

mailbox-selection last-redirect-num

description ** cue auto attendant number **

translation-profile incoming MainNumber-AA_Called_25

translation-profile outgoing PSTN_CallForwarding

destination-pattern 3098

b2bua

session protocol sipv2

session target ipv4:10.1.10.1

voice-class sip outbound-proxy ipv4:10.1.10.1

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 2012 voip

description ** cue prompt manager number **

translation-profile outgoing PSTN_CallForwarding

destination-pattern 3097

b2bua

session protocol sipv2

session target ipv4:10.1.10.1

voice-class sip outbound-proxy ipv4:10.1.10.1

dtmf-relay sip-notify

codec g711ulaw

no vad

Rising star

CUE is in use most of the time on UC520

Hi Lewis,

Can you please change those dial-peers to look like this:

"dtmf-relay rtp-nte"

I wont comment on the other stuff as I don't know enough about your configuration, I can make assumptions but that would be harmful with not knowing more information.

But make that change as I suspect it will be more suitable, if it doesn't work then it is easy to revert back.

Cheers,


David Trad.
davidtradconsultinggmail.com

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Enthusiast

CUE is in use most of the time on UC520

David:

That will only work if CUE is configured to match, no?

Assuming that DTMF to CUE currently works, we can infer that it is configured to SIP-NOTIFY, not RFC2833.

In any case, SIP-NOTIFY is a valid method for DTMF... it really shouldn't cause any problems.

Lewis: You mention two different error scenarios... what are the exact error messages you are getting?

-Dan

CUE is in use most of the time on UC520

HI Daniel,

I don't know what the error message is, the users are complaining that it rings busy when they check voicemail.

Enthusiast

CUE is in use most of the time on UC520

Interesting, I had assumed you were getting the "Mailbox is in use, contact your administrator" message.

A busy tone is something else entirely.

Have you been able to capture a SIP trace while this is happening?

CUE is in use most of the time on UC520

here is another config for the integrated module.

interface Integrated-Service-Engine0/0

description cue is initialized with default IMAP group

ip unnumbered Loopback0

ip nat inside

ip virtual-reassembly in

service-module ip address 10.1.10.1 255.255.255.252

service-module ip default-gateway 10.1.10.2

I also stated that they were not using IMAP, however, I may be wrong on that. I have noticed a few mentions about IMAP in the config.

CUE is in use most of the time on UC520

ok guys, here it is. The final answer.

After going through the CUE config, we noticed that the IP address on the CCN Subsystem SIP was wrong.

ccn subsystem sip

gateway address "10.1.1.1"

dtmf-relay sip-notify

end subsystem

the IP should have been 10.1.10.2

interface Integrated-Service-Engine0/0

description cue is initialized with default IMAP group

ip unnumbered Loopback0

ip nat inside

ip virtual-reassembly in

service-module ip address 10.1.10.1 255.255.255.252

service-module ip default-gateway 10.1.10.2

after changing this, the system has worked so far. Crazy thing is, this has been like this since the beginning of the year when cisco tac helped us to rebuild the CUE when it went down before. Anyway, seems to be fixed now, I hope. I will keep you posted if it changes. thanks for all your help.

CUE is in use most of the time on UC520

by the way, Dave, I gave you points because you were correct on it being an issue with SIP and it getting hung. thanks again for all the help both you guys gave me.

Highlighted

CUE is in use most of the time on UC520

OK, guys. issue never went away like suspected, just less frequent. I am having to unlock users daily. If  I wait for about an hour or so, they free up themselves. weird. I know we have a "maxsession=6" and I was wondering if that could be the issue. if it is, how do we upgrade this or are we stuck with 6 sessions?

Enthusiast

CUE is in use most of the time on UC520

The number of sessions to CUE is fixed on the UC500 platform.

Have you checked "show ccn call application" while this problem is occuring?

Also, what specifically are you doing to "Unlock" mailboxes?