cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Please be advised, the GuideMe Wizard is no longer available on the Small Business Support Community. For search capability please use the community search field to find content related to Cisco Small Business documents, videos, and discussions.
942
Views
0
Helpful
3
Replies
Highlighted
Rising star

DID Mapping and CCA 3.1.1 Issues

Hi Team,

Today during an installation I had to redo some DID mapping using CCA 3.1.1 (This system was configured using CCA 3.1), and I ran into some very annoying and problematic issues.

Firstly in the staged configuration of the system on the LAB bench (Telephony Wizard Setup) the DID mapping went smoothly, everything was done as I had instructed it to do. However today when I had to go through and re-map quite a few of the numbers, I hit disaster after disaster.

Issue as listed:

  • If you remove a DID Range that is mapped, CCA will not allow you to re-map that same range again, it continually errors out and says that the range does not map the extension range (Which is WRONG WRONG WRONG!!!)
  • If you Exit out of CCA and return back in (Done to flush out anything cached in CCA) it comes back with a configuration that does not match that which is on CLI
  • IN order to get mappings done after the fact, you have to go through and do it DID number by DID number and can no longer do ranges... This results in an exceptionally large translation rule/profile mapping which is just huge

If you remove any DID mappings CCA 3.1.1 is also reconfiguring the CLID from the number I had chosen to the first number in the range (WHY??????) and to make matters worse it removed any of the static configuration and just left one there for all outbound calls to use, so no individualized ones

I have the client working in a manner that is suitable now, but the frustration was setting in, systems are staged before going out to a client to avoid embarrassment and issues like this plaguing a deployment, but alas this is becoming increasingly harder to avoid and simplicity is becoming harder to come by as well.

I do not have the time to try and replicate this ina LAB environment given that so many installs have come out of the wood work at the same time, but I am CERTAIN that this is a bug, it has to be as I have never hit this issue on any previous setups and I have done this setup and after the fact configurations more times than I can count.

Is it possible for the Cisco engineering team to work this up in a lab, the scenarios is as follows:

  • 100 number In-dial
  • Certain groups are mapped to individual extensions, other groups are mapped to a singular extension (Being the reception phone)
  • Using the Telephony Wizard you create this mapping first
  • Once the installation is complete you modify at least one of the groups be removing it and then reinstating it either as the same or a partial portion of the group
  • Extension range is 2XX

If you require any further information to reproduce this then please let me know...

Cheers,


David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Everyone's tags (3)
3 REPLIES 3
Beginner

DID Mapping and CCA 3.1.1 Issues

Hi David,

I am sorry for the frustation you have experienced, and thank you for posting your issues. I don't have any answers for you yet, but I did not want this post to get lost (this at least get its it in my history!).

I am confident there is more than one bug here, but it will take some time to pinpoint all of them.  An important question in terms of reproducing them inhouse: what kind of trunks?  Since you used the wizard, I am thinking PRI?

For CCA Incoming Dial Plans, not much has changed in the last several releases.  And there was certainly no change between 3.1.0 and 3.1.1.    Prior to 3.1, there were a lot of strange behaviors caused if there was a dash ( - ) in the Descripiton field; the fix in CCA 3.1 was to disallow that char on the UI.  But you say that this was all configured with either 3.1 or 3.1.1? 

The other recent addition (circa 3.0) was the integration of fax mail, to apply service applications on the inbound peer.  Do you have faxmail setup?

The CCA Troubleshooting log for that box would be immensely helpful also  (Help > Support Information > Troubleshooting Log).   The peritent data may be long gone if you have been busy with other installs, but it is a godd idea to grab one whenever you experience something like this using CCA.

Laura

Rising star

DID Mapping and CCA 3.1.1 Issues

Hi Laura,

I am back out at the clients site today to try and finish the build of and will try and obtain all relevant logs, but given this is a large organization their phones are constantly ringing so I cannot put the system in an unwanted position otherwise they might burn me at the stake

Thank you for your reply though

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Rising star

DID Mapping and CCA 3.1.1 Issues

Ahhhhhhhhh... This install is scaring me badly

10 SPA525G2 deployed all with park slots on the first 3 available buttons, and I hit that UGLY...NASTY...INSANE bug of the phones crashing when they put a call on park and then try to retrieve it, BUT WAIT!!!! There's more, with 10X 525G2 phones on the system, WOAH!!!! It sends the UC-560 into total meltdown and then cascades down to the network and then ~~~BLANK~~~ Everything off-line everything dead.... BUT WAIT!!! There is still more the RC firmware that I was given just would not work on 8.2 it worked on the previous SWP but this one, NOOOOOOOOO the TFTP server first wouldn't take it, then after some forceful persuasion I moved onto the Telephony-Services section, NOPE!!! GAAAAAAAAAH!!! I just gave up, never have I don't that EVER

Here is the real COOL one though phones were ringing each other phantom, nothing was showing up on the CLI on any debugs and I turned on every debug I could think of, I almost called the Phsyc Hospital to come and take the system away, I think it had suffered a bad dose of Bi-Polar, I have never seen this in 4 years... EVER!!

After the staff (30 of them) were sent on an early lunch I was able to save the configuration and then power cycle the unit, this took away the majority of the problems with the exclusion of the PARKING a call issue, that still exists and sadly I had to leave the site without working out an alternative to using them, I am crossing all fingers the system stays upright until I can schedule in another visit..

But in all seriousness, I have never seen so many bugs that are major ones on the UC-500 series, now couple that with CCA issue, and I think we have a disaster waiting to happen. I have never in 4 years doubted or questions Cisco's QA process (OK maybe in jokes from time to time), but today had me wondering what on earth is going on, never have I ever been so concerned about installing a Cisco, and if I could halt all the installs that I have to do now I would, but that would create a disaster much to large for me to control, so back to finding ways in mitigating risk.

Back to my cave I go bruised and winded

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *