Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


Drag and Drop SPA Phone Loads to UC5xx working

I have heard a few complaints over the last few months with Drag and Drop of the Phone Loads for SPA 5x5 and 525 models

You CAN download new phone load like 7-4-6 from CCO and “drag and drop” the .bin file inside it (there is usually a readme and an exe file for using a different deployment load tool) onto the UC500 topology icon.  This has always worked for me so I was always puzzled when a saw the occasional “It don’t work” post on the community.

Yesterday I may have stumbled into the answer.  Or at least one possible scenario that may help some.

I wanted to go back to 7.4.4 to try something, so opened the UC540 8.0.4 zip file and then the PhoneLoads zip within that and then into the Phone directory and opened the 525 files.  I dragged and it wouldn’t drop.

I then EXTRACTED the file from the zip to my PC.  Then it worked.    Perhaps it has something to do with this for others where it didn’t work?

Dragging from within a zip archive doent seem to work for me.  If anyone sees this, extract the file first then it may work for you.


Accepted Solutions

I was able to drag and drop the .zip phone load file in 64-bit Win 7, but you need to drop it exactly into the compact flash slot of the uc520 icon, near the top of the topology.  I could not drop the .zip into any phone or into any other location of the uc520.

View solution in original post

Scott Martin

Hi Steven,

I am running CCA 2.2(5) with software pack 8.0.4 and the drag and drop phone loads simply don't work on Windows 7 x64. I am trying to do it with the SPA525G 7-4-6 firmware.

I have extracted the phone loads as you suggest and am dropping the .bin file - I have tried dropping on the phones, the UC540 itself, and basically I just get the circle with the line through it anywhere within the CCA window.

Has this been tested on Windows 7 x64?

Can you check these things for me?

I have seen this work on Windows 7.  Got to be something with Windows or connection.

I was able to drag and drop the .zip phone load file in 64-bit Win 7, but you need to drop it exactly into the compact flash slot of the uc520 icon, near the top of the topology.  I could not drop the .zip into any phone or into any other location of the uc520.

Should I be throwing salt over my left shoulder at the same time?

Either way - yes I have looked at the requirements document and fit the bill, and no, dragging the zip to the CF slot on the topology (or front panel) view does nothing either.

To clarify, I am trying to load the spa525g-7-4-6 phone load, and have tried both the fully extracted .bin and the .zip to no avail.

Opening a case will work better than throwing salt over your shoulder :-)

Hi Steve,

It's hardly worth opening a case on my end - as good as the Small Business Support team are, the cases are rather time-consuming for such a small feature. Plus, I already have two outstanding to manage.

I have simply updated the phone firmware individually using the SPA's web page firmware update.  Eventually I will TFTP the phone load to flash and update the config with CLI - which will be faster than logging a case.

I will add a CCA feature request for the Phone Load Management section - this should allow individual phone loads to be uploaded - rather that just a software pack.



You probably checked this already but be sure you have admin rights on the PC. This has actually solved a few TAC cases.

Hi Ray,

I'm an admin on the PC. I've also tried 'Run As Administrator' in Win7x64 however it makes no difference.

John Gawf


There are quite a few threads about phone loading not working.  It also didn't work for me, however I think there is some mis-understanding on how it works and I didn't have it right until I read the CCA 3.0 manual.  Here are my experiences:

1) Using the Phone Upload dialog (Maintenance->Phone Load Management) in CCA doesn't work wtih the .zip phone downloads from CCO.  This only works with the UC500 software packs.  It is mis-leading since the file dialog only accepts .zip archives and that's exaclty what those phone loads are.  I would like to see the the CCA software give a better diagnostic when it fails (say it only applies to the UC500 software packs).

2) Drag and drop only works with the .bin phone loads inside the archive and not the whole .zip phone archive.  This also isn't clear unless you've read the manual.  I called the SBSC today and they weren't clear about what gets dragged.  "Just drag and drop the phone load" is what they told me.

3) When using Windows 7 (32 or 64) you must disable the User Account Control Settings to use drag and drop.  I found this on pg. 65 of the CCA 3.0 manual.  To disable the UAC settings go to Control Panel->User Accounts and Family Settings->User Accounts->Change User Account Control settings.  Pull the slider and disable completely.  You must re-log in to that User or reboot for the setting to take place.  It gave me a complete new desktop for that user.  SBSC also didn't know about this.


We had exactly the same problem.

After disable the UAC (user account control), the problem was solved.

We can now use drag an drop !

A couple of weeks ago I spent hours on uploading the 7945/7965.  I had the zip file stored on my Widnows XP Pro desktop and would fail every single time.  I was using CCA3.0 (1).   Tried several times.  I thought that may be the file is corrupt.  So I downloaded it again, but this time I saved it on the c:\temp folder.  Right off the root, instead of the desktop.  The upload went right through.  However for SPA50x, this trick does not make any difference.  For those you need to unzip the file and just upload the .bin file.  The zip file for the spa50x phones have other stuff which is not necessary or needed.

Recognize Your Peers
How would you describe your level of technical expertise?