Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


Error voicemail installation Failed while upgrading UC520 using cca

I am trying to upgrade our UC520 using configuration assistant and software pack It seems to go all the way to voicemail and then it fails. This is what CCA is now saying for my version information. It seems partially installed. Any ideas on what could be going wrong.

uc520 details.JPG


I have tried installing the whole software pack and upgrading just the voicemail and it still won't work. Please Help. I checked in the status and it always fails at voicemail boot loader install. In the staus window this is what i get.

bl_boot_helper_cmd tftpboot 0x4000000 cue-installer.uc500.8.0.3
Using internal device
TFTP from server; our IP address is; sending through gateway
Filename 'cue-installer.uc500.8.0.3'.
Load address: 0x4000000
Loading: * T T T T T T T T T T
Retry count exceeded; starting again

Anyone have an idea?

Hi bgibson.PT

I have exactly the same problem. I tried it but the software package seems updated and the voicemail don't.

I think we will have to upgrade it through CLI.

I didn't try it yet.


Hi bgibson,

At this point in time I would highly encourage you to contact SBCS support and have them look over this issue for you, if the AIM module goes into a failed state it is unlikely that CCA can recover from it and your case would need to be escalated to a high status which would then require some CLI configuration to reinstate the system back to normality.

I have seen this issue before, and have had to rebuild the AIM module via CLI by getting into the upgrade mode just before it goes into boot mode, it is quite complex to explain the process on here (Although if you search under my name for previous posts you will find a complete write up on it).

Contact support if you wouldn't mind and log the case with them and get them to help you out on it, this is why we all pay for that support and we all should use it to its fullest where possible.



Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

Hi all

I have exactly the same problem!

Is there a solution to this problem?

I hope for a quick solution




I'd like to look into this, however the UC520 isn't supported by SBSC so you won't be able to log a case with us, you'd need a smartnet contract and would have to contact TAC. 

Maybe we can get a resolution here on the forum.  Like David mentioned, first I'd like to verify the state of cue, by either running cue diagnostics from CCA or from a putty session run the command "ser int 0/0 session", you'll be prompted to login, hit enter at the blank prompt and you should have an enable prompt for e.g. 10-1-10-1# is good, serviceengine> is bad.  Once we know the state of cue then we can proceed.



I tried the downgrade from 8.1.0 it to 8.0.5 but the problem it's not changes.

I used the Laptop connect directly the F0/0 port.

During the download I used Wireshark and I observed that in a SYSTEMATIC WAY, there are two packets UDP generated by the laptop with the number of block 3 and 9, to which the UC520 always responds with an "ICMP unreachable".



Correct me if I am wrong, but you "only" need to connect to FA0/0 to repair the UC520 when it is in ROMMON mode.

I did the boot helper repair by connecting to one of the ethernet ports. Have you made sure the firewall is disabled on your pc. Do you get an ip from the UC?


We had a similar problem with

"TFTP from server; our IP address is; sending through gateway

Filename 'cue-installer.uc500.8.0.3'.

Load address: 0x4000000

Loading: * T T T T T T T T T T

Retry count exceeded; starting again"...

It turned out that interface Integrated-Service-Engine0/0 was shutdown... So a simple "no shutdown" command solved our problem.

Hope this helps,



I don't know if this issue is solved yet, but am experiencing the same problem here.

Had to reinstall completly as when it failed the UC520 would boot into rommon.

Repaired with this link :

Then tried to repair CUE as you did bgibson with the boot helper. "kinda" got it working as I was able to access it then from the CCA, but it would still give me errors when trying to upgrade it again.

Then opened a case with Cisco and after few minutes of searching in there internal memos, seems like there is a known bug with the upgrade to 8.1.0

He suggested me to downgrade it to 8.0.5

Will let you know how it goes as it is the only solution I have right now.

As for your problem with the

"Loading: * T T T T T T T T T T

Retry count exceeded; starting again"

I would make sure your TFTP server is running properly, that you don't have any firewall on.

Are you able to set your pc so it gets an IP from the UC. normally, the UC should be able to access this ip address and grab the files from TFTP server...

Vittorio Alfieri

I'm pretty sure mdube nailed it. You can check if anything else is occupying your tftp or ftp port by trying to run a tftp server on  you computer such a Solarwinds Tftp server. If it starts, it means the port is free, if it doesn't that means something else is using the port. (Turn it off, and close it so that it doesn't conflict with CCA)

The other thing I would do for testing is extract the from the, and upgrade only the voicemail to get past that step and save time. Forget about regional packs for now.

I couldn't get it to upgrade because Teamviewer (which was how I was connecting the PC attached to uc520) occupies the FTP port, and didn't let the CCA start FTP. I fixed this buy using RDP instead.

Generally if the transfer fails, it seems that there is a connectivity issue. I set up the CUE as part of the same VLAN as the switch VLAN of the uc520, so that I could ping it from the PC with CCA. Using this setup it worked like a charm.


Here is the CUE config on the IOS side:

(Where vlan 10 is the data vlan for the switch on the uc520)

conf t

interface Integrated-Service-Engine0/0

ip unnumbered Vlan10

service-module ip address

service-module ip default-gateway



route Integrated-Service-Engine0/0


I had this exact same problem but found the solution and it was so silly on my part I was ready to kick my self many times.  Almost as silly as not putting ip classless in a router configuration. 

So here was the soltuion.  Turn off the firewall running on Windows 7.  I logged out and back in under the local Administrators account on my workstation, disabled the Norton FIrewall and the upgrade went without a problem.

But I do have a follow up question.  When I try to configure voicemail it hangs right here and never gets past this point.

kiyam kadir


issue resolved easily.

make sure that the tftp PC from which you are running CCA or TFTP server can reach the integrated-service-module interface IP address and the CUE modules IP address.

and it will work like a charm.

sorry for my initial comment but i still believe that CME rocks and CUCM is far better.

appreciate any feedback about my solution