cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

589
Views
0
Helpful
4
Replies
thawkins
Beginner

FXO Ports Not Disconnecting - Voicemails Reappearing

I have a UC540 (current software version) and I recently setup an auto attendant.  Everything is working good there, but when an outside callers dials an extension and gets a users voicemail the fxo port doesn't disconnect after the caller hangs up.  This is resulting in voicemails with 240 seconds of dead air which is causing the voicemail boxes to fill up quickly and won't allow any more messages to be received.  If the caller stays on the line and chooses the option to send the message by pressing #, the message goes through and the port disconnects properly.  If the user answers the call and speaks with the outside caller, the port disconnects properly when either party hangs up.  I've tried changing the pstn trunk settings on the ports for different disconnect signaling and turned off battery reversal.  Nothing seems to help.

Also, I have users complaining that on some mornings (like today) when they come into the office, their mailboxes are full of old voicemails from the last couple of weeks that they have deleted previously.  This is also causing voicemail boxes to fill up.

Has anyone else had problems like these?  Thanks in advance.

4 REPLIES 4
Nathan Compton
Enthusiast

You may have to play with the supervisory disconnect options in CCA under the PSTN lines.  You can try the different options until one works.  Also, some rural carriers around me don't turn supervisory disconnect on by default.  I've had to fight with Embark and Alltel to get this turned on before.

Regards,

Adam Compton

Thanks for the info Adam.  I have tried all of those settings on the PSTN Trunk settings for each voice port with no luck.  I also called CenturyLink and they enabled the feature that they call "cutoff on disconnect".  That also has not helped.

I've had this same problem with several of these systems (almost everyone UC500 with FXO ports that I've ever deployed) and these are the things that are always recommended and they never seem to help.  I've even had this same problem on some CUCM environments when outside callers connect through analog lines to a Unity call handler auto attendant.

It is most definitely a supervisory disconnect issue.  I looked up centurytel and they actually have a glossary with a definition of it:

1.34 Disconnect Supervision

An on-hook supervisory signal end at the completion of a call.

I'm not sure if this is the exact name of the feature they need to turn on or not.  The only thing I can suggest is to toggle the supervisory disconnect on the fxo line, make some test calls, and find one that works.  No magic bullet for this issue I'm afraid.

Adam Compton

David Trad
Rising star

Hi Travis,

This is typical of FXO based services and why I evangelize the migration to ISDN as you do not get the same issue with ISDN services

This is typical in the following scenarios:

  • Call forwarding (Follow-me) to outside numbers
  • Call Transfers to outside numbers
  • SNR (Single Number Reach)
  • Call Conferencing if you drop out but all the other lines do not tare down

Not so bad when the far end is a mobile device, 1 out of 5 might create a failed tare down

Especially bad when the far end is a Voice Mail depository, the tare down may occur when you max our the VM's limit

This becomse a real problem when it starts to lock the ports up and a "Shut" - "No shut" does not work to bring the port back alive, and a reload is required.

Now you can try the following but it would be my guess that your chances of success will be not so good

  • Change the attenuation of the FXO port
  • Change the Gain of the FXO port
  • Try each supervisory disconnect method

If you can change it to ISDN service then I highly recommend it even if it is a little more expensive, the reduction in headaches is much much better

Just my thoughts, and I know this does not solve your problems, I have spent hours... NO days trying to resolve these problems before, please do not do that or you will loose your sanity.

(PS) Hit this problems with the UC-320W so many times It is the one thing I fear the most about having these sold, but alas it is what it is and what it comes with until Cisco offer the BRI version

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
This widget could not be displayed.