cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
594
Views
0
Helpful
4
Replies
Highlighted
Beginner

FXS phone answers with "TransferButtonPress"

Hi,

I have a problem with analog Siemens wireless phones. Most of the times 9/10 you have to answer incoming calls twice before the call is connected at both ends. Under "debug ephone state mac-address (FXS port mac address)" I see in the log that the call is answered and then it says "TransferButtonPress".

When I tried this with the customer 2 out of 3 calls went wrong and 1 succeded answering on the first press of the answer button. All of them is captured in the debugs attached. I've cleaned up the debugs so the incoming number is 099100000, called number is 8081.

Failed call:

020212: ephone-22[21/2][AN75D016E9A0003]:SkinnyDisplayCallInfo calledName=Kassan Dect

peer_vdb is NULL for DN 8, chan 1 at SkinnyIsPeerNonSCCP

020213: sccp_endpoint_vsa_query:Invalid phone for dn 9 chan 1

020214: UpdateCallState DN 9 chan 1 operating in mode 6

020215: ephone-22[21/2]:OFFHOOK

020216: ephone-22[21/2]:---SkinnySyncPhoneDnOverlays is onhook

020217: ephone-22[21/2]:Ringer Off

020218: ephone-22[21/2]:ANSWER call

020219: ephone-22[2]:SetCallState line 1 DN 8(-1) chan 1 ref 44988 TsOffHook

020220: ephone-22[21/2][AN75D016E9A0003]:Answer Incoming call from ephone-(-1) DN -1 chan 1

020221: ephone-22[21/2][AN75D016E9A0003]:Incoming Answer: can't find ephone calling DN 8 chan 1

020222: defer_start for DN 8 chan 1 at CONNECTED

020223: ephone-22[2]:SetCallState line 1 DN 8(-1) chan 1 ref 44988 TsConnected

020224: ephone-22[21/2]:SpeakerPhoneOffHook

020225: DN: 8, CHAN: 1, voice_hcmask: 0x890000F

020226: DN 8 chan 1 Voice_Mode

020227: ephone-22[2]:OpenReceive DN 8 chan 1 codec 4:G711Ulaw64k  duration 20 ms bytes 160

020228: ephone-22[2]:OpenReceiveChannelAck:IP 10.1.10.2, port=17306, dn_index=8, dn=8, chan=1

020229: ephone-22[2]:StartMedia 10.1.1.1 port=2000

020230: DN 8 chan 1 codec 4:G711Ulaw64k duration 20 ms bytes 160

020231: ephone-22[21/2]:TransferButtonPress

020232: ephone-22 TRANSFER using transfer-system full DN 8 consult transfer

020233: ephone-22[21/2]:Transfer with consult line 1 DN 8 chan 1 using second line 1 DN 8 chan 2

020234: ephone-22[21/2]:Consult for line 1 DN 8 chan 1 using line 1 DN 8 chan 2

020235: ephone-22[21/2][AN75D016E9A0003]:HoldButtonPress (allow_toggle = 0)

020236: ephone-22[21/2][AN75D016E9A0003]:HoldButtonPress HOLD activated for DN 8 chan 1

020237: skinny_hold_resume: dn=8 chan=1 s2s=0 state=9 hold=1

020238: ephone-22[21/2][AN75D016E9A0003]:SetCallState line 1 ref 44988 state 10 TsCallTransfer ignored

020239: ephone-22[2]:SetCallState line 1 DN 8(-1) chan 1 ref 44988 TsHold

020240: ephone-22[2]::callingParty 099100000

4 REPLIES 4
Highlighted
Beginner

How far away is the Analog phone from the FXS port and how many 66 blocks is it jumpered across?  Have you tried an alternate analog phone?

Highlighted

The distance is about 50 m/165 ft. The cable is patched one time 1 ft from the PBX and then using a pair in a Cat6 cable that goes all the way to the phone. I haven't tried another phone yet, going out to the customer site tomorrow and replacing it.

Highlighted

Tried plugging the analog phone into the FXS port directly and rule it out as the cause.  Also, find another "copper pair" to use instead of using an extra "copper pair" in a CAT 6 cable.  There is a reason for "twisted pairs"; you may be having some signal interference at that distance.  And finally, there may be a way to turn up the voltage on that port to allow for the long distance but this would be done at the CLI; out of band.  Call into STAC to have them amend it for you so that you stay within compliance with your support contract.  There number is 1-866-606-1866.

All the best,

Robcast

Highlighted

Haven't tried plugging it in directly. Will give it a go tomorrow though. The Cat6 cable is not shared with data, only analog lines for a couple of Siemens phones, is it still a source for disturbance? Unfortunaly the customer doesn't have a service contract registered on this UC.