cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter

698
Views
0
Helpful
5
Replies
Beginner

If the morning try to use the phone ... and any number of outgoing wind is cut into 3-digit????

Hi!!!

Yes,
this morning on the phone any number entered will be cut to 3 digits (on display) and then get a busy signal. I tried to reboot, nothing ...

I type 001555555... After pressing the dial for a moment the display shows the full number and immediately after 001, and of course 20 seconds after the busy signal! I hope this is nonsense and just go somewhere in the CCA to fix a flag, I do not see what could have caused all this! I have already done some testing on the dial-plan, it is ok! What can I check to find what produces the problem?

NB:

  • Another day I used CCA to take a ride in the configuration and check if everything was ok (a 'common' telephone connected to a FXS port could not make calls): quite regular, although there is nothing strange but does not work; now after two days the whole system is KO  :-(( I'm trying to make a comparison with an older saved configuration  but I have too many differences, argggggg!

  • The call is sent regularly, but the number is cut; the busy signal after about 20 seconds, is a consequence of the cut:
  • 000707: ISDN BR0/1/0 Q931: RX <- RELEASE_COMP pd = 8  callref = 0x86
            Cause i = 0x829C - Invalid number format (incomplete number)

73,

Arturo.

Everyone's tags (4)
5 REPLIES 5
Highlighted
Beginner

Re: If the morning try to use the phone ... and any number of ou

I do not understand!


Someone explained it to me??

I installed CCA 3.0.1 and I made a trip to the configuration. Then I activated the service, "fax to mail" in its panel and magically the phones are back to work.... Now the numbers are no longer cut!

By accident!? It was a problem created from the previous version (3.0) or what?

I see very few differences in the pattern and almost all attributable to the fax service to mail!

--- conf.before       2011-05-24 10:55:46.000000000 +0200
+++ conf.after       2011-05-24 12:48:53.000000000 +0200
@@ -19,7 +19,7 @@
boot-end-marker
!
!
-logging buffered 4096
+no logging buffered
no logging rate-limit

@@ -168,16 +168,16 @@
  request ANY sdp-header Connection-Info remove
  response ANY sdp-header Connection-Info remove
!
-voice class custom-cptone CCAleavetone
- dualtone conference
-  frequency 400 800
-  cadence 400 50 200 50 200 50
-!
voice class custom-cptone CCAjointone
  dualtone conference
   frequency 600 900
   cadence 300 150 300 100 300 50
!
+voice class custom-cptone CCAleavetone
+ dualtone conference
+  frequency 400 800
+  cadence 400 50 200 50 200 50
+!

@@ -393,7 +393,27 @@
  dspfarm
  dsp services dspfarm
!
+fax receive called-subscriber $d$
fax interface-type fax-mail
+mta send server 10.1.10.1 port 25
+mta send with-subject both
+mta send mail-from hostname 10.1.10.2
+mta send mail-from username $s$
+mta receive aliases 10.1.10.2
+mta receive maximum-recipients 7
+!
+application
+ service cca_fax_detection flash:/applications/faxmail/app_fax_detect.2.1.2.2.tcl
+  param fax-dtmf 2
+  param mode listen-first
+  param voice-dtmf 1
+  param prompt flash:/applications/faxmail/en_listen_first.au
+ !
+ service cca_offramp flash:/applications/faxmail/app_faxmail_offramp.2.0.1.1.tcl
+ !
+ service cca_onramp flash:/applications/faxmail/app_faxmail_onramp.2.0.1.3.tcl
+ !
+!

@@ -857,6 +877,7 @@
  no sip-register
!
dial-peer voice 4 pots
+ corlist incoming user-internal
  destination-pattern 304
  port 0/0/3
  no sip-register

@@ -1404,6 +1425,7 @@
  description ** fax onramp for outbound faxmail to CUE **
  service fax_on_vfc_onramp_app out-bound
  destination-pattern ^...$
+ information-type fax
  session target mailto:$d$@10.1.10.1


73,

Arturo.

Highlighted
Enthusiast

Re: If the morning try to use the phone ... and any number of ou

I don't know that we could explain this without seeing your full config, before and after making the changes.  If the number is being cut off, before dialing all the digits, I would suspect that there was an unwanted dial-peer, or ephone-dn in the config that was being matched, before the number could hit the wanted outgoing dial-peer.  With outgoing numbers, the dial-peer/ephone-dn matches happen after each digit, so the first match it finds, (In your case 3 digits.) is the one it will use.

Thank you,

Darren

Highlighted
Beginner

Re: If the morning try to use the phone ... and any number of ou

I nervously changed several things ... could be the problem with this dial-peer?

dial-peer voice 1800 mmoip
description ** fax onramp for outbound faxmail to CUE **
service fax_on_vfc_onramp_app out-bound
destination-pattern ^...$
session target mailto:$d$@10.1.10.1

Enabling and disabling the fax-to-mail has been removed and everything is back to work!

NB: in any case it did everything himself CCA 3.0; and tests of dial-plan made from CCA did not show any problem!

Thanks Darren,

Arturo.

Highlighted
Beginner

Re: If the morning try to use the phone ... and any number of ou

 

No, I can not have a relationship with what happened this morning! To double check I removed the mail to fax option and it works fine anyway! But I can assure you that throughout the morning there was no way to use the phones!!

73,

Arturo

Highlighted
Enthusiast

Re: If the morning try to use the phone ... and any number of ou

It is very possible that the dial-peer you listed could cause this issue, as it will accept any 3 digits.  But to be sure what the problem was, we would need to see the actual config at that time it was happening.

Thank you,

Darren