Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


Microsoft PPTP / GRE not working with UC320

We just upgraded our phone system to a UC320.  We are configured with the default VLAN settings.  I have added port forwarding for 47 and 1723 but when I try to cennted with the Microsoft VPN optin with my Windows 7 desktop I receive an error 619.  Does anyknow if this is possible with the UC320 adn what I should try to get this working again.  It worked with our old router.

Christopher Edgeworth
Frequent Contributor

Hi Scott,

Have you verified that PPTP works LAN side with both hosts on the same LAN subnet?  Assume your port forwards are for TCP protocol.  Make sure you can ping your LAN side host from the UC320 (Status -> Support Tools -> Ping).  You may need to put a call into the Small Business Support Center so they can look at a few things interactively with you.


Yes I can ping the internal IP number of the Windows server from the UC320.  The IP number is and returns a signal.

PING ( 32 data bytes
32 bytes from icmp_seq=0 ttl=128 time=1.3 ms
32 bytes from icmp_seq=1 ttl=128 time=0.3 ms
32 bytes from icmp_seq=2 ttl=128 time=0.3 ms
32 bytes from icmp_seq=3 ttl=128 time=0.2 ms
32 bytes from icmp_seq=4 ttl=128 time=0.4 ms

--- ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 0.2/0.5/1.3 ms

Brandon Turpin
Cisco Employee

Hi Scott,

Are you trying to connect to a Windows Server on the inside of the UC320?  If you take Wireshark captures on both the server and the client, do you see any GRE packets in the captures?  Since there isn't an option to setup forwarding for GRE (protocol 47), we're looking into how the UC320 handles GRE pass-through. 



We have a static IP service with Time Warner.  Thta service is connected to the UC320 FXS port.  Then we have our SPA504G phones attached to the a CIsco Switch that is attached to the UC320.  Our desktop computers are connected to the SPA504G.  We have VLANs configured.  The phones are 10.1.1.X, and our computers are 192.168.31.x.  The Windows Server is connected to the Switch and is  We can ping it from the UC320.  I have also port forwarding configured for ports 1723, and 47 (tcp) pointing to  Our system has firmware version 2.1.0 (22).  I haven't configured or run wireshark.  I will consider it if you feel it will help.

Hi Scott,

It looks like we will need a PMF for this.  We need to be able to setup forwarding for GRE (protocol 47), which is different than TCP port 47.  Please open a case with SBSC so we can work to get a PMF built for you.



Hi Brandon!

I've the same problem as Scott. Is the problem already solved or is there a workaround? At the moment I have installed Firmware 2.1.2 (1) on my UC320.


Hi Matthias,

We currently have a PMF to use as a workaround for this.  The PMF works for some people, but there may be some issues as Scott has mentioned.  Please open a case with SBSC to get the PMF.



Hi Brandon,

Any news about this issue?





Here is an update.  We have been forced to configure our UC320 by adding our Windows Domain Controller as a DMZ.  Then I have found by replacing my Linksys BEFSR41 in my home to a new Cisco E1200 router.  I am now able to create a PPTP VPN connection from my home (ONLY) which then allows me to RDP to our Microsoft Windows 2008 and 2003 Servers.  I have tried connecting remotely from other locations (Starbucks, Client Offices, Cell Phone Hot Spot, etc) and still can't.  I know the problem is the UC320 and I really hope this gets fixed since this is causing a problem for my company.


Hello.  So, does Portforwarding work at all on this unit? 

I am trying to do some portforwarding on my UC320.  I am using the ip address of as the default gateway for my LAN, which is the UC320.  I am using a Cisco SF302-08P Managed POE switch with an IP address of  From the UC320 i can ping the SF302-08P and visa versa.  However, when i try to port forward in the UC320 to the switch (so i can manage both remotely) it doesn't work. 

The Port Forward rule i'm using is as follows:

TCP/UDP Port 8090 forward to port 80. 

I have also tried many permutations of this rule using multiple ports on the WAN side (80, 8081) and just using TCP (no UDP).  All variations produce the same result - nothing!

Also, i do have http management enabled on the switch.  I can manage the switch just fine from my web browser just by entering  So that seems to be working as well. 


Hi Matthew,

You can use a USB memory stick on the UC320W and use the UC320W TCPdump tool along with Wireshark to try to figure out what is going on.  First capture on the WAN side and look for traffic coming into the box on TCP port 8090.  If you see that, then capture again on the LAN side and look for traffic from the same source IP address that should be destined to your switch destination port of 80 IP  If you are uncomfortable using these tools, a call into the Small Business Support Center can help.



Thanks for the reply.  Great idea.  I totally forgot about that TCP dump feature.  So, i went straight to the "horses mouth".  SBSC had me change the port from 8090 to 5000 and wala - it worked.  I asked why none of the other ports i tried worked.  His response, "i don't know, sometimes different ports work on different UC320s".  Happy it's working, but a little scared to put this at the head end of my customer's network because they are wanting to do some port forwarding to different servers on their network.  So, i'm crossing my fingers and moving forward!  Thanks for the reply in any case!


This widget could not be displayed.