Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


Problem with SPA525G2 and EHS

Hello guys,

So we have a client with SPA525G2 phones and he wanted to have a wireless headset on a few of them.

I got the Plantronics CS510 headset along with the APC-45 which is required for the EHS feature.

Now, the problem we are running into is that they simply can't take a call through the headset, nor can they hang up the call with it.

Pressing the button on the headset will simply "connect/disconnect" the headset from the phone, without having an impact on the call, weither they are on a call and want to hang up, or answer.

I have attached a few pics of this, hopefully it will help understand my problem...

ButtonPressedOff is of course when phone is idle, and headset is off

ButtonPressedOn is when I press the On button on the Headset, you can see that the communication between the phone and headset is working

ReceivingCallButtonPressedOn is when I receive a call, press the On button on the Headset, but cannot hear anything in the headset, because the call is still not answered

OnCallByPressingAnswerOnPhone is when I am on line, hear the other party through the headset, BUT had to press the answer button on the phone to actually take the call.

CallStillOnEvenWhenPressingButtonOff is when I want to hang up with the headset. I press button off, the headset disconnects from the phone, but the other party is still online and hears nothing, I still have to hang up manually from the phone.

I've ran "service phone ehookEnable 1" and recreated cnf files too, without any success.

And SPA525G2 are up to date, firmware 7.5.2a and UC560 is running on the latest 8.6.0

Thank you for your help!



Accepted Solutions

This is what I just got from Cisco

You are hitting the following bug CSCuc20443. 

There’s an open cdet for EHS not working in SCCP mode for SPA525.

EHS currently works in SIP mode only for SPA525.

From the notes: This issue may be fixed in Firmware 7.5.4

View solution in original post


Anyone got a suggestion, something I could test to see what is going wrong?



Does anyone have an idea as to what is happening with our system?

Roman Rodichev
Rising star

Have you been able to resolve this? My customer has the same issue. I was thinking of switching them to a mechanichal lifter, but I just realized that the other issue they have is that they don't hear incoming call ring in the headset, did you also have the same issue?



I opened a TAC with Cisco so they could help me figure out the issue.

She told me she had spoken with her back bone team (?)  :

I contacted my back bone team and also the support forum author about the wireless head set and they told me that  Wireless headsets  CS510 from Plantronics with the APC-45 is not supported . Cisco has not tested these headsets so they might work or they might not work.

So seems like it is not supported. I have replied that Plantronics actually sells those headsets as being compatible with the SPA525G2 and needs to know what would be compatible instead. I am waiting for an answer on that. Does your client have the exact same headsets, or is it another model/company? Because if it is different, I could add that to my TAC and in fact "proove" that it is not the headsets that are actually not compatible, but either the phone firmware or UC firmware...

Now, to complicate things I did try those headsets at another client's site. AND IT WORKS...

Only thing I can see that is different, is the bootstrap version, and the model of the UC. The one that is not working is a UC520, but it's working on a UC560

Consider the following :

Not working :


Cisco IOS Software, UC500 Software (UC500-ADVIPSERVICESK9-M), Version 15.1(2)T4, RELEASE SOFTWARE (fc1)

ROM: System Bootstrap, Version 12.4(11r)XW3, RELEASE SOFTWARE (fc1)

SPA525G2 phone firmware : 7.5.2a

Working :


Cisco IOS Software, UC500 Software (UC500-ADVIPSERVICESK9-M), Version 15.1(2)T4, RELEASE SOFTWARE (fc1)

ROM: System Bootstrap, Version 15.0(1r)XA3, RELEASE SOFTWARE (fc1)

SPA525G phone firmware : 7.5.1

I honestly don't have a clue, and am a bit deceived that the answer from Cisco will simply be : they haven't been tested, so it might work, or it might not. Meanwhile, Plantronics sells them to be compatible. And if this is not working, what else will??? I am not going to install a mecanical lifter, we are in 2012, this is such a legacy technology, EHS was specifically made to replace that technique...

Spent some time on the phone with Cisco and Plantronics today. Basically these EHS cables for SPA phones or the SPA phones themselves are the issue, EHS works one way only. The phone can talk to headset (headset button on the phone activates it), but pushing headset button on the headset doesn't activate headset function on the phone.

We went ahead with Jabra GN wireless headsets with manual lifter. The reason why we didn't go with manual lifter on plantronics headsets is because they have another issue. When the call comes in you hear very quite three beeps for incoming calls and there's no way to change that volume, so the person in the warehouse where it's loud can easily miss the call.


I find it hard to understand why would one setup actually work perfectly (with the UC560) and not working in another setup.

Still wondering if the System Bootstrap being in a different version would be the cause?

Because I will tell you this : I took one of the SPA525G2 phones at the client's site where it wasn't working, plugged it at the other client's and used the same headset setup. And it IS working there... So it's either firmware 7.5.2a that has a bug with it compared to 7.5.1, or the ROM System Bootstrap... Or maybe some hardware limitation of the UC520 vs UC560???

This is crazy I have to say.

I'm testing it on UC540, and it doesn't work.

I highly doubt that UC's bootrstrap version would cause this. After all it's a decision of the phone.


Will try to get my hands again on those headsets, and will see if it will work with firmware 7.5.1 on the non-working UC

If it works, then it's a firmware issue. But I am unsure I want to test it on the working UC, a.k.a. upgrade the 7.5.1 firmware to 7.5.2a and see if it's still working. Because if it is not working, and then I downgrade again and it is not working anymore, I will have one angry client to deal with...

Have you tried firmware 7.5.1?

This is what I just got from Cisco

You are hitting the following bug CSCuc20443. 

There’s an open cdet for EHS not working in SCCP mode for SPA525.

EHS currently works in SIP mode only for SPA525.

From the notes: This issue may be fixed in Firmware 7.5.4


I cannot see the cdet you mention as it contains proprietary information or so the error message says.

But basically, seems like it would be a known bug and should/could be fixed in 7.5.4?

I will forward that to the engineer that is handling my TAC support.

Thank you!!!



Thank you very much!

My Cisco engineer on my TAC case confirms this is actually what we are experiencing here too. I can't have access to the data of the bug as it seems to be private data, but anyway, seems like they are working on it.

Hopefully, this WILL be fixed in firmware 7.5.4 and not in a later release.

Thanks again!

If your clients don't really need the range (or expense), why don't you use a Blue tooth compatible headset with that phone..

Well the client actually wanted to have crystal clear sound, with a huge range, which they do get with the CS510/CS540 headsets.

Right now, it is working for one of our client (on a UC560), the other one (on a UC520) is willing to wait for firmware release as it is not critical right now for them.

That's good to know.  I didn't think it worked at all.

Recognize Your Peers
When looking for support content like videos or documents, how do you arrive at our support content?
Help us support you!