cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

1591
Views
0
Helpful
9
Replies
digitalchild
Beginner

Problems with FXO

Hello,

I'm having a couple of issues with directing FXO's inbound call routes to a particular phone.

I have FXO1 and FXO2 with inbound calls set to go to a single phone extension. FXO2 is the spill over for a line hunt setup with our service provider. People aren't often if ever directly dialing FXO2.

If someone calls FXO1 it shows up and can be answered without issue. If someone then calls FXO1 again, it spills over to FXO2 and cannot be answered.

I've tried setting up 2 shared FXO's each with only a single FXO's and the reception as the only member.

I then have 2 buttons, main line and mainline spill on the phone itself.

If someone calls in on FXO1 and its answered, then someone calls FXO1 again, the line hunt spills it over to the second line. The light on the phone flashes orange, but we are unable to pick up the call.

Putting the first call on hold and then trying to answer the second line by either hitting the flashing button or using the soft keys does not work.

The way we expect it to work is

FXO1 - Main Line

FXO2 - Spill Line

All incoming calls go FXO1, FXO2, VM.

If FXO1 is currently being used, FXO2 should be able to be answered by hitting the button on the phone just as if it was a single line. I've read through the manual and it says if the light is flashing orange you can answer the call by either picking up the handset or pressing the headset/speakerphone button then pressing the line button, this doesn't work.

This is all on an SPA508g, I have to be configuring a route or something incorrectly, can someone shed some light on this for me?

thanks in advance.

9 REPLIES 9
Christopher Edgeworth
Frequent Contributor

Hi Jaime,

How exactly are you configuring the buttons on the phone?  Did you configure each FXO as a Shared FXO Line button?  Or are you using PBX mode and routing the calls to a phone's primary extension?  What happens if you call the phone number dedicated to the second FXO (without a call on the first FXO)?  Can you answer the call then?

Can you make outbound calls using the second FXO line?

Make sure you do not have Do Not Disturb (DND) enabled on the phone you are trying to answer the call.

Chris

Hi Chris,

I tried routing them to the primary extension and that didn't work so I setup shared FXO's for each extension as below.

I have the following shared FXO's setup

Main Line - FXO 1 with reception as the only member on button right 1.

Spill Line - FXO 2 with reception as the only member on button right 2.

If i call the secondary number without being on the main line, it can be answered. If the mainline is already active right button 2 flashes orange but cannot be answered.

If the main line is in use by another phone then FXO2 is automatically used when reception picks up to make an external call. DND is not enabled.

Am I missing something? or have I discovered a bug?

thanks for the response Chris.

Jamie.

Hi Jaime,

We don't see this problem in our labs.  Suggest you put a call into the Cisco Small Business Support Center where they can take a look at the logs on your second FXO port.  You could also try moving the 2nd FXO to a different port in the UC320W and see if that makes a difference.

http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

Chris

Hi Chris,

I didn't think to look into the logs, I'll check this. I'll also set this configuration up on a SPA504g and see if I get the same behaviour.

If not I'll contact the cisco SBSC. 

thanks

Hi Chris,

I have setup the same configuration on an SPA504g

Right Button 1 - Ext

Right Button 2 - Shared FXO - Main line (FXO1 , SPA504g as only member) 

Right Button 3 - Shared FXO - Spill  line (FXO2,  SPA504g as only member) 

Main number is dialed and answered from button 2, but not transferred.

Main lined dialed again button 3 flashes orange

Put Call one on hold

Answer Call 2 by pressing the flashing orange button

This is the behaviour we expect and are getting. Set this exactly the same on the 508g and the second line cannot be answered.

If your lab can't repeat this, does it mean the phone is faulty?

thanks.

Hi Jamie,

Can you move the line in FXO port 2 to FXO port 3?  Configure FXO port 3 as your second shared FXO.  See if the problem still happens when we are using FXO port 3 instead of FXO port 2.  This will help tell us if there is a problem with FXO port 2.

Thanks,

Chris

Hi Chris,

I've done as instructed and the 508G is still unable to pick up the call. I've configured this on the 504G and its working fine.

Where to from here?

thanks,

Jamie.

Hi Jamie,

If I'm reading what you have written correctly, you can now answer the calls to the 2nd FXO on the SPA504 but not on the SPA508G phone?  If that is the case, you can try this:

  1. Factory reset the SPA508 phone by selecting the Settings button on the phone and then selecting the option to factory reset (13 I think).
  2. When the phone resets as part of the factory reset, unplug the power from the phone and leave it disconnected.
  3. Log into the UC320W configuration Utility and go to Configuration -> Devices.
  4. Find the SPA508 phone and delete the phone by hitting the X.
  5. APPLY the configuration.
  6. When the system comes back up, reconnect the SPA508 phone.  The phone will reset a couple of times as it generates a new config file for the phone.
  7. Set up the line buttons and users for the phone in the configuration utility and APPLY the configuration again.
  8. Try the call again.

The above steps are for rebuilding the phone configuration file from scratch and starting with a factory reset device.  If you are still having problems, it is time to call the Small Business Support Center for help.

Thanks,

Chris

Hi Chris,

Yes it all works with the 504G as expected. I'll give the phone a full factory reset and if it persists. I'll call the business center.

Thanks for all your assitance on this matter. I'll update with the outcome.

cheers,

Jamie.