cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

2709
Views
5
Helpful
2
Replies
micrinservices
Beginner

Provision issue with SPA504G

I am using a 3 tiered provision setup. On the root of my TFTP I have spa504G.cfg:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<flat-profile>   
    <Profile_Rule ua="na">/CiscoVOIP/$PN.xml</Profile_Rule>
    <Syslog_Server ua="na">192.168.210.101</Syslog_Server>
    <Debug_Server ua="na">192.168.210.101</Debug_Server>
    <Debug_Level ua="na">3</Debug_Level> <!-- options: 0/1/2/3 -->
</flat-profile>

So then for /CiscoVOIP/$PN.xml I have SPA504G.xml:

<flat-profile>
    <Profile_Rule_B ua="na">/CiscoVOIP/$MA.xml</Profile_Rule_B>
    <Resync_On_Reset>Yes</Resync_On_Reset>

.

. -snip-

.

</flat-profile>

and then in the same dir I have the config file 0002fdff586d.xml

The issue is this: After a factory reset, the phone will find /spa504G.cfg and apply it. It then reboots but it won't load /CiscoVOIP/$PN.xml. It doesnt even make the request.  If I do a manual reboot of the phone it immediatly loads up /CiscoVOIP/$PN.xml and subsequently /CiscoVOIP/$MA.xml.

I setup a few of these phones a few months ago and it seems to me that I didnt have to manually reboot. Is there a command I am overlooking?

These phones are using firmware 7.4.6.

I have attached the .pcap files of both the factory reset and then reboot. Note that in packet 45 of the factoy reset file is when I fired off the reboot.

Thanks

Greg P

2 REPLIES 2
picturemark
Beginner

Try using a well formed URL in your profile rule.  Judging by your pcap files, this would probably be...

tftp://192.168.210.17/CiscoVOIP/$PN.xml

In the pcap files you posted, the phone is sending TFTP requests to IP address 192.168.210.254, but that is not your TFTP server.  Is that your DHCP server or default gateway?  Also note, I do not see any DHCP reply traffic going from server to client, only requests from client (phone) to broadcast.  Are you using DHCP option 66 or some other method to inform the phone of the TFTP server address?  It's not clear from the pcap how the phone gets its own IP address, or how it ever finds your TFTP server 192.168.210.17 in the first place.

Lastly, I'm not quite sure how to make sense of this, but here is a quote from page 135 of the SPA500 Admin Guide regarding Profile Rule URL interpretation...

"If no protocol is specified, TFTP is assumed. If no server-name is specified, the host that requests the URL is used as server-name."

I dont know what "the host that requests the URL" is referring to, but when you use a fully formed URL as mentioned above, it doesn't matter.

Hope this helps!

That seemed to do the trick. I could swear I tried that when troubleshooting this, but I tried it one more time on your suggestion and after a factory reset it loaded all 3 files without a hitch.

thanks

Greg

Create
Recognize Your Peers
Polls
How would you describe your level of technical expertise?