cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
3283
Views
0
Helpful
37
Replies
Highlighted
Rising star

Review of CCA 3.1 & SWP-8.2 [UPDATED 08-08-2011]

Hi Cisco Team,

Firstly let me just congratulate you on the release of CCA 3.1 and what a FINE release it is

So let the fun begin...

Was bored on the weekend so I decided to give this thing a good once over, and finished it of this morning by checking its ability to work with 3.0.1 based configurations, and I must say, CCA 3.1 performed exceptionally well, and was pleasantly surprised by a number of things.

Pros:

  • The new Icon, whilst not a functional thing, cosmetics is always a good thing the new Icon looks the part and I quite like it, no more confusion between CCA and CNA as they both shared similar Icons
  • The Speed of it... WOW!!!! This new version loads up in half the time of version 3.0.1, uses up about 40% less memory on first load up which is a pretty good sight to see
  • Discovery process is vastly improved, the speed is much better and you can start working pretty much in half the time as the previous version, no more having ot get a coffer whilst waiting for it to discover everything to be able to work in a safe environment without causing issues with CCA
  • Loading up the User information is brilliant and exceptionally fast, WELL DONE team, that is just an awesome sight to see again
  • Good touch with the customization of the ephone-templates much needed addition, 10 templates is a good amount
  • Assignment of templates on a per phone basis... EXCELLENT!!! previously this could only be done via CLI and CCA would at times remove this configuration randomly, so this is a welcomed addition
  • Bilingual phones.. Great addition team, great addition
  • New Call Back Rule....... Oh stop it, your spoiling us, a very long awaited feature and very much welcome \0/ **Celebrates** you have no idea how much this frustrated installers/engineers like myself and customers alike not to be able to redial on a missed call, it is an absolute pain to have to train a group on how to press edit and add the steering digit in, they just give you this dumb founded look as to why such a complexity in doing such a simple function... I am cheering on the inside on this one
  • New Scripts look good, have done any tests with them as of yet, but I am sure many people will be happy to see them
  • Voice Mail Zero Out Option... Not to spoil the review, but ABOUT TIME this is yet again a very much welcomed feature and long awaited
  • Manual DTMF configuration for SIP trunk is a great addition, again removes the need of trying to do this on the CLI, a big thanks to the team for this one
  • Unlocking the Meet-Me from the outside world, a great feature but I have always been a little worried about this, I guess it will serve its purpose to a wider audience
  • In-bound Caller ID... Happy to see this however Software Pack 8.1 has issues with this on an IOS level, so I am assuming this is in preparation to 8.2 coming out soon
  • Local Directory Support... WooooooooooooooooooooHoooooooooooooooo!!!! I was toasting to this on the weekend
  • Disable DHCP server... YOU BEAUTY!!! Another welcomed addition, Fantastic Team
  • Crash Information gathering, this is just awesomeness it is helpful as removing the flash card or tftp can be a pain in the butt
  • Back Ground (Desktop Pictures) management is fantastic, again another huge thanks for this
  • Addition of the 300 series switches for management, if the ESW range is being replaced by these switches then we needed the ability to use CCA to management them

CCA is starting to take good form, it is edging close to be in competition with its fellow WEB GUI, given that in the past if we engineers needed to do remote work we had SSH or via Port Forwarding web access to the GUI, we are still not quite there yet with CCA, and when you can get VPN access and for CCA to work with it, you have a partial replacement, but still a long way away from reaching that goal. None-The-Less, 3.1 provides a good insight into the road map of its development, and so far it is clear that the design team is listening to the community at large, it is evident that our collective opinions/thoughts are being looked at and this can only serve to make CCA a more well received configuration tool, especially with those who are still quite adamant that it cannot serve as a replacement for the WEB GUI or CLI.

CONS:

  • No ability to turn call waiting beeps of, this still needs to be done via the CLI. If it is in CCA 3.1 it is hidden, I spent at least 30 minutes looking through every user based section trying to find a way to do this
  • Topology still does not quite save properly, it is fine until you add a new device and then it goes all over the place again, not crucial but annoying none-the-less, and Bonjour devices do not save in the position you put them, in particular printers they are the worst culprits
  • Inability to apply IDLE screen service URL's, this is a major request given that Cisco is now being looked at for Hotel based environments, being able to push information to the phones via the service URL to idle screens is a great feature, this can only be achieved via CLI and not sure if this will be removed in SWP-8.2
  • Inability to convert the Topology to PDF format still
  • Missing ability to print out call flow topology once the system has completed the Telephony Wizard, this is a powerful feature and Cisco really needs to introduce this in its next version
  • Lack of SCC configuration management, this was a much needed feature given the issues that are being faced by engineers, this is an absolute must for the next release, or even better on a maintenance release
  • IOS not letting the user add another List.xml file, which means you can only place custom images onto one phone at a time, it will throw up an at you advising you that this is already being served, which is in fact not being served, a bug that must have been missed in the QA process
  • The link to download the SSL software is broken, when you click on it to takes you to a site that displays the following error  "The download process was interrupted.Please restart the download process. If you continue to see this message, contact Cisco support at web-help@cisco.com

Not many CONS can be listed at this stage, the major issues that were outstanding in CCA 3.0.1 still have to be put through their paces and this can only be done (In theory) on the same systems that this issue was happening.

To be put to the test in round 2 of testing:

  • Bulk user modifications: Version 3.0.1 had a nasty issue of randomly deleting user configuration or not properly applying the request and at time disabling that users details in the system
  • CCA Correctly applying Park Slot configuration without having to restart the whole system, on all installs that required Park Slots after the fact, this issue is prevalent and at each of those installation the only way to get Park Slots working was to restart the whole system once the configuration was applied
  • Brand New build from scratch, I have quite a few installs coming up soon and I hope to be able to do them on SWP-8.2 and CCA 3.1

The Wrap Up:

All up there was about 6-8 hours spent looking over this, and overall this is a good release and it has the HUGE thumbs up, no where near as many features as what I thought it would have, and given that Cisco do not seem to publicly show what is on the road map I suspect that there will be some with shared disappointment and others who have been hanging out for some of these very much needed features with shared excitement.

Who knows maybe the next release of CCA will be a huge surprise and it will be a Xmas present wrapped up with all sorts of goodies, the real compliment would be having a well defined and workable Office Manager that is vastly improved and will work hand in hand with the latest CCA, but alas that is another issue entirely.

All-in-All my hat goes of to the Cisco Team, a job well done and I am looking forward with a renewed energy for the next release of CCA, by the time we have exhausted this versions capabilities we should be ready for the next big surprise...

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
37 REPLIES 37
Highlighted
Beginner

Hi David,

Thank you so much for taking time to share your thoughts about CCA 3.1! I'm really glad you noticed the speed improvements and the new desktop icon! Those were not "features" per se, and we didn't list them in the CCA 3.1 announcement or the Admin Guide, yet team put a lot of effort into improving overall user experience with CCA - interaction and the looks. Thank you for pointing those out!

On the CONS section:

  • No ability to turn call waiting beeps of, this still needs to be done via the CLI. If it is in CCA 3.1 it is hidden, I spent at least 30 minutes looking through every user based section trying to find a way to do this

Not in CCA yet. This is a candidate for CCA 3.2.

  • Topology still does not quite save properly, it is fine until you add a new device and then it goes all over the place again, not crucial but annoying none-the-less, and Bonjour devices do not save in the position you put them, in particular printers they are the worst culprits

You are right. There is an issue with saving Bonjour devices properly in the topology view. We will look to address this in CCA 3.2.

  • Inability to apply IDLE screen service URL's, this is a major request given that Cisco is now being looked at for Hotel based environments, being able to push information to the phones via the service URL to idle screens is a great feature, this can only be achieved via CLI and not sure if this will be removed in SWP-8.2

I agree. IDLE URLs should be part of CCA. This is a very solid candidate for CCA 3.2 .

  • Inability to convert the Topology to PDF format still

This is a neat feature and would provide a more convenient way to save topology comparing to simply taking a screenshot, and then saving this screenshot in PDF format. This is on the CCA to-do list for one of the upcoming releases.

  • Missing ability to print out call flow topology once the system has completed the Telephony Wizard, this is a powerful feature and Cisco really needs to introduce this in its next version

This would indeed be very powerful. May not be available in CCA 3.2, but I took a note of it for the future. Thank you.

  • IOS not letting the user add another List.xml file, which means you can only place custom images onto one phone at a time, it will throw up an at you advising you that this is already being served, which is in fact not being served, a bug that must have been missed in the QA process

This, I believe, is an IOS limitation.

  • The link to download the SSL software is broken, when you click on it to takes you to a site that displays the following error  "The download process was interrupted.Please restart the download process. If you continue to see this message, contact Cisco support at web-help@cisco.com

Are you refering to AnyConnect client? Will need to check.

  • Bulk user modifications: Version 3.0.1 had a nasty issue of randomly deleting user configuration or not properly applying the request and at time disabling that users details in the system

Have you run into this issue in Expert mode? How many users were you configuring at a time? We will need to verify this in our lab.

  • CCA Correctly applying Park Slot configuration without having to restart the whole system, on all installs that required Park Slots after the fact, this issue is prevalent and at each of those installation the only way to get Park Slots working was to restart the whole system once the configuration was applied

We will verify this in the lab.

Again, thank you for sharing your thoughts and suggestions with us. I'll circle back with you on our lab findings.

Sincerly,

Anna

Highlighted

There are a few items not listed above that really need to be added into CCA:

  • IPv6 support
    • CCA does not yet support IPv6
    • ISPs in the United States and elsewhere are already planning on supporting IPv6
    • The following CCA-configurable devices are already IPv6 capable: UC500, SA500, AP541N, 300 series switches
    • 6900 and 7900 series phones already support IPv6 (although 6900 series phones require version 9.2(1) or later phone loads for IPv6 support) with the SCCP protocol
  • The following improvements to SIP trunk settings:
    • Ability to register additional inbound numbers, in addition to the main number
    • Support for enabling and disabling codecs
    • Support for G.722, iLBC, and H.264 codecs over SIP trunks in addition to G.711 mu-law, G.711 A-law, and G.729
    • Ability to disable all codecs except G.711 on inbound fax numbers (this can actually be done through CLI)
    • Support for enabling the P-Asserted-Identity header
  • The following improvements to phone settings:
    • Ability to enable keep conference on phones
    • Ability to configure extensions spanning multiple buttons
Highlighted

I'm working on round two of the review John

Doing 2 brand new builds and a couple of upgrades, this should complete the cycle of the review and already I would have to expand a fair bit more on my first review.

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Highlighted

I am starting to wonder if David ever sleeps...  One important feature that should be included in the next version should be the ability to test SMTP server settings on the voicemail to email section of CCA.  A button that shoots out an email similar to the one in Outlook would be perfect.  Troubleshooting right now is a big pain due to changing and applying settings after someone leaves a voicemail.

Highlighted

[Review Update 2]

Well round two has begun, and not off to a good start I must say

Being my typical self and always just throwing myself into the deep end and just migrating to the latest, I decided to use CCA 3.1 for two new builds.... Errrr was not expecting what happened, needless to say I had to calm myself down before writing the update

Issue 1:

  • Telephony Wizard botching the configuration after you hit apply:
    Basically after spending some considerable time applying a 30 handset configuration, which just had to have complex call routing rules to boot, I waited patiently for it to apply and moved onto the second system and started to build that one. After the applying of the configuration had been achieved, I continued as per the screen prompts, waited for CCA to reload and then prompt me for the user/pass, to which I gleefully entered the details in that I had asked to be put in there on the second screen (After the user import wizard)... Now the problems begin, nothing I entered worked,,, time to default to the console cable to see what is going on, still no luck...HUH? Ended up using the confreg process to get into the system as I would normally do if a lock-out occurred on a 520 or 540 and has been done many times in the past... Well turns out this the NVRAM was wiped clean, so the "copy start run" command no longer worked.

    So back to the begining this build went, my mind is now racing at a 100 mile and hour trying to work out what has gone wrong, this build was no different to any other system build other than the complex call routing rules that needed to be put in place, although the Subnet for the data VLAN needed to be changed to 10.0.0.X

    On the plus side, since the build was still fresh in my mind, I managed to rebuild the system in record breaking time, I beat my own personal best, just waiting to see now if it apply's the configuration correctly this time.

  • Same Issue as above, but different system, different PC doing the build
    Went through the whole setup again, same run of the mill build, change the subnet, put in the required username and password etc...etc.. Try to log into the system after the reload and what not, no go same thing as system one, crossing my fingers and toes I do the confreg again, this time I strike some luck and am able to recover, and realize that the username has been chopped in half, and since the password was encrypted no idea what it just done to that.... Here is the interesting part the ip dhcp pool was in the 10.10.10.X subet but the rest of the configuration was in the 192.168.10.X subnet (Data), and to top that off half of the configuration was missing.... I resigned that the configuration was trashed and decided to just move to the next stage and try another rebuild

I am not a big fan of coincidences, I am a believer that things happen for a reason, I don't know if this was a user error issue, but I have used CCA for so many systems I know my way around it reasonably well, and have done quite a few systems with version 3.0.1, so I am at a loss to the above problems.

Issue 2:

  • Inbound Call Routing Configuration Screen
    Unless you have a ridiculously big screen, when working on a 100 number in-dial range, and more than 20 users, the pop-out screen tops out at 19 users, you then have to scroll down using the directional keys on the keyboard and hope that you counted the right amount to pick the right one. This section is in desperate need of a scroll bar, I am not aware of any engineers that have a screen larger than 14" and we use the same Laptop for installs both in the office and out on the road, they are tuned specifically to work with CCA to avoid the many pitfalls such as firewalls/multiple adapters/AV's etc..etc..

  • Needed an extra step before you actually get to the Inbound Call Routing Screen
    When you are working with a larger deployment and an in-dial range, it would be good to have a section just before you start allocating the DID's to a per user, this section should allow you to choose the following:

    * Default the entire range to "EXT" instead of defaulting it to VM
    * Default the entire range to "Group XYZ"
    * Default the entire range to "AA"


    This would make life so much easier, then having to click on each and every user (100 of them) and allocate the numbers, by creating a defaulting profile, it would then allow us to allocate only those that need to be allocated, a massive reduction in point and click, and also a good preventative measure of RSI

One of the features that was made available in this version was to disable the DHCP service, the following was observed.

  • In the Telephony Wizard there is no way to disable DHCP, you have to continue building the system as if the UC was going to be the network concentrator, instead of allow us to click on a box that says Disable DHCP and then presenting us with a section to allocate the IP address scheme for VLAN 1 (Data Vlan), this means we have to go in after the fact and work on the IP address scheme, this may lead to problems down the track, and I suspect if there is a problem with the way you configure this section, it might be causing the issue with bad configurations (Working on a theory right now and will update with the outcome).

Feature Request 1:

  • BulkUser Import spread sheet
    I would like to see this expanded upon, in this spread sheet it would be good to be able to allocate a DID to a user, it would save quite a fair bit of time in the build process, it would also be good to be able to do button assignment maybe in a second tab, and a secondary XML file created, working in a spread sheet environment can be quicker as the replication of data is much easier, in the past life when working on the CLI you would create your configuration in a txt file and then upload it to the system, it was the quickest form of building a system... If the basics like this could be tackled, then CCA would scoot through the process and make the fine tweaking of the system the major part, it would be a true bulk user import then

I dare say a 3rd update will be required, once I resolve these two problems and get these systems into a production state, it might be worth while reviewing the new features, I will need to allocate a system and a time to do this so I can break it without having things thrown at me

Back into the snake pit I go, managed to write this up whilst waiting for both configurations to apply

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Highlighted

Connect a second screen (probably need a TV for 100 users) to your laptop and set the resolution to the absolute max to see more users.  The CCA team knows about this issue also because I ran into as well. 

  • Inbound Call Routing Configuration Screen
    Unless you have a ridiculously big screen, when working on a 100 number in-dial range, and more than 20 users, the pop-out screen tops out at 19 users, you then have to scroll down using the directional keys on the keyboard and hope that you counted the right amount to pick the right one. This section is in desperate need of a scroll bar, I am not aware of any engineers that have a screen larger than 14" and we use the same Laptop for installs both in the office and out on the road, they are tuned specifically to work with CCA to avoid the many pitfalls such as firewalls/multiple adapters/AV's etc..etc..

Highlighted

Hi Marcus,

Connect a second screen (probably need a TV for 100 users)

I just played this scenario through my head... I have  a smile from ear-2-ear now, you made my day

Me: " Hey Boss"

Boss: "Yer"

Me: "Can I please have a big azz TV screen please"

Boss: "WTH For??"

Me: "I need it to do configuration in CCA"

Boss: *** WALKS AWAY SHAKING HIS HEAD ***

Me: *** WONDERS WHAT HE SAID WRONG ***

I am sure everytime I am spoken to I am asking for more stuff which means more money spending... Well I am starting to get that impression anyway

Oh I needed that laugh... Thanks again

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Highlighted

and tucking a 60" LCD TV under your arm is going to make: doors, your arms, your car size - not to mention client reactions, a bit problematical

Highlighted

Hi Robert,

Good to see you back on the forums

I trust everything is going well with you these days, I haven't heard from you lately so I just assumed you have mastered and tamed the UC-500 beast

I am consulting Hudini on how I can get away with the big tv problem, although he has no valid number anymore to call, might have to try throgh other channels to track him down

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Highlighted

Hi David

No, just been reading your adventures!

My box is pretty solid now – but have to venture more into the “telephony side” – ACA, Voice Mail set up, etc.

Time has been consumed with the trivia avalanche of this premise move of my actual UC560 client; who has decided to have 3 of the last 4 weeks on leave – while Rome burns around me…

Such fun! J

Hmmm… on the TV issue, I could make up a part number, buy it from Kogan online – and then you could tell the Boss it was a new piece of diagnostic kit from a new Disty???

(devious, am I not…) J

Regards,

Robert Prideaux

Director

Ailean OnLine

Description: Description: ailean_colour_complete_sml

Highlighted

Hi David,

Issue 1:

  • Telephony Wizard botching the configuration after you hit apply:
    Basically after spending some considerable time applying a 30 handset configuration, which just had to have complex call routing rules to boot, I waited patiently for it to apply and moved onto the second system and started to build that one. After the applying of the configuration had been achieved, I continued as per the screen prompts, waited for CCA to reload and then prompt me for the user/pass, to which I gleefully entered the details in that I had asked to be put in there on the second screen (After the user import wizard)... Now the problems begin, nothing I entered worked,,, time to default to the console cable to see what is going on, still no luck...HUH? Ended up using the confreg process to get into the system as I would normally do if a lock-out occurred on a 520 or 540 and has been done many times in the past... Well turns out this the NVRAM was wiped clean, so the "copy start run" command no longer worked.

    So back to the begining this build went, my mind is now racing at a 100 mile and hour trying to work out what has gone wrong, this build was no different to any other system build other than the complex call routing rules that needed to be put in place, although the Subnet for the data VLAN needed to be changed to 10.0.0.X

    On the plus side, since the build was still fresh in my mind, I managed to rebuild the system in record breaking time, I beat my own personal best, just waiting to see now if it apply's the configuration correctly this time.

  • Same Issue as above, but different system, different PC doing the build
    Went through the whole setup again, same run of the mill build, change the subnet, put in the required username and password etc...etc.. Try to log into the system after the reload and what not, no go same thing as system one, crossing my fingers and toes I do the confreg again, this time I strike some luck and am able to recover, and realize that the username has been chopped in half, and since the password was encrypted no idea what it just done to that.... Here is the interesting part the ip dhcp pool was in the 10.10.10.X subet but the rest of the configuration was in the 192.168.10.X subnet (Data), and to top that off half of the configuration was missing.... I resigned that the configuration was trashed and decided to just move to the next stage and try another rebuild

I'm sorry to hear about the Telephony Wizard set-up problems you ran into.

Would you be able to email me (atsukerm@cisco.com) the logs from both UC560 systems by going in CCA to Help->Supporting  Info->Troubleshooting log ? We need to investigate this further.

Thank you,

Anna

Highlighted

Would you be able to email me (atsukerm@cisco.com)  the logs from both UC560 systems by going in CCA to  Help->Supporting  Info->Troubleshooting log ? We need to  investigate this further.

Uhm that will be a little hard to achieve from one of the computers, it no longer works, well boots up anyway.

Will work on the other one for you once it becomes free as it is working pretty hard at the moment to do 2 UC-560's and 2 UC-320W... I am attempting to grow extra arms and eyes today

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Highlighted

Hi David,

  • The link to download the SSL software is broken, when you click on it to takes you to a site that displays the following error  "The download process was interrupted.Please restart the download process. If you continue to see this message, contact Cisco support at web-help@cisco.com

Are you refering to AnyConnect client? Will need to check.

You are right. This URL is broken. I'm looking into it to get it fixed. Thanks for pointing out!

  • Bulk user modifications: Version 3.0.1 had a nasty issue of randomly deleting user configuration or not properly applying the request and at time disabling that users details in the system

Have you run into this issue in Expert mode? How many users were you configuring at a time? We will need to verify this in our lab.

  • CCA Correctly applying Park Slot configuration without having to restart the whole system, on all installs that required Park Slots after the fact, this issue is prevalent and at each of those installation the only way to get Park Slots working was to restart the whole system once the configuration was applied

We will verify this in the lab.

Testing team weren't able to reproduce either of these issues in the lab. If you come across any of these again, can you please semd me (atsukerm@cisco.com) the logs AND the config files from your system?

Thanks,

Anna

Highlighted

Hi Anna,

Testing team weren't able to reproduce either of these issues  in the lab. If you come across any of these again, can you please semd  me (atsukerm@cisco.com) the logs AND the config files from your system?

Sure will, I have a case open right now on this system with an attached SPA-525G2 phone, which is directly related to the park slot issue as well

That's on another thread that is active at the moment.

I seldom expect things to be reproducible, I am fairly certain I have been cursed and have become a firm believer in green gremlins (The nasty kind) aiming to sabotage every single install

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *