cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Please be advised, the GuideMe Wizard is no longer available on the Small Business Support Community. For search capability please use the community search field to find content related to Cisco Small Business documents, videos, and discussions.
11212
Views
4
Helpful
3
Replies
Highlighted
Beginner

[SOLVED] Asterisk with SPA 303

Hello everyone,

we have a new setup with asterisk (1.6) and some SPA 303 phones.

There is a configuration on asterisk, which allows to programm call-redirections from the phone.

With a softphone i was able to programm call-redirections by dialing *440 or *450 etc.

But when i dial this from the SPA 303 the call is answered after dialing the first 3 keys (*44 or *45 etc.).

Also i'm not able to make transfers via keys given in features.conf (#[ext] or [*ext]).

So, the question is, how can i setup the phone / asterisk correctly?

Does somebody have a good example-configuration for SPA 303 with asterisk (Phone-Config + asterisk sip.conf)

Would be great.

Thanks!

Everyone's tags (5)
3 REPLIES 3
Cisco Employee

Asterisk with SPA 303

SPA phones are Small Business products.

Try posting your question here -

https://supportforums.cisco.com/community/netpro/small-business/voiceandconferencing/ipphones?view=discussions

Beginner

Asterisk with SPA 303

Usually SPA phones do have vertical service activation codes that starts with *(asterisk). Check out the configuration manual. I dont have a 303 phone. But most SPA phones do have options to change it via web interface. Refer manual for and change that doesnt clash with your dialplan.

http://www.cisco.com/en/US/docs/voice_ip_comm/csbpipp/ip_phones/user/guide/spa300_sip.pdf

-HTH Karthik.
Beginner

Asterisk with SPA 303

Thanks for your Replys,

i could solve the Problem yesterday. I had to change the Dialplan for the Extension.

The Standard-Dialplan accepts only two digits after *, cause of the pattern "*xx". If no other pattern can match the dialed numbers, the phone places the call automatically. I changed the Dialplanentry to "*x." and now it works!