cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

1085
Views
0
Helpful
12
Replies
dosmanov1
Beginner

SOS Phoneinrecovery mode spa303-g2 v01

Good afternoon everyone. I have 1 problem with the new SPA303-G2 v01 phone. When the power is connected on the screen, there is a PhoneInRecoveryMode. and hangs, tried to update the firmware connect it to the PC and through the utility drive a serial number, but it comes out nagging that the device could not be found. the firewall and antivirus are disconnected, port 69 is free. The question is, can I somehow restore this phone? which I tried to put the firmware on, I also do not know, since the phone is new and only got in the hands. Or maybe like doing a firmware reset and reinstalling it again? or the only option, is to try all the versions of the firmware in the hope that it will work?

12 REPLIES 12
Dan Lukes
Advocate

Phone have no valid firmware inside, just "recovery mode" loader.

Special recovery firmware utility needs to be used for it, it's .exe file with "recovery" text in it's name. It's bundled with some firmware versions that can be downloaded on Cisco's support / download software page.

 

Note that recovery firmware version need to follow internal recovery mode loader version. 7.5.2b loader or older require 7.5.2b or older recovery firmware utility, more recent loaders require more recent recovery firmware utility.

 

Loader version is shown by recovery mode utility of whatever version. Provide screenshot in doubt.

 

Phone serial is printed on label attached to phone, but you can use generic FFFFFFFFFFFF serial number instead.

 

Also note the firmware loader doesn't wait for recovery utility forever. So if phone seems not to respond, just power cycle it.

 
Dan Lukes , hi.
 
 
 
 
 Thanks for your answer.Below I attach a screenshot, launched Recovery.exe ver 7.5.2b and entered the serial number of the phone, after which I received the information below. After that, I pressed Upgrade, after the uploading firmware to my phone started, after the updating began, and the phone began to flash. After that, the phone reboots and the utility can not find the phone (I'm using the screenshots.) Maybe I'm using the wrong version of recovery or not the problem? I connect the phone to the router, to the access point, and to the SW port on the phone, if I connect to the PC port on the phone and directly to the laptop, the recovery utility does not find the phone at all when entering the serial number. Are there any options for recovery?Recovery Mode.jpgconnecting to spa.jpg

 

cannot finf and connect.jpg

 

 

 

If phone flashed but reverted back to S.O.S recovery mode, the firmware tool used is incompatible with loader.

 

According screenshot, version of recovery loader is 7.4.4, so you should use version 7.4.4 of firmware recovery tool. Unfortunately 7.4.4 firmware suite is no longer available. Use 7.4.9c (e.g. spa50x-30x-7-4-9c-recovery.exe) instead. Recovery tool have neither options nor configuration - it require just serial number (or wildcard

 

Once recovered, you can upgrade phone standard way to 7.5.2b and then to 7.6.2SR4 (the latest one).

 

Unfortunately the version 7.4.9с ((the telegraph also flashes during updating and then turns off completely, disconnects at the moment when the recovery tool searches for the phone (after the sos phoneinrecoverymode is on the screen and the 3 buttons on the phone are on constantly: 1) Turn on the microphone 2) Turn on the headset 3) Speakerphone.

Well, something is wrong - but no way to just guess what.

I need full packet capture of communication between PC and the phone in question. Use Wireshark or so to catch them. The dump may allow me to identify the cause.

 

Dan Lukes , hi! below i/m attaching packet capture. I started the wireshark application before running recovery.exe and stopped after rebooting the phone and disconnected after the appearance of the sos recovery mode on the spa303 screen. I hope that correctly used wireshark, because previously I did not use this tool. Please inform . if I did something wrong.

In the mean time ...

]Can you please take look on sticker attached to phone and disclose exact value of PID VID printed here ?

I filtered out all packets not related to phone's recovery and attached filtered dump. You may consider to edit your comment and delete your dump - it contain some unrelated packets revealing your network details.

According the dump itself, everything looks good - first four packets are Cisco's proprietary recovery protocol. It order phone to use TFTP to download /spa71f6.bin firmware file. The most of rest of dump file is successful TFTP transfer of such file. I has verified even content of firmware file - yes, you are using correct recovery tool utility with 7.4.9c firmware embedded.

It just should work, but it doesn't. It may be hardware issue - internal flash is broken, phone is unable to write firmware to it even its correct. Recovery procedure is undocumented by Cisco and provide neither logs nor debugs, so we have nothing to analyze.

OK, so what you can do now ? You can use oldest firmware available - the 7.4.6, a 7.5.x firmware before 7.5.2b (e.g. 7.5.1), a 7.5.x firmware after 7.5.2b (e.g. 7.5.3) and the 7.6.2SR4 as the most recent firmware available. Just for sure - it cost nothing to try (but I expect no success). You can apply for warranty (if still covered by it). Or you can call SMB support center and ask for help ...

 

So sorry I have no better advice ...

 

This post contain information related to other's site thus it may contain information considered Sensitive or Confidential.

Hi,

and maybe because dhcp is worth it? and when the phone is rebooted, a new ip is assigned and the connection to the previous ip can not be restored and recovery.exe can not find the phone? or in the recovery mode the phone does not receive the ip address? tried and older firmware, it still does not help. unfortunately the warranty on the phone is over. It remains only to contact the SMB support center. could you tell me how I can go there?  Thank you for your feedback on my problem, thank you for trying to solve it

Forget recovery utility results. Recovery utility may be just so fast, giving not enough time to phone to recover. Phone may not be found just because is not ready yet.

 

There's more reliable sign of recovery procedure result.

If phone reboots and show standard display screen, the recovery has been successful.. If still displaying S.O.S Recovery message, then it still lacks valid firmware image - recovery has failed.

 

Be sure you are waiting long enough so phone have time to burn image into flash - it may take even few minutes. Don't power cycle it so fast.

 

DHCP is not used here.

 

Note I'm still interested to know exact PID VID as printed on phone's sticker.

 

Technical Support for Small Business Contacts

 

Below I specify PID VID SPA303-G2 V01. The phone is rebooted immediately after the reboot with the inscription sos recovery mod, and the utility also searches for the phone during the reboot. and gives what is not found, as a whole it is logical as the phone is switched off and is in boot mode. It seems that the solution will be solved only by recovery 7.4.4 only where to get this firmware (((also confuses the moment when you connect the phone to the computer directly, recovery.exe does not find the phone by serial number, only when connecting to the router, the phone is recognized by recovery.exe

Well, the SPA303-G2 V01 is standard retail model (there are some customized units that may have modified firmware inside).

7.4.4 firmware will not help you. There has been no recovery tool inside of 7.4.4 pack released.

 

Note the so called "recovery tool" is code implementing recovery mode protocol (very simple protocol) and tftp server. Then is bundled with standard *.bin firmware file into single .exe file.

 

The recovery tool part is still the same, across versions, just bundled firmware vary. Skilled hacker can replace embedded firmware binary with another one creating recovery tool of version not released by Cisco.

 

Skilled hacker can even reverse-engineer recovery mode protocol (i did it). A programmer can read such specification and re-implement recovery tool from scratch (TFTP server sources are freely available, so just simple recovery protocol needs to be re-implemented by self).

 

So if you have spare time, there's still something you can try. Unless your time costs nothing, it will be cheaper to buy new phone. Moreover, I'm almost sure it's just waste of time even if your time costs nothing. Phone not willing to recover with 7.4.9 firmware (I did it so many times on phone with 7.4.4.rec loader) will not recover even with 7.4.4. There must be an internal issue that causes phone is unable to save firmware. I suspect broken internal flash.

 

So sorry I have no good news for you ...