cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
12068
Views
0
Helpful
13
Replies

SPA 504G / Dhcp not working in voice Vlan

ricardo.o
Beginner
Beginner

I have some problem with my SPA-504G, the ip phone don´t sent a DHCP discover on the voice vlan,

this works fine if i dont enable the vlan taggin and unset te vlan, when i set this parameters the phone

not receive ip automatically, but if i set the ip manually all works.

my dhcp is ok, another SPA-942 phones works fine with this configurations.

Someone have the same problem ?

i need some help

Thanks

13 REPLIES 13

Patrick Born
Cisco Employee
Cisco Employee

Hi Ricardo,

Where is the phone sending the DHCP DISCOVER when you have VLANs enabled?

Take a look at a Wireshark trace to determine this. Consider posting a Wireshark trace for analysis.

You say, "if i dont enable the vlan taggin" Take a look at the SPA500 Admin guide [see my signature for a link]. You don't have a choice to enable/disable voice tagging. When you select Enable VLAN, voice packets are tagged. You do have a choice to tag data packets by selecting "Enable PC Port VLAN tagging" though.

Some things to check:

1. Verify that the phone is running 7.4.8 firmware [it's good to be current]

2. Verify that CDP and LLDP-med are disabled in case you've a switch that is responding to the phone and confusing the issue

What VLAN ID are you setting voice to?

What VLAN are you setting data to?

Consider posting your phone's HTML configuration file for people to review and comment on.

Regards,

Patrick

----------

Use this reference document to locate SPA phone resources

I'm running the 7.4.8 firmware

The CDP and LLDP are disabled

When i select ENABLE VLAN the phone don't receive ip via dhcp,

i have others SPA942 and all works fine when i enable vlan,

What VLAN ID are you setting voice to?

2090

What VLAN are you setting data to?

1 (Default)

Ricardo,

Verify:

that your DHCP server has address scope on the voice VLAN and/or that there's a route to the phone [could the DHCP server be out of voice VLAN IP addresses?]

from your DHCP server on the voice VLAN that it can ping a device on the voice VLAN

with Wireshark that the phone is sending DHCP DISCOVER packets on the voice VLAN

Good luck,

Patrick

----------

The DHCP is working fine, i have others SPA942 working fine in this configurations,

if i do a factory reset, the dhcp on the SPA504 works, but after i set the option Vlan Enabled

the dhcp stops work, and if I disable the vlan option, the phone doesnt works too.

the only way to phone works again is with a factory reset.

i'm sending a Wireshark cap, with the port mirroring in the switch.

The packets 1 and 2 is before i enable the vlan, and disable the vlan, the fone stops work.

The packets 3 4 5 6 is after a factory reset, the communications is ok.

Ricardo,

Thanks for the trace and the additional testing. I'm conferring with my colleagues and will report back.

Regards,

Patrick

----------

You have some news ?

Alexander2015
Beginner
Beginner

Any news? I have this problem too..... (((((

ricardo.o
Beginner
Beginner

I have some news, the phones still not working but i do some tests and i discovered some things

when i disable this option in the switch port

  port-security port-mode userlogin-secure-or-mac

the phone works fine.

Probably the problem in the phone is with 802.1X auth.

The SPA942 and SPA 922 works fine with the 802.1X enabled or     disabled.

The SPA504 doesnt works if 802.1X is enabled.

the phones don´t need to do a 802.1x auth to work.

but if the auth is enabled on switch port the 504 dont work.

port-security port-mode userlogin-secure-or-mac

This mode is the combination         of the userLoginSecure and macAddressWithRadius modes.

l      For wired users, the port performs MAC         authentication upon receiving non-802.1X frames and performs         802.1X authentication upon receiving 802.1X frames.

Cisco, please help-us

Hello Cisco,

Are there any info on this one. Is this  a known bug . I am using 7.4.9c in 502 and had the same issue. 525 works fine with 7.5.2 firmware.

Regards

Robert

Hi, 

robert.arokiasamy, updating the firmware worked perfectly for me.

I was trying to use 802.1x with a SPA502G phone and a PC on a port configureted with voice and access vlan, but the phone didn't let the PC to authenticate.

I was using a SPA502G with 7.4.8a firmware, then i updated it to 7.5.2b and it worked.

 

Regards!

jrogers42
Beginner
Beginner

Sorry to resurrect an old thread, but we had a similar problem, SPA504G phones using VLAN tagging for phone and data port. We resolved the issue by disabling native VLAN on the switch - for some reason the phones did not like having the native VLAN the same as one of the tagged VLANs on the phone. Possible bug. 

I'm not sure I understood your description. You didn't disclosed the VLAN numbers, so I'm not sure about the configuration.

 

It seems you are using a VLAN ID for packet tagging on Cisco phone, but the same VLAN is claimed to be natove vlan on switch. It's incorrect configuration. Native VLAN is vlan that's distributed using untagged packets. You should not sent tagged packet with such ID at the same time as the switch behavior is not defined for such scenario.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: