cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
6394
Views
5
Helpful
32
Replies
Highlighted

spa 504g PC port periodically shuts down

Hello all, I have a problem with spa504g. I'm using few spa504g in my office. Computers connected to the network via phones onboard switch. From time to time pc lose the network connection (usially it happened after switching of the ethernet cable from the computer, or after computer going to the sleeping mode). Problem can be fixed by rebooting of the phone. I have the same problem on all spa504g in office.

Can somebody help me please?

P.S. sorry for my english, i'm from russia.

32 REPLIES 32
Highlighted
Hall of Fame Master

Wrong forum, try "small business voice - phones". You can move the post using the control panel on the right.

Highlighted

thank you

Highlighted

Dmitry,

Thanks for raising awareness on the PC port issue.

Can you provide a couple of additional data points?

Firmware version of SPA504G phone

Screen shot or value of Voice -> Info Tab -> Phone status -> provide SW port: and PC Port: speed and duplex values.

Also on the pc side what type of network card? 10/100 or 10/100/1000? Any additional

information will be helpful.  What is the power settings value when the pc go into sleep mode? 

Thanks again for your post and any additional information you can provide.

Regards,

Randy

Highlighted

Hello Randall,

      Phones have 7.4.3 software wersion, SW and PC Port have 100M Full Duplex mode. Most part of PC have

Realtek PCIe GBE Family Controller (speed and duplex in auto mode).

     About sleep mode- all PC have the different plane. But i think that issue happend when pc and phone disconnected for the few time. (unplagged, gone sleep, powered off).

     For example my pc, wich powered almost all the time, have this bug very seldom.

Thanks for your help.

Regards,

Highlighted

Dmitry,

Thanks for the additional information on the issue.

I will update our internal test teams and try to duplicate the issue.

Please plan to migrate to newer firmware 7.4.9c when you have a chance.

Randy

Highlighted

Randall,

Thank you, I'll apgrade the firmware and inform you about results.

Dmitry

Highlighted
Beginner

Hello,

we have the same issue with SPA504G's in our office. All of our phones have firmware 7.4.9c.

At first we only noticed the problem with laptop users - when they moved around the office and frequently connected/disconnected their laptop, then at one point the phone's PC port stopped working. Only solution was cold-booting the phone.

There were also a few times when the problem occurred after laptops went to sleep/hibernate.

But now we've also seen cases where the disconnection just happens in the middle of the day, without any previous cable connects or disconnects and without power state changes.

I've only mentioned laptops, because we don't have any PC's set up through IP-phones.

SW and PC port speeds for us are all "100M Full Duplex"

Network cards in laptops vary, including "Marvell Yukon 88E8055 gigabit", "Intel(R) 82567LM gigabit", "Broadcom 440x 10/100", etc.

Unfortunately we've had no luck in trying to duplicate this problem in a controlled method, so it's hard to give any certain facts.

best regards,

Lauri

Highlighted

We also have been experiencing the same issue.  We have a mix of (10) 504 & (6) 942, the 504 are more problematic.

Have tried 7.4.5 to 7.4.9c (all inbetween) and still have lockups.

Provider is Nextiva, they have tried most everything on their end as well.  Lockups freeze the client computer connected to the PC port.  No web access, no menu access, frozen clock time really gives it away.

Mike

Highlighted

I have opened a defect against the SPA50X phones id CSCtz17933 on the PC port periodically shuts down issue.

Thanks for raising this issue on the support forum.

Regards,

Randy

Highlighted

Hello,

I have updated the firmware to the latest version on a few phones... still the same issue.

Regards,

Dmitry

Highlighted

Dmitry/All,

The team is actively trying to  duplicate the issue in the Cisco labs. 

If possible, the next time the pc port on the phone is in the bad condition can you please try to disable and enable the network interface on the connected device?   Please comment if the condition clears without rebooting the phone.

Thanks,

Randy

Highlighted

Randall,

We have tried that previous with no change in status.  We have seen status of "Limited Connectivity" and "Not Connected".  Typically not connected. 

We have reduced the number of occurences by doing a few things:

1 - Disable Provision & firmware upgrades

2 - Set all phones static IP inside the network

3 - Use external DNS (OpenDNS & Google DNS Public servers)

4 - Static IP on the external (WAN) connection

Nextiva (Phone provider) is mentioning a DNS related issue ont he device, and has had many reports from different customers using the 50X series phones.

Again, this does not usually happen on the SPA942 models as they rarely have problems. So may want to look into what was changed. 

Thanks,

Mike

Highlighted

Hello All,

Randall,

I also tryed to disable/enable the network interface during the issue. It doesn't help. Only rebooting of the phone helps.

Regards,

Highlighted

We ran into this quite some time ago...it was clear that is was an issue with the Firmware Upgrade / Upgrade Enable of the phone.  It periodically checks for either Firmware Updates...and goes through a boot cycle when it does...

Changing the Firmware Upgrade rule to NO which is set to YES by default resolved the issue.