cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

1503
Views
0
Helpful
6
Replies
Richard Benfatto
Beginner

SPA504AG - Skype VoiP and Cisco Linksys RV 082

SPA504G - Skype VoiP and Cisco Linksys RV 082Have been traying to make the SPA 504G work behing NAT with the RV082.


I have audio one way only. Call establishes and then I can speak but I cannot hear the other end.


Any ideas as to what settings am I missing? Default SPA504G RTY ports starts in the 16,000's so this may have to be changed and RTC RTCP forwarder to the internal phone in the RV 082?


Thanks

6 REPLIES 6
nseto
Frequent Contributor

The phone has the NAT Support Parameters located in teh SIP tab.  You can adjust the VIA info there and set STUN server if using a STUN server, or set the EXT IP parameter to the router IP adddress.  The NAT mapping enable is in the Ext tab under NAT settings there.   Refer to the admin guide for the info on each parameter.

Good morning, do not have your name but thanks !

There is now more to it. Last night I decided to connect the phone directly to the Internet as to get a public IP with no NAT.

I was able to call someone and have perfectly well two way audio BUT the person when trying to call me said :" I get a ring tone once and then defaults to busy tone". I never get the ring, in summary I cannot rreceive calls and now there is no NAT whatsoever........................ I am really puzzled.

I may need to get the Admin guide. The box came with a CD ROM and some papers but there is no (at least I cannot find it) a technical manual with every setting and what it means.

Thanks again !

nseto
Frequent Contributor

This will require more analysis.  You can contact either Skype support or our support dept at http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

They will need to see the phone config and the debug log to see why this is happening.

Thanks, I am ultra puzzled.................VoiP is not my expertise but I am CCNA and CCNA Security Instructor at college and Ironport Mail Hubs so have some knowledge of things, or I believe so.............

VoiP is very painful specially with 7 types of NATs though connecting it directly is what killed me.

In other words I run out of ideas.........

Cheers

Richard,

I believe part of your challenges is the RV082 does not have a SIP ALG embedded into the router firmware. One Cisco router that has a SIP ALG is (W)RV180.    The SIP ALG function will inspect the packets from the SPA Phone and replace the private IP Address i.e 192.168.1.x contained within SIP messages  with the public IP address of the router WAN port.  Thus avoiding one way voice and other SIP interop issues.    One work around is to config the SPA Phone with a STUN Server which will compensate for a RV082 not supporting a SIP ALG.

Regards,

Randy

Randall, thanks.

Well forget about the RV 082. Not sure if you read all from the begining.............

I connected the phone directly to the Internet (public) no NAT, symmetric or asymmetric. Basically no more NAT...........

and the phone still does not take incoming calls.

So I can ring anyone in the planet and talk two way audio but it will not ring........................

The person that initiates a call to me gets a short one ring and then goes to busy tone. On my side the phone sits in the hook and never ring.

So, this is when I need to see what Skype is doing and if the problem is there or where.

By the way, prior to connecting the phone to the public side directly I did do port forwarding with the RV 082 and had two way audio. Since I could not receive incoming calls, I connected the phone to the internet with no protection and same story. WIth or without RV 082 same drama...........

I will contact Skype but not sure if I am going to get anywhere...................