cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

2100
Views
5
Helpful
6
Replies
netconeng
Beginner

SPA504G display hangs when trying to do a LDAP lookup

Hi,

we are experiencing a big trouble with LDAP search.

We have set to phones: one 504G and one 525G.

We are trying to do lookups with the same configuration.

SPA525G is working fine. 504G hangs on "Requesting Directory from LDAP Server...".

More: 504G does no more answer to softkey "cancel" but web gui is accessible and working fine.

We tried to enable debug and syslog but the only message that the phone sends to syslog server is:

"LOCAL3.DEBUG: num items:2" and then he tries to connect to LDAP server port 389.

We have seen that it succeded in establish TCP connection handshake (SYN, SYN/ACK, ACK). No other traffic is sent to LDAP server (Windows Server 2008 R2).

After the phone syslogs: "KERN.ERR <<<signal:10  received from thread CCTRL>>>" and "LOCAL0.INFO: request reboot type=4 reason=System 4(8000)".

In this state the phone is contacting regurally the SIP server. So it seem to be working in other parts of the system exept display and keys.

Anyway the phone does not reboot and we need to power cycle it to  make the display, keyboard and softkeys work again.

It's a big problem. You can look at configuration at the end of post.

Any idea to make it work or to do some other troubleshoot action?

Thanks

Luca

<LDAP_Dir_Enable group="Phone/LDAP_Corporate_Directory_Search">Yes</LDAP_Dir_Enable>

<LDAP_Corp_Dir_Name group="Phone/LDAP_Corporate_Directory_Search">Test</LDAP_Corp_Dir_Name>

<LDAP_Server group="Phone/LDAP_Corporate_Directory_Search">XXX.XXX.XXX.XXX</LDAP_Server>

<LDAP_Auth_Method group="Phone/LDAP_Corporate_Directory_Search">Simple</LDAP_Auth_Method>

<LDAP_Client_DN group="Phone/LDAP_Corporate_Directory_Search">cn=&quot;Active Directory Reader&quot;,dc=costruzionipavesi,dc=com</LDAP_Client_DN>

<LDAP_Username group="Phone/LDAP_Corporate_Directory_Search">adreader</LDAP_Username>

<LDAP_Password group="Phone/LDAP_Corporate_Directory_Search">*************</LDAP_Password>

<LDAP_Search_Base group="Phone/LDAP_Corporate_Directory_Search">dc=costruzionipavesi,dc=com</LDAP_Search_Base>

<LDAP_Last_Name_Filter group="Phone/LDAP_Corporate_Directory_Search">sn:(sn=*$VALUE*)</LDAP_Last_Name_Filter>

<LDAP_First_Name_Filter group="Phone/LDAP_Corporate_Directory_Search">cn:(cn=*$VALUE*)</LDAP_First_Name_Filter>

<LDAP_Search_Item_3 group="Phone/LDAP_Corporate_Directory_Search"/>

<LDAP_Item_3_Filter group="Phone/LDAP_Corporate_Directory_Search"/>

<LDAP_Search_Item_4 group="Phone/LDAP_Corporate_Directory_Search"/>

<LDAP_item_4_Filter group="Phone/LDAP_Corporate_Directory_Search"/>

<LDAP_Display_Attrs group="Phone/LDAP_Corporate_Directory_Search">a=cn;a=sn;a=telephoneNumber,n=Phone,t=p;</LDAP_Display_Attrs>

<LDAP_Number_Mapping group="Phone/LDAP_Corporate_Directory_Search"/>

6 REPLIES 6

I have the similar problem with 7.5.4 firmware on SPA303. The older 7.4.9 works fine.

Waiting new FW

I also get the same problem with 7.5.4.

However, be sure to report this ticket to Cisco, since they just cannot guess the fault.

I am opening a ticket for it.

I realize this is an old ticket but 7.5.5 fixes the issues and Distinctive ring still works for those who care.  Many other versions break Distinctive ring but fix LDAP.

trackerballs
Beginner

Hi,

     Has anyone found a workaround for this ?

Yes, I rolled back to the 7.5.2. Now it works fine

Erik Dekkers
Beginner

I have this problem too.

Wireshark trace just shows a TCP handshake and then nothing. Phone freezes an needs to be rebooted by powering it off.

I'll try the 7.5.2 firmware. Too bad such things aren't tested by Cisco when releasing new firmware.

This widget could not be displayed.