cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Please be advised, the GuideMe Wizard is no longer available on the Small Business Support Community. For search capability please use the community search field to find content related to Cisco Small Business documents, videos, and discussions.
16970
Views
0
Helpful
12
Replies
Beginner

SPA504G Registration State: FailedNo Response

I have a remote SPA504G (7.4.8a) that sits behind my home router/firewall that up to this point has worked perfectly.  Yesterday the unit went to orange lights on all the lines and I haven't been able to find out what happened.

Neither the VOIP server nor the home network are the issue, as I've successfully used both X-lite and CSipSimple from the same home network to connect to the same extensions.  Additionally, there is another SPA504G at another user's home that is working okay.

The device itself is successfully registering with the DHCP server, and the switch seems to work since I have a printer passing through.  I've unsuccessfully tried connecting to a Public SIP server using the phone.  I have also tried resetting the device and configuring it again.  Does anyone have any other suggestions?

Thanks.

12 REPLIES 12
Beginner

Re: SPA504G Registration State: FailedNo Response

Since the post, I've downloaded the slogsrv utility from here (https://supportforums.cisco.com/docs/DOC-9862/) and enabled "Full" under the "SIP Debug Option".  There is no traffic to speak of even though I have the PC firewall disabled... I can still connect to its web server.

Cisco Employee

Re: SPA504G Registration State: FailedNo Response

Hi cswakefor,

Try following these directions to configure debug level 3 on the phone: https://supportforums.cisco.com/docs/DOC-9934

Orange LEDs are an indication that the phone's line/s are configured but not able to register to the SIP server.

If you had a nework issue, the mute LED button would be red.

You said you reset the phone, but didn't say how. Try a factory reset: setup > 14 [factory reset]

The best, fastest, easiest way to figure out what's going on is to remove power from the phone, start Wireshark on your network, and apply power to the phone. This will allow you to verify that the phone is getting an IP address on the appropriate VLAN, requesting and receiving appropriate files [CDP or LLDP responses cause the phone to behave in a manner that you may not have predicted], and then trying to appropriately register to the correct SIP proxy.

Good luck with the troubleshooting, sounds like you're making good progress with the second phone in place with a similar config.

Regards,

Patrick

----------

     One reference document to locate SPA phone resources

Beginner

Re: SPA504G Registration State: FailedNo Response

Got my hands on another SPA504G - works perfectly with the same settings.

SPA504G Registration State: FailedNo Response

Hi ,

we are having the exact same issue , it says as failed No Response..any workaround for this ?

Appriciate your advice ,

Thanks

Purna

Beginner

Any resolution on this matter

Any resolution on this matter?

I have 7 out of 8 phones (SPA504 and SPA922) at one location that suddenly stopped working yesterday. I've tested everything but no luck.

 

Any suggestions?

Engager

Upgrade from 7.4.8a firmware

Upgrade from 7.4.8a firmware to latest and try again. I suspect nobody will spent time to analyze issues related to historic firmwares ...

Beginner

The SPA504's were running 7.5

The SPA504's were running 7.5.2; I upgraded all to 7.5.5b.

The SPA922's were running the latest. After about a 12 hour outage the phones that were not registering and trying everything possible, they started working again! Very strange behavior.

Engager

You didn't mentioned the

You didn't mentioned the firmware version, so I assumed you have the same as claimed in original question. Well, 7.5.5b is still not the latest version. You should debug the latest version if possible.

OK, so whats now. I assume that 'everything possible' include power-cycle. Phones become working again with no configuration change, so it's not simple configuration issue. Power-cycle didn't solved the problem, so it seems not to be simple firmware bug.

It seems to be an network problem. Like phones are configure to use DHCP, but IP range has depleted so phones received no IP from DHCP (until some old assignments become expired). Or so.

Turn on syslog&debug (level 3) messages. Be prepared to catch them as well as SIP messages. Wait for outage. Check phones WWW UI Info page - the IP address assigned, registration status. Check it on phones menu if WWW UI is not available. Catch SIP messages as well as syslog and debug messages. They will help you (us) with further analysis even in the case the issue is caused by a reason external to the device in question.

 

Beginner

I have a user that works from

I have a user that works from home and had the same issue twice. For some reason after both outages the way to fix it was by factory resetting the phone, re-configuring the phone "http://IPofThePHONE/admin/resync?http://YourSeverAndYour/provisioning/p.php/spa$MA.xml and then reboot the router. 

You have to do it in this order. Reset>Reconfigure>reboot router. 

If you do in a different order it will not work. This does not make sense but troubleshooting VoIP is becoming more of an art than science. 

 

 

Engager

It's because lack of

It's because lack of information. For example, you didn't disclosed the phone's firmware version, you didn't tried to analyze what's wrong if you do the steps in different orders (or you analyzed, but didn't disclosed the results). It seems you just found solutions by random try.

Yes, it's not the scientific way of issue solutions - it's rather magic - or art, if you wish. You didn't helped to found scientific solution so much.

But who will spend time for scientific solution if magic works well ?

 

Beginner

Re: SPA504G Registration State: FailedNo Response

I ran into a similar issue recently and performed a factory reset, upgraded the firmware, rebooted switch/router and none of them worked. turned out it was a simple fix. I had previously compared all settings with another working SPA504G phone and copied over the password in subscriber information under EXT1 tab. I manually entered in the password correctly and voila the phone registered and no more amber light.

Highlighted
Engager

Re: SPA504G Registration State: FailedNo Response

How you compared password in subscriber information under EXT1 ?

 

Phone never discloses passwords entered. Even saved configuration lacks passwords. There's just no way to extract password from phone.

 

It seems you copied placebo-string ************* shown instead of password in UI. Phone registration has been unsuccessful because of incorrect password. Correct password entered solved such issue.