cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Get the latest Cisco news in this December issue of the Cisco Small Business Monthly Newsletter

4745
Views
0
Helpful
11
Replies
Highlighted
Beginner

SPA508G on UC520

I've just set up a UC520 with 2 SPA508Gs and 2 SPA525gs.

I'm using the Early adopter software for SPA508G compatability.

My small problem is that the SPA508Gs pick up an IP address from the data Vlan, and show as unregistered. I've set them up manually, so they have extensions, but no the right IP addressing.

Any suggestions why?

Thanks,

Adam

Everyone's tags (1)
11 REPLIES 11
Rising star

Re: SPA508G on UC520

Are the phones plugged into a cisco switch?  Is CDP enabled?  Can you post the topology that you are running?

Beginner

Re: SPA508G on UC520

All phones are plugged directly into the UC520. There is another switch chained off of it (Netgear unmanaged), but it only has PCs plugged into it.

Thanks,

Adam

Re: SPA508G on UC520

Adam,

This is very speculative on my part, but I want you to remember when you upgraded to the EA pack on the UC520, and the CCA 2.1 Phone Load Manager poped open (its now also part of the SW Upgrade in the Maintenance drawer), did you select the SPA500 phone loads at that time (.ie before the SW upgrade took place?)  ... if so, there is a chance the CNF Files didnt get created correctly (since these phones were not recognized or supported in previous IOS/CME).

If thats the way you remember it, and you have a system to try this on in a way that doesnt intrude on the user (who is probably operating and doesnt want to get disturbed),, you can manually delete those lines in the voice window, then select the standalone phone manager and delete the phone load for SPA500, and then when thats done, add it back (two different tabs in PLM).  When adding it back, you only have to point to the same UC520 EA bundle zip you used for upgrade.  It analyses the phone loads and presents them to you.

Then plug in the phones and see if they register, and appear in your voice window to configure.

Steve D

SE Sales

Beginner

Re: SPA508G on UC520

Yes that is how it happened.

Is there a way I can do it without remove the lines, as like you say, there are users on it!

Re: SPA508G on UC520

Yes, I suppose you dont have to delete the line.  I just wanted to verify if would register when you were done.  The next time the phone is reset, it will look for the load and see that there is a new one for it.   BTW, you can reset any line from the CCA Topology map (just right mouse click the phone icon and select restart).  The phone does show up as a member of the Voice network in CCA, right?

Check the topology and Monitor Drawer --> Telephony --> phones and Extensions and look that its in the 10 net and Green (registered).

You can also check to see what load the phone is actually running on...

# show ephone phone-load  <--- I didnt find this in CCA, but thats not to say I missed it in one of the menus

Its probably the same as whats on flash, as its brand new and we didnt update it yet i dont think ;-)

Steve

Beginner

Re: SPA508G on UC520

I have removed the Phone-load, just doing it out of hours.

I now have another wee problem. I am working off of a VPN, and when I try and upload the phone load again I get and error. It identifies the loads correctly, but can't upload them. The error string is a huge html string, from the jist of it it looks like it can't tftp it from my machine.

I've uploaded phone loads manually before through the CLI, but I'm a bit rusty, can you point me towards the commands?

Thanks.

Re: SPA508G on UC520

Yeah.....You know I heard we blovk certain functions from being executed over the WAN (like Upgrades and the like) since it is so dangerous.

But I would have suspected it to be grayed out......

let me check with the Engineering team.....

Steve

We discourage CLI since we went through so much R7D to make CCA happen, but its ' copy tftp flash'

Beginner

Re: SPA508G on UC520

You'll excuse the wry smile at discouraging the use of CLI. First time I've heard that from a Cisco employee!

CCA is getting better with every release.

Thanks.

Adam

Re: SPA508G on UC520

LOL

Yeah, I hear ya!!!  :-)

..... thats the whole point.  We want our partners NOT to have to be Cisco Employess to deploy our systems.   We like GUIs for this purpose.

Fast time to deploy, lesser skill required, easier to maintain.....

There, do I sound like a Sales guy now?

Wishes for a happy friday!!!

Steve

Beginner

Re: SPA508G on UC520

i am having the same problem loading some loads on a UC560.  i get the big long error string with html in it basically saying i can't tftp.  did you figure this out?

Beginner

Re: SPA508G on UC520

I updated them using cli, which I'm afriad I'm not confident to repeat here.

Couldn't get it to work over a VPN.

I suggest you start a new thread to make sure the Cisco guys see it - they will have a an answer!

Good luck,

Adam