Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


SPA525G Display Goes Solid Grey

User was using the scrolling buttons to select different calls and suddently the screen goes solid grey.

Power cycled using the PoE connection.  The phone buttons functioned but the screen remained solid grey.

Without the use of the display, I stepped through the options and did a factory reset.

On reboot, the screen remained solid grey.

Did a firmware upgrade to 7.5.3

On reboot, the screen remained solid grey.

Unplugged phone for 2 hours

On plugging it back in the display screen worked.

I then programmed it and on reboot the screen was solid grey again.

Any suggestions on what else to try?

We purchased it from Amazon about a year ago.  How does Cisco's warrentee work?

Is it too late to RMA the thing?



Jeremy Koch

Hi, how did you log into the phone? via CLI?

UC540 system with 8.6 Software Pack

UC540 system with 8.6.2 Software Pack

Thanks for your interest...

Reset to Factory Defaults = I had an idenitcal model phone next to this one. And I emulated the same key strokes on the good phone on the one with the gray screen.

Firmware Upgrade = I used the phone's web access GUI to perform this task

Just wondering if you "see" the phone in CCA?

Is there an extension assigned to it?

If it is not there, add it manually in the Users/Extensions tab by adding the MAC address...

Since it is responsive (as you can access the configs menu directly on the phone) I suppose it's either that the phone isnt configured with an extension, or not communicating properly with the UC. Could you check if it is getting an IP address? If so, is it in the same range as the UC?

I am able to recieve and place calls from this unit.

I am using 3CX phone system.

3CX registers the phone and  the static IP address assigned.

Ok... I have tried unpluggin the phone for 24 hours and reattached it.... and this time around the screen did not come back but stayed a solid grey...

I have come to the conclusion that it must be just busted.

Thanks for your help....