cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Get the latest new and information the November issue of the Cisco Small Business Monthly Newsletter

563
Views
0
Helpful
2
Replies
Beginner

SPA525G not registering anymore, no error message. Can I get a more verbose error msg?

I have a freepbx box with two phones on it at one location. Via VPN, another phone connects from another location. The PBX is 192.168.2.4, the phones that are in that office at 192.168.2.94 and 192.168.2.95. The phone at the other location that connects via VPN is 192.168.3.98.

So, the VPN'd phone worked great for a while. Then one of its extensions went red. I restarted the phone, and now both extensions are red. The PBX can actually ping the IP of the phone, and machines on the "other end" can even browse to the phone and configure it remotely by putting 192.168.3.98 in the web browser. Other fuinctions(CCTV camera system, quickbooks, worktracer, file sharing) all work over the VPN'd network. The only thing that doesn't work is this phone.

I've tried a factory reset and reconfiguring it but it still doesn't register. The best I get is Registration State:    Not Registered

This error message really isn't helpful. How can I get a more verbose error message so I can troubleshoot this further?

Thank you!

2 REPLIES 2
Highlighted
Advocate

Re: SPA525G not registering anymore, no error message. Can I get

A packet tracer (Wireshark, tcpdump or so according local situation) will give you exact information about content of registration packet sent by phone and response from PBX side.

Also see phone's Administration guide, chapter 6 (Setting Optional Network Parameters), tags Syslog Server, Debug Server, Debug Level.

Also see

Beginner

Re: SPA525G not registering anymore, no error message. Can I get

Before I drove myself too nuts setting up syslog server, I decided to try a simpler solution to diagnose network problem vs. phone problem. I grabbed one of the other SPA525G units from my main office location, which was set on DHCP, and moved it to this location. It functioned. I tried the phone in question from the original post. Nothing - red extensions, that won't register. I try loading up the config on both of them to be the same, but same problem. I try factory reset and firmware upgrade, same problem. I'm going to give a try to returning this phone for another SPA525G. I think this phone is defective.

Thanks!