Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter


SPA525G2 Plantronics Voyager UC V2 Bluetooth Failure


Software Version: 7.4.8

Bluetooth Firmware Version: 0.00.32a

When attempting to pair a Plantronics Voyager PRO UC B230 I receive the error, "Pairing Failed"

It worked twice, but I had to reset the phone and I could never get it to pair again. It was nice when it worked

I have tried through the phone's gui and the phones web page. I have power cycled and opened Cisco STAC support requests. We tried to downgrade the phoen's firmware, and upgrade the Plantronic's firmware - no help.

I am able to pair the Plantronics headset with my iphone, and my iphone with my SPA525G2.

Cisco SPA525G2 BT.log (Diagnostic log) follows;

00000000000000476328   bt 7  [BT]<btReadClientPkt>: Start Bluetooth Debug(Debug Log[1] Path[/tmp/usb/usbsda1] FileName [spa525g_bt.log] MaxSize [1024000] SampleRate [0] Level [0])

00000000000000476330   bt 7  [BT]<btMessageHandler>: Message = CMD_DEBUG_LOG_REQ

00000000000000477772   bt 7  [BT]<btReadClientPkt>: Headset name 405539A278FA

00000000000000477773   bt 7  [BT]<btMessageHandler>: Message = CMD_HEADSET_CHANGE_DEVICE_NAME

00000000000000477773   bt 7  [BT]<btReadClientPkt>: Application Mode = 0

00000000000000477774   bt 7  [BT]<btMessageHandler>: Message = CMD_CONFIG_APPLICATION_MODE

00000000000000477775   bt 7  [BT]<btReadClientPkt>: Headset Pin Code 0000

00000000000000477776   bt 7  [BT]<btMessageHandler>: Message = CMD_HEADSET_CONFIG_PIN_CODE

00000000000000477776   bt 7  [BT]<btMessageHandler>: Message = REGISTER_HISTORY_DEVICE_REQ_ASY

00000000000000477777   bt 7  [BT]<btMessageHandler>: Message = CMD_ACTIVATE_REQUEST

00000000000000477778   bt 7  [BT]<sendMsgToChip>: write 'VD_CHIP_STATE_REQ#' into /dev/ttyS1

00000000000000477779   bt 7  [BT]<btRespClient>: Message= CMD_ACTIVATE_RESPONSE, status= 0

00000000000000477781   bt 7  [BT]<sendMsgToChip>: write 'VD_RESET_CHIP_REQ:1#' into /dev/ttyS1

00000000000000477898   bt 7  [BT]<sendMsgToChip>: write 'VD_ACTIVATE_REQ#' into /dev/ttyS1

00000000000000477899   bt 7  [BT]<sendMsgToChip>: write 'EventPowerOn#' into /dev/ttyS1

00000000000000477901   bt 7  [BT]<startActivateProcess>: auto-connect is turn on

00000000000000477902   bt 7  [BT]<sendMsgToChip>: write 'VD_CONFIG_APP_MODE:0#' into /dev/ttyS1

00000000000000477903   bt 7  [BT]<sendMsgToChip>: write 'EventChangeLocalName:405539A278FA#' into /dev/ttyS1

00000000000000477905   bt 7  [BT]<sendMsgToChip>: write 'EventConfigPinCode:0000#' into /dev/ttyS1

00000000000000477906   bt 7  [BT]<sendMsgToChip>: write 'VD_AUTO_CONNECT_START_TIMER:30#' into /dev/ttyS1

00000000000000479010   bt 7  [BT]<btMessageHandler>: Message = CMD_SEARCH_REQUEST_ASYNC

00000000000000479014   bt 7 !!VD_INQUIRY_SCAN_REQ!!

00000000000000479015   bt 7  [BT]<sendMsgToChip>: write 'VD_INQUIRY_SCAN_REQ#' into /dev/ttyS1

00000000000000480815   bt 7  [BT]<btProcessUartMessage>: <VD_INQUIRY_SCAN_RES> End!!

00000000000000480815   bt 7  [BT]<btRespClient>: Message= CMD_SEARCH_RESPONSE_ASYNC, status= 0

00000000000000480816   bt 7  [BT]<btProcessUartMessage>: <VD_INQUIRY_SCAN_RES>auto-connect is turn on

00000000000000480817   bt 7  [BT]<btProcessUartMessage>: Scan Complete

00000000000000480818   bt 7  [BT]<btMessageHandler>: Message = CMD_GET_SEARCH_RESULT_REQUEST

00000000000000480818   bt 7  [BT]<btRespClient>: Message= CMD_GET_SEARCH_RESULT_RESPONSE, status= 0

00000000000000482003   bt 7  [BT]<btMessageHandler>: Message = REGISTER_HISTORY_DEVICE_REQ_ASY

00000000000000482008   bt 7  [BT]<btMessageHandler>:addr=00:23:7F:B6:4A:27, name=Voyager PRO UC v2,, pin=0000, auto=1

00000000000000482008   bt 7  [BT]<btMessageHandler>: Message = CMD_CONNECT_REQUEST_ASYNC

00000000000000482025   bt 7  [BT]<sendMsgToChip>: write 'VD_SLC_CONNECT_REQ:0x00230x7F0xB64A27:C4#' into /dev/ttyS1

00000000000000482026   bt 7  [BT]<sendMsgToChip>: write 'VD_AUTO_CONNECT_STOP_TIMER#' into /dev/ttyS1

00000000000000482027   bt 7  [BT]<btMessageHandler>: <BT_CMD_CONNECT_REQ>auto-connect is turn off

00000000000000482485   bt 7  [BT]<btProcessUartMessage>:VD_SLC_CONNECT_RES Fail Status:4

00000000000000482486   bt 7  [BT]<btRespClient>: Message= CMD_CONNECT_RESPONSE_ASYNC, status= 0

00000000000000482489   bt 7  [BT]<btProcessUartMessage>: <VD_SLC_CONNECT_RES>auto-connect is turn on

00000000000000482490   bt 7  [BT]<sendMsgToChip>: write 'VD_AUTO_CONNECT_START_TIMER:15#' into /dev/ttyS1

00000000000000482491   bt 7  [BT]<btMessageHandler>: Message = REGISTER_HISTORY_DEVICE_REQ_ASY

00000000000000482794   bt 7  [BT]<btMessageHandler>: Message = CMD_FIRMWATE_VERSION_REQUEST

00000000000000482795   bt 7  [BT]<btRespClient>: Message= CMD_FIRMWATE_VERSION_RESPONSE, status= 0

Everyone's tags (2)
Cisco Employee

SPA525G2 Plantronics Voyager UC V2 Bluetooth Failure

Hi Brook;

Quick question, which BT mode you have the SPA525G set to? (phone, headset, both)...try setting it to headset.

Please note the phone supports just one BT device at a time, i.e. headset or phone, not both.




SPA525G2 Plantronics Voyager UC V2 Bluetooth Failure

The Voyager UC V2 is Plantronics newest, best selling hands-free headset.

The Cisco SPA525G2 is Cisco's best sellign VOIP phone.

The Plantronics headset will not pair with any Cisco SPA525G2 with the 7.4.8 firmware.

The only compatable Cisco SPA525G2 firmware we have discovered is 7.4.7.

We would be greatful if you could fix this in the next update.



SPA525G2 Plantronics Voyager UC V2 Bluetooth Failure

I believe I saw that there is a 7.4.9 firmware out for the SPA525G/G2 that also includes a Bluetooth firmware update as well.  I cannot speak to what impact that will have, just pointing it out.


SPA525G2 Plantronics Voyager UC V2 Bluetooth Failure


Thanks for the heads up.

I just saw the 7.4.9-bt update after I posted and have applied the update via the phone's GUI.

The 7.4.9-bt firmware does not resolve the issue. The same pairing issues remain.


SPA525G2 Plantronics Voyager UC V2 Bluetooth Failure

Now I am stuck with Bluetooth formware Ver 0.34 that came with Phone firmware Ver 7.4.9 and I can roll the phoen firmware back, but not the bluetooth. Ugh.


SPA525G2 Plantronics Voyager UC V2 Bluetooth Failure

Updated to firmware 7.4.9C and still cannot pair.

Cisco, can you please fix this?

Im going to try to downgrade to an earlier Bluetooth version on the SPA525G2 if it will allow it - back to a Bluetooth version that works.