cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
822
Views
0
Helpful
26
Replies
Highlighted
Beginner

SPA525G2 Wireless Call Quality Issues

I have two SPA525G2's in my office.  One is at my desk and connected directly to my WIFI router using the LAN port, the other is at another desk using WIFI only.  The WIFI unit indicates it has a full signal, its probably 5 foot away from the wireless router if that, i can hear the callers fine but they say i sound very choppy.

On the Cisco/Linksys E6400 wifi router i have QOS turned on for both MAC ID's of both phones. I have no issues with the hard wired phone, is there some setting im missing on the phone that is wireless or any tricks anyone knows to make the call quality better?

I have a 80/5 internet connection so its not a bandwidth issue, only a couple computers doing light web browsing.

Any ideas?

Thanks

26 REPLIES 26
Highlighted
Hall of Fame Master

Wrong forum post in "small business voice - SPA phones". You can move your post using the actions panel on the right.

Highlighted

Thanks, just moved it!

Highlighted
Beginner

exact same issue , SPA525G2 with 7.5.7s update , I'm using this phone in multiple office locations with different wifi routers and different internet providers, I have about total of 10 spa525g2 phones with the same issue across all locations ;

 using this phone over network cable - HD clear conversation using my freePBX Asterisk (Ver. 11.5.1) and ulaw codec but  as soon as I switch same phone same moment to wifi only connection - VERY choppy voice almost to the point I cant hear anything !

 

2 years + and not fixed by Cisco ?

Highlighted

I see no way to fix. According description it's wireless-related issue. It may be matter of wireless signal itself or matter of the phone's processing of wireless signal. It need to be decided. But no data allowing analysis of the issue has been provided. Thus no way to fix ...

 

Highlighted

I can provide all details needed since I have same issue for the past 12 months across all FW and different Hardware Versions of SPA525G2 - its so simple for Cisco - just take one new SPA525G2 phone and try to connect it to any wifi router in my case I'm using it with ASUS RT-AC66U, also multiple different Netgear routers.

Its so obvious same phone over Wifi chopped sound with ZERO devices using same wifi band ( i did this control test) , next minute connected with network cable to the same router -- HD quality voice.

 

If cicso need more details/files/profiles -  I'm wiling  to provide all details, I will reply with my phone /email and details about my environment if needed.

 

Its a shame that the only SPA wifi phone available from CISCO and advertised by CISCO as being wifi ready - not working with WIFI - yes it does connect to WIFI but whats the point if you cant use it; I been struggling with this issue for the past 12 months since day one and waiting for CISCO to address/resolve this issue by FW updates 

 

We need some resolution on this by Cisco !

Thanks 

 

Highlighted

It seems you missed there's volunteers forum only. Although some volunteers may be Cisco emplyee at the same time, here you are not speaking with Cisco. If you wish to create trouble ticked you need to call SMB support center.

But back to the matter - issue reported two times during two years ? It doesn't sound like that any user connecting their SPA525G2 to any wireless router is affected by the issue.

SIP/RTP audio streams are sensitive to network issues. Either so high jitter or even low packet lost will deteriorate the audio quality.

If you wish for help here then catch all packets related to an affected call. Including the RTP audio packets. If the captured file will reveal no network issue then we can assume it's phone's issue.

 

Highlighted

Thanks Dan,

just captured 1-2 minutes of my conversation (attached) using my SPA525G2 phone (ip.addr == 192.168.1.143 (1c:1d:86:02:2c:ca))connected  to my ASUS RT-AC66U router over 2.4 band open-Wifi (2 feet away), my friend were c/o broken voice ( not to the point they cant understand me but enough to complain about it), after that few minutes later I switched to another SPA525G2 phone connected to the same router with Cat5e cable - and clear conversation from the start.

 

PS: I can replicate this issue in 3 different locations with 3 different routers and 3 different internet providers.

wire-shark we running on my Win 8.1 wifi connected Laptop ip.addr == 192.168.1.154

 

Thanks Mike

 
 
Highlighted

From the file you provided I extracted the packets send from/to SPA525G2 phone only. E.g. packets from/to MAC 1c:1d:86:02:2c:ca.

It is 162 packets - few LLDP messages, one ARP, the rest is HTTP request/response related to phone's status page. Despite the status page disclose there's connected call, you captured neither SIP nor RTP stream related to call.

Thus no data related to call to analyze.

I can replicate this issue in 3 different locations with 3 different routers and 3 different internet providers.

I'm almost sure the issue is unrelated to provider.

It's "wireless media" related, based on my experience and information you provided.

Most of wireless network have issues - because of signal reflections, noise (including those caused by WiFi operated by someone else and those caused by Bluetooth devices running near), complex area topology (so shared access to band doesn't work well). Short distance from peer doesn't eliminate those issue, sometime it make them worse.

It's rather rare to see WiFi network with no issues. Also note that Bluetooth operate on 2.4GHz as well as WiFi, thus Bluetooth devices active near WiFi devices may affect their operations.

Even in your short capture file I see a lot of duplicated/out-of-order packets. Although I don't know what caused those irregularities in your particular case, it's evident they are there. RTP streams are very sensitive to it.

It's no time for final decision yet, but the issues you are describing ARE caused by noised WiFi most of times. According live stream distribution, the WiFi is rather "can be used for" than "good for".

 

Highlighted

Agree that wifi kind of not the most stable environment for data/time sensitive applications , but in one of our hospitals we use other Cisco the only wifi portable phone (don't remember model but it's small pocket size with battery) and those phones work pretty consistent with no broken voice in a heavy wifi environment. 

I bet if Cisco would troubleshot this issue they could easily find solution with easy fw update. 

 

For some reason I could not capture any sip data 

 

Highlighted

May be Cisco could easily find solution, but I'm pretty sure they will not even attempt.

Linksys division is gone, you know. As well as good support provided to public community. Core Cisco no longer speaks with user's community about this product line. And never comments problem reports here.

In advance, you are unable to provide even most basic information required. No debug logs, no SIP session captured, even we know nothing about audio codec used. Just somewhat fuzzy claim  "dissatisfied with sound quality if connected over wireless".

Unless you reported the issue to dedicated support center you should not bet on solution. In advance, unless you can provide detailed information related to the issue in question you should not bet on solution even if you will report to dedicated support center.

Experts in this community will not provide updated firmware to you, but they may found an acceptable workaround. But no hats here so I can't promise you will receive good advice even if you will provide information for analysis.

So consider further steps.

 

Highlighted

using ulaw codes as the only one under freePBX Asterisk 11.5.1

 

attaching few config screens from one of my wifi connected spa525g2

for some reason wire-shark not capturing SIP packet not sure if I'm doing something wrong??? using open wifi with zero inscription, running wireshark from Win 8.1 in prom. mode 

 

would gladly provide basic logs, just not sure how to generate it and from which part of the system: router, phone, pbx ?

 

Thanks for your help Dan

mike

Highlighted

for some reason wire-shark not capturing SIP packet not sure if I'm doing something wrong???

It may be matter of LAN topology and equipment used. It may require specific configuration to be able to capture other's data. With so cheap (read: dumb) network equipment you may be unable to capture them at all.

Ask network administrator of your's local network for help. He is familiar with topology and equipment you have.

just not sure how to generate it

Set Debug Level to maximum. Set Syslog Server and Debug Server to IP address of a computer and capture messages on it.

Highlighted

ok... just installed and activated capture on my router using:

tcpdump -i eth1 udp portrange 5060-5062 or udp portrange 10500-11652 -s 0 -w /home/capture5

20 sec capture5


tcpdump -i eth1 udp portrange 5060-5062 or udp portrange 1-11652 -s 0 -w /home/capture6

1-2 min capture6

Highlighted

There are two calls in capture5 - the outgoing Call-ID: 1fdbbea-e501dcb4@192.168.1.143 started in packet 16 and the incoming Call-ID: 382259c556a22cba73a8acf812c1d386@205.204.83.3:5060 started in packet 109 and one call in capture6 - the outgoing Call-ID: 314a4bce-bcdb132c@192.168.1.143 started in packet 62

Unfortunately RTP packets (e.g. those carrying the audio stream) are not captured. Phone is using UDP ports 16384-16482 (as configured in RTP Port Min, RTP Port Max), I don't know what range the Asterisk is using, for first call it has used port 14298, for second call it has used 17104 and for the third one 16940 has been used.

You should tune tcpdump filter to catch RTP as well. Consider just 'host 192.168.1.143 or host 205.204.83.3' and give tcpdump a second try.

But before it set (on SIP tab) "Stats In Bye"  to Yes and "RTP Packet Size" to 0.020.

 

Just for sure - please note that anyone can listen the content of call once the dump will be posted here. Also called and calling numbers are disclosed as well as proxy address and auth name (but no password).

 

As the capture5/capture6 has been used to tune tcpdump filter only and have little or no value for future readers you may consider to remove them.